Volumio for PI 1.2 Feeback thread

Is it necessary to edit /etc/modules in this new version when using with hifiberry DAC?

Hi all!

Everything works fine now with wifi. Purchased Edimax EW-7811Un today and just tried it. The former used Logilink Wifi dongle doesn’t work properly with V1.2. In V1.1 it worked very well. That’s too complicated for me. I just can’t imagine the reason.

Fact is, that when using Edimax EW-7811Un everything is all right with wlan connection in V1.2. Now I’ve messed up a lot here for nothing- sorry for that.

But generally it would be good to have more flexibility with Wifi dongles. The logilink Type I used is known to be easy to install 'cause of implemented
ralink 5370 chipset where driver issues are usually no problem. So I never had problems with it- 'till V1.2.

Mmm… I think is not related… But I have an idea… If you can launch commands via ssh, you could try this:

ifdown wlan0

ifup wlan0

From an ethernet connection, while you are also connected via wi-fi. Please paste the outputs… And, which dongle are you using?

No, just activate i2s, via settings. And reboot!

After several hours of testing I can say almost everything runs well. With EDIMAX- dongle wlan works in any case.

Is it only my imagination or does version 1.2 sound better now?

Only one worrying thing: If I stop playing tracks or radio for a longer time it is very hard to get connection again. Better via PC but via smartphone very hard till impossible. Wifi dongle seems to fall asleep.

Tried several fixes but playing via MPD using USB DAC has bad crackling throughout. Using Airplay is absolutely fine.

I’ve read PulseAudio as a solution, could that possibly work - dbader.org/blog/crackle-free-aud … pulseaudio

edit: After reading as much about this as I could find on here, I wiped and started again. The first I did was apt-get update, apt-get install rpi-update, sudo apt-get rpi-update. Not sure if it’s the reason for it working, but it seems ok now.

My Volumio setup stopped working after 1.2 upgrade, namely the wireless. Using: tenda.cn/tendacn/Product/sho … ductid=385

Installed wicd-curses. Can scan for wireless networks, but wlan “not ready”.
Seems like wlan adaptor can’t get an IP address from DHCP. Tried to setup security when connected with eth0. Didn’t work.

In wicd-curses shows the eth0 gets an IP via DHCP.

Going to try a OnNetwork wlan adaptor tonight. It’s what I have at work.



Following my previous post, I am afraid that I am now experiencing WiFi issues too. The wifi simply drops out every now and then. I have same Edimax dongle as you, Michaelangelo. It is connceted via a powered hub. Music simply stops playing then, about a minute later, I get a couple of brief bursts of music and then nothing. I am unable to connect via ssh either when this happens.
To sort it out, I have to reboot the pi, then restart mpd. On doing so it carries on from where it left off.
I have had something similar before with 1.1 when I tried to run the wifi dongle directly from the pi without using a powered hub.
Sorry, no solutions from me. Still love Volumio, though!

After testing several more hours I can say that the one and only problem stays: in wireless connection I lose contact to volumio from time to time, especially when left music playing for a longer time, even worse when I stop music and want to continue after a while- then it’s often very hard to get connection to volumio again- have to call IP adress felt 20 times to awake wifi dongle.
Music dropouts I didn’t discover.
Everything else works fine so far after I’ve changed to edimax.
Moreover I’m shure now that 1.2 sounds even better than previous version.

OnNetworks wlan dongle did not work either.

Just got the HiBerry in the mail. Must go back to previous version.


I appear to have the same problem as everyone else with 1.2B…
I’m using a Wi-Pi adaptor which is plugged directly into the Pi (this works for everything else I use Pis for). Connecting only works when I first connect with wired ethernet. I can then set up wireless, and it then work on wireless until I power off, after which I need the wired connection to set up wireless again.
Where are you storing the wireless setup info? It hasn’t been moved to the volatile temp storage by chance?

I have been fortunate that I was able to get an ethernet over power line adaptor working so that I could set up the volumio player in my 11YO son’s room… he was tormenting me about getting it going again!

My Setup is: RPI, WiPi dongle, (temporary ethernet powerline adaptor), hifiberry DAC. (Music on NAS).


I had quite a bit of trouble getting my NAS to work. I have a Western Digital USB MyBook attached to a TP-LInk TL-WR1043ND router. When I click on SAVE MOUNT, my browser status says “Waiting for…” and the GUI says “CONNECTING…” It stays this way for more than 10 minutes. I rebooted several times, trying different mount settings until I found one that worked. With the “perfect” settings (ro,sec=none,nounix) the browser reconnects immediately after the SAVE MOUNT. Unfortunately, I can not play any music files. The console shows:
Transfer to device 6 endpoint 0x1 failed - FIQ reported NYET. Data may have been lost.
Transfer to device 6 endpoint 0x2 failed - FIQ reported NYET. Data may have been lost.

My configuration is: RPi model B, 8 GB class 10 SD card, wired Ethernet, headphone output, HDMI monitor
The previous Beta1.2 works except for stuttering during music playback.

Can you navigate to your NAS on the pi using ssh and see music?


The messages:

Transfer to device 6 endpoint 0x1 failed - FIQ reported NYET. Data may have been lost. Transfer to device 6 endpoint 0x2 failed - FIQ reported NYET. Data may have been lost.

possibly have to do with the latest firmware. They do not have to do with your NAS and they appear on dmesg after a pop or click from my experience.

I get the “Transfer to…” error messages continuously while trying to play music, about one message per second. If I press the stop button in the Volumio GUI, the error messages stop. I understand that it may be a firmware problem, but it only happens when trying to play music so it does seem to be Volumio-related.

Also once every 10 to 15 seconds I get:
dwc_otg_hcd_handle_hc_fsm: 10 callbacks suppressed

Yes, I can see some of the music directories on my NAS. I know this is a drastic step, but I decided to update the firmware to see how Volumio Beta1.2 would work with the latest version. I used rpi-update to upgrade the firmware to 3.10.33+ #654. I can now play music from my NAS and I haven’t heard any stuttering of the output from the headphone jack. I switched from wired Ethernet to a USB WiFi adapter and that also works fine. I do not see any error messages on the console.

The only problem I see now is that not all the NAS music directories are listed. I used the UPDATE MPD DATABASE function and let it run overnight, but Volumio lists only the first 142 artist directories (up to the first artist that starts with the letter E).

Sorry if I’m a little confused…

I get that you can only see some of your music using the volumio web interface (142 up to E must be quite a large collection…).
If you ssh into the Pi, and navigate to your NAS mount point using the command line (/mnt/NAS/your mount name) can you see all of your music files?

I only have of the order of 300cds ripped at this stage, and I wonder if you have a NAS mount problem, or the size of your library is causing a problem.
If you can’t see the music files under the /mnt/NAS… directory, then volumio can’t either.


Sorry that my reply was confusing. You are correct - if I use ssh and list the Volumio NAS directories, I can only see 142 directories. And of course you’re right - if ls can’t see the directories, then Volumio can’t see them either.

I just tried to manually mount the same NAS directory and give the mount point a different name. I can see all the music directories. I had trouble getting anything to mount with the latest Beta 1.2 and I thought I had it figured out. Apparently not. I will try some other mount flags tomorrow to see if I can get the full directory tree under Volumio. Just for reference, once I got the NAS mount to work in the earlier Beta 1.2 I could see all the directories so I thought the problem was related to the new Beta 1.2.

Thanks for helping me try to get to the bottom of this.

Downloaded and installed the image yesterday.
It starts okay, but sound has a lot of pops and clicks and distortions - it did not happen when I used RaspyFi… I play mostly FLAC from external NFS share, and I use external USB->SPDIF converter based on TAS1020B and fastest downsampling to 44.1/16 bit. Hardware is regular RPi 2.0. with 512M RAM

I had the same problem so wiped and started again. I installed and ran rpi-update straight after install and it was fine. It might be a coincidence so I can’t say it’ll definitely work.

sudo apt-get update sudo apt-get install rpi-update sudo apt-get rpi-update