Volumio for PI 1.2 Feeback thread

Could you explain better what did you changed? It is set as default as dhcp…

I added this, because on some cards the power management was causing the wi-fi adapter to disconnect after some idle time. The settings are stored on a sql database, located @ /var/www/db/player

@lagna, yes still on ext3

Reverted back to 1.1. No issues. Works fine again.

What distro release is 1.2 on? Seems something is very wrong with how it handles wlan on startup. Exhausted my linux knowledge and simply does not work without a lot of startup hackery. Will be interesting to see what comes of it as the release was very solid in terms of the volumio mpd portion.

I’ve been investigating all day this. On wireless, it connetcs, but cannot obtain an IP address… This is a DHCP issue… Quite annoying as a bug!

Ok, got my results. Prepare to laugh :smiley:

I have 2 Pis. On both of them I have other devices attached, like an i2s dac or a OLED monitor.

Tried all day. Updated all the hell of packages, changed configs, and stuff like that. Then, desperate I removed all the device attached. Then it suddenly worked.
Furhtermore, on one Pi I have a linear PSU. On this Pi, 1.2 wi-fi didn’t worked, until I changed PSU with another one.

So, I can confirm that wireless works, at least for me. I’m using the Edimax EW-7811Un.

Can I have more feedbacks? Some of you who have wi-fi working?

Please mind, that at first boot the worker needs quite some time to start, so make sure you hit ctrl+f5 two times, before configuring wi-fi. For people that cannot get their dongles working, could you please paste the output of

ifconfig -a

Let me know guys, bye bye sunday :smiley: :smiley:

I installed 1.2 yesterday and I have just spent the last 3 hours listening to some good sounds. I have a pi with a usb dac. I am also using an Edimax 7811un wifi dongle accessing my mp3s on a windows desktop.
I set the wifi up via the gui whilst connected via ethernet. I found with 1.1 that I frequently had to restart mpd, but this doesn’t appear to be the case with 1.2.
Yesterday I had the wifi dropped out completely twice, but it has been great today. If problem comes back I will investigate.
Thanks for a great package.

First, I haven’t tested 1.2 but I wanted to correlate the Wifi problems with a thread that was on the forum here earlier about manually updating volumio.

See this post: solution-pops-and-clicks-t772.html#p2932

That’s my reply, but in the original thread it discussed updating the base RPI via apt-get/upgrade, etc.

Based on everyone’s wifi findings here, it likely has something to do with a newer Pi build? In my personal case my wifi did finally connect, but it took several minutes and even then it was spotty. Once my wifi was connected my NAS never came up. It was too late at night to properly debug but it seemed like the NAS tried to mount early on, no wifi, so failed. Then wifi came up later -but the NAS never tries to remount once the wifi is up.

There’s something fishy about the latest RPI builds perhaps?

Hi all!

When I first startet version 1.2 with ethernet and wifi dongle connected wifi worked after rebooting . Then I powered down, disconnected ethernet and connected a usb stick with music data in addition. After that it didn’t work. Then I reconnected ethernet, made the wifi configuration on webUi again- reboot and it worked.

I now will make the changes recommended in the thread and report again. Sleepless anyway.


Addition: I do not connect DAC via USB because I use a RME fireface and this one doesn’t support linux connection in any way. So I always use HDMI- Output with a Ligawo HDMI to coaxial or toslink audio extractor before connecting to RME DAC through coaxial or toslink plug. Both devices PI and Ligawo converter are each powered by strong batteries. So no power issues in this case.

So, now I have finished some more experiments. In my configuration the problem is: When I have ethernet and wlan connected first I of course have to setup wifi for the first time- then I have to reboot- and wlan works- every time I reboot it works also from then. The problem is: When I power down- disconnect PSU and power up again- wlan doesn’t work.

Then I have to connect ethernet again and repeat wifi setup.

When I disconnect ethernet cable while pi is running and I do reboot afterwards, wlan is running without ethernet cable plugged. then I can reboot as often I want, wlan is always working again without ethernet connection.

When I power down and start again, wlan is lost- then I have to plug ethernet cable again and wifi setup has to be repeated. Then reboot and it works again.

I have deleted ‘wireless-power off’ in /etc/network/interfaces. No success. I recognized, that, everytime wifi setup has to be done again, the line is recreated.

Sorry for lacking coding skills, but from this point I stuck.
I didn’t understand the thing with ‘iwconfig’ and ‘ifconfig -a’. I wasn’t able to paste anything in the lines then showed :blush: As I mentioned- no coding skills.

As an additional info: With Version 1.1 connections worked fine- so no dongle issue. I even brought direct connection between pi and smartphone to life via wifi setup and phone’s hotspot configurations set.

But maybe the experience I’ve made helps.


Thank you for the reports! Please mind that on just wi-fi, the boot needs quite lot more time to start… I’ll dig again into that, lol!

I’ve kept that in mind, I had let extra long time pass before I proceeded with trials to achieve proper booting.
Just one more thing. I’ve set all my router IP’s to static inside the routerdevice to avoid changing addresses. That worked good for me with volumio 1.1. So I was able to set my changings in volumio that I’ve done before to default again (static IP Addresses back to DHCP in both cases ethernet and wlan).
This router settings I’ve kept also during the trials with version 1.2.

After a breakfast- test of V. 1.2 with ethernet connected I haven’t discovered any more bugs. Seems to work very well. It’s faster and the clicks between tracks when skipping disappeared. So there’s only the wlan thing left.

Thanx for the great work!


First time user of Volumio (RaspyFi). So it’s was a really exciting morning to me :wink:
I was dreaming about such solution! It’s great!

so. atm no DAC, no Amp just raspbery pi and headphones
Pros :

  • UI very intuitive and 5 mins were more then I needed to connect my NAT ( somehow it didn’t required my domain name, which wasn’t default - wasn’t expecting that )

Cons :

  • had to unplug my HDMI and reboot in order to start listening what’s playing… but that’s kind standard thing when you are dealing with raspberry pi. so it’s not really a con… but IMHO there could be a nice shiny button for that in UI.
  • didn’t know about that “STOP playing before reboot” thing… so was a bit worried for a moment… There could be some note or maybe some top tips dialog for first time users… dunno. easy fix again.
    ( as previous two are something one can google out and fix. but the following… )
    I felt it is not as stable as you would expect…
  • WEBRADIO , USB , NAT kept disappearing from “Browse” menu. :question:
  • Some issues when clicked “Add and play” - it just didn’t do anything… ( MAYBE it’s because of stupid DNS server we have and the fact that I’ve tried controlling it from few browsers at the same time. eg. chrome on my linux machine would have “Browse” menu empty, but chrome on android device would work very well at the same time. ) :question:

we will see how it goes after few days of listening.

So. It’s fine if you let it play nice playlist or some station. A calm /etc/init.d/mpd stop; reboot; go - helps in situations like that…
I believe it’s just a matter of time until OS gets stabilised or it’s a matter of time until I figure out what’s what…

HAPPPY! :wink:

Getting errors trying to install cifs-utils that I didn’t get on 1.1. This is the only way I can mount my NAS (would be nice if this way of mounting could be built into the GUI!).

volumio@volumio:~$ sudo apt-get install cifs-utils Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed: keyutils libnss-winbind libpam-winbind winbind Suggested packages: smbclient The following NEW packages will be installed: cifs-utils keyutils libnss-winbind libpam-winbind winbind 0 upgraded, 5 newly installed, 0 to remove and 2 not upgraded. Need to get 2,794 kB of archives. After this operation, 13.4 MB of additional disk space will be used. Do you want to continue [Y/n]? y Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main winbind armhf 2:3 .6.6-6+deb7u2 [2,120 kB] Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main winbind armhf 2:3.6.6-6+deb7u2 [2,120 k B] Get:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libnss-winbind armhf 2:3.6.6-6+deb7u2 [ 473 kB] Get:4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libpam-winbind armhf 2:3.6.6-6+deb7u2 [ 97.3 kB] Get:5 http://mirrordirector.raspbian.org/raspbian/ wheezy/main cifs-utils armhf 2:5.5-1 [70.1 kB] Get:6 http://mirrordirector.raspbian.org/raspbian/ wheezy/main keyutils armhf 1.5.5-3 [33.3 kB] Fetched 1,036 kB in 2min 18s (7,473 B/s) Selecting previously unselected package winbind. (Reading database ... 34155 files and directories currently installed.) Unpacking winbind (from .../winbind_2%3a3.6.6-6+deb7u2_armhf.deb) ... Selecting previously unselected package libnss-winbind:armhf. Unpacking libnss-winbind:armhf (from .../libnss-winbind_2%3a3.6.6-6+deb7u2_armhf.deb) ... Selecting previously unselected package libpam-winbind:armhf. Unpacking libpam-winbind:armhf (from .../libpam-winbind_2%3a3.6.6-6+deb7u2_armhf.deb) ... Selecting previously unselected package cifs-utils. Unpacking cifs-utils (from .../cifs-utils_2%3a5.5-1_armhf.deb) ... Selecting previously unselected package keyutils. Unpacking keyutils (from .../keyutils_1.5.5-3_armhf.deb) ... Setting up winbind (2:3.6.6-6+deb7u2) ... insserv: warning: script 'K02shairport' missing LSB tags and overrides insserv: warning: script 'shairport' missing LSB tags and overrides [ ok ] Starting the Winbind daemon: winbind. Setting up libnss-winbind:armhf (2:3.6.6-6+deb7u2) ... Setting up libpam-winbind:armhf (2:3.6.6-6+deb7u2) ... Setting up cifs-utils (2:5.5-1) ... Setting up keyutils (1.5.5-3) ... localepurge: Disk space freed in /usr/share/locale: 0 KiB du: cannot access `/usr/share/man/sr/man1': Input/output error find: `/usr/share/man/sr/man1': Input/output error E: Problem executing scripts DPkg::Post-Invoke 'if [ -x /usr/sbin/localepurge ] && [ $(ps w -p $PPID | egrep -c '(remove|purge)') != 1 ]; then /usr/sbin/localepurge; else exit 0; fi' E: Sub-process returned an error code


it sounds like your storage is bad…
Maybe a corrupt SD Card:

Input/output error

Did you try another card?


Not sure if that’s for me, but if so I’m just about to try another card now. :slight_smile:

I removed manuals to save space…

try with

mkdir /usr/share/man/sr/man1

Seems to have worked, thanks.

Got a very bad problem with flac files now though. Using a USB DAC (UD110v2) and it’s great when playing mp3 files. If I try a flac file it pops and clicks every few seconds, then after I stop the track I can’t connect to Volumio without unplugging the power cable. As soon as I press the stop button the browser says “connecting” and just stays that way.

I’ve reverted back to the previous v 1.2beta (I used the patch to repair the UI)

This latest version would sometimes just stop playing. Sometimes it would be for 10 seconds, other times for a period too long to continue waiting! I think there were skips too in this version (I’m only using 16/44 files).

I’m using Ethernet rather than WiFi.

Hi Michelangelo!

I have now maybe a stupid question on wifi problem: You have written in the blog that you realized logging via RAM when I understand this right. Is it then possible, that when only rebooting is initiated after wifi setup RAM is not cleared depending on PSU characteristics? You said, that you 've made different experiences with another PSU. Some PSUs I recognized to deliver still current for some seconds after plugging of probably because of still loaded elkos. Maybe thats the reason why I have working wlan after only rebooting. After powering down, off plugging PSU and powering up again there is enough time for RAM to clear so that the setup info from before is no more available and I have to do wifi setup again.

This is only an idea and might be complete nonsense.