Volumio for PI 1.2 Feeback thread

A new image of Volumio for Rasberry Pi has been released, the news are described here:

Since this is a really experimental version, I really would like to know your feedbacks, like what doesn’t work and what is improved since the 1.1 version. Thank you!

First off - Thanks for the update. Long awaited :slight_smile:

Positives -

  • Web GUI loads much faster
  • Database updating happens faster or atleast the progress shows up faster in the Web GUI
  • Installed squeeze player and works like a charm

Bugs -

  • No sounds comes when using it as MPD player. Track plays, but no output ( via web gui or Sound@home app ). Same goes for Radio
  • Airplay works but it stops and plays ( looks like it is trying to buffer )

Thanks for all the hard work :smiley:

Hardware used - M2tech Hiface II, Lan connection, Rpi Model 2

Great application, Michelangelo. Thanks a lot!

Here are some issues I have found with beta 1.2 (RPI, Volumio beta 1.2, USB DAC with CM6631A, USB Wifi, external power supply, all connected together before power on, web access through MS WIn 7 IE8 and Chrome):

  • I can’t connect using wifi only for the first time. I was scanning IP adresses in my network byt Volumio wasn’t connected. So I needed to connect using Ethernet, configure Wifi and I can unplug Ethernet then. Even after restart I can use wifi only now
  • I still have an issue with USB DAC (CM6631A driver). Volumio web interface only offers ALSA. I need to reboot it and I can see audio (USB output them)
  • I can’t connect to Web GUI with Wifi connection only - I need to do SSH, restart MPD - /etc/init.d/mpd restart and I can connect via web GUI then. However if I have ethernet cable connected I can get to web GUI without any issues

If I remember correctly I have seen these 3 issues with beta 1.1 as well.

If I do all above steps it works very fine but I can´t power of RPI. Otherwise I need to always restart MPD to have web gui available and reboot volumio to see my USB DAC.

I’m using Ethernet not WiFi, but no problems so far.

It works fine for me using mpdroid.

I use it with es9023 dac connected to i2s and i don’t have any issue’s so far, everything went fine

Sent from my Nexus 4 using Tapatalk

I confirm it very stable with excellent reproduction of 24/96 flacs using samba.

Unfortunately, I still get pops while listening to 192/24 FLACs on Cambridge Audio DacMagic 100.

Hardware connected to my Pi during playback:

  • DAC
  • network cable

Hi there. Just registered to let you guys know that /var/log/php_errors.log is filling up the sdcard in 1.2beta. It also happens if you do an “apt-get upgrade” on 1.1. I think php5 has been recently updated and causes this. I don’t know php, so i can’t help with a fix!

Yes, it has been updated! Thanks for this report, I’ll investigate that!

Today, version 1.2 is installed, use (item.taobao.com/item.htm?spm=a1z … 5269012142) This es9023 board i2s connection skins, sounds good, faster than the 1.1 start version of the fast, smooth to operate than the original, thanks developers Michelangelo.

I have the RPi connected via P5 to a Buffalo DAC. It looks like it works faster and smoother than the previous release, but I still get horrible pops between one track and the other. I tried the CFix, but with no improvement.

Any suggestion what to work on to make some tests ?



Thanks Michelangelo for updating this great development!

I’ve tried it out today, but unfortunately after unplugging ethernet cable, I do not get connection through wifi anymore, wlan does not work.
With version 1.1 this problem doesn’t occure. Has anybody made similar experience and are there any hints to get a solution?

I’ll give it some more starts now, maybe I’m lucky :wink:


Does not work over wifi at all without having ethernet connectivity on boot.

wifi config does not see existing setup.

Wasted my weekend. No music. Don’t feel like going back to 1.0 tonight.

Warning - wifi users - do not upgrade to 1.2.

Hope this helps folks who “brick” their Volumio with the latest release.

Old versions are here: sourceforge.net/projects/volumio … erry%20PI/

Author does not have links on this site to the older versions. Hope this helps.

Thanks for reporting I’m investigating wi-fi issue now. Just less polemics, please

While I’m investigating this, could you guys please try to remove the line

wireless-power off



Let me know if this solves!

Hi -

The power save setting does not help. I notice the in app setup adds that. I usually setup my wifi manually on PI’s. It seems the UI and the backend is doing something on startup as it works but then drops out on a reboot. Where does volumio store its internal configs? It does seem to read the system settings for wifi consistently?


Is 1.2 still using ext3/4?

this version is quite a lot better than 1.1 probably because so far i have yet heard any crack noise playing music.
the web interface is quite responsive and there is not sluggishness as in the previous version

one thing is that in my first installation, it was not able to recognize my DAC. also, i could not get the web interface up on browser after changing a few settings. it didnt help even on cold boot. I had to install it for the second time in order to bring the web interface up and this time, it could see my DAC.

Just an update: playing 16/44 material is fine with no crack noise. However, it is not the case playing 24/96 music files. Occasional cracks noise does appear but less frequent than version 1.1

Hi All,

With respect to the Wifi issue, I had issue with Wifi without Ethernet coupled, not connecting. I then changed my IP Wifi setting in “/Interfaces” from static into DHCP, and it works!

Also had issue with connecting with the NAS, but could solve it with the MKDIR-statements of Onholysmoke (thanks)

No other tweaks.

Having done that, it just works GREAT! No clicks and most of all, no echo anymore with piano or guitar. Man, I am happy with this.