Volumio for PC + Fujitsu Futro S450

Hello to everyone,
I’m trying to install Volumio on this Thin Client. I’ve already installed the Volumio’s image on the compact flash of the Futro,but when I turn it on it seems to hang just after the BIOS an it gives me back an error as attached.

I asked: does anyboy had experience with the Futro? Is it compatible with Volumio?

Thanks!!
Errore.jpg

I think that this is due to the fact that you installed that on the integrated memory and maybe we don’t have kernel modules loaded, probably Gé can help with that.
In any case, how much RAM does it have?
Please flash Volumio to a USB key and see if it boots from there…

Hi,

yes, this looks like a problem we’ve seen before. It cannot access the boot disk, as Michelangelo wrote, probably due to a missing kernel module.
Whether I can help is yet to be seen, the difficulty is find out which module is missing. It worked for some, perhaps we can get this running too.
Did some googling for Futro S450, and will make a guess (actually a bit more than guess, but no guarantee).
I’ll send a link to a test version, I would be pleased it you could test that and report back.

-Gé-

@fuzzu: you have a PM.
Did you have Debian running on this with compact flash (CF Card, correct?) before?
In case you did and the test version does not work, you could still do something for us.
That would involve re-installing it on compact flash and upload the initrd image file, which you will find in /boot.
I could unpack it and check what ata/pata modules it has that we don’t.

-Gé-

Sorry, but unfortunatly I completly missed the answer on this forum, my fault, sorry for that…

For Michelangelo: the RAM is 1 Gb, I hadn’t tried to boot it from USB because I have some difficult to do it.
In a different way, I don’t know why but it seems that in the BIOS the option to boot from USB is missing. I’ve tried to ask to the Fujitsu assistance but hey couldn’t tell me the reason, for them it should be there.

For gkkpch: I tried to do what you suggest me, but I discover that I’m no longer able to install it: Windows not recognize me the compact flash anymore, he show me in the “menage disk” but he said it is not able to assign it a letter, the exact message is attached to this post.

I bought the futro used some time ago and left on a shelf for a quite long time, now I’m tring to understand if it worth it to try to make it work or if it is better to give up…

Thanks to all for the big help
Erroe.jpg

don’t give up, you might miss something :slight_smile:
Drop me a PM if you need any help…

Thanks, I’ll do It!!

Hey there,

I’m looking for a working solution for the futro s450. Any suggestions to install volumio in the internal cf card?

To start with, did you try this: https://volumio.org/forum/volumio-x86-install-hdd-t5058.html?

Also, there were quite a few changes since the OP, so please try the latest x86 version
It might not give you the ultimate volumio experience on an x86 yet (have not verified where we currently are release-wise), but that version should at least show whether those particular s450 boot problems have been improved, it is also the latest version functionality-wise (but may not have been tested completey)
Very curious to hear your feedback.

– Gé –