Volumio doesn't reconnect to Wifi / Can't reach it anymore via SSH

Hi all,

on beforehand, my system information:
Volumio Version: 2.873 (Kernel: 4.19.118-v7+)
Hardware: Raspberry Pi 3 Model B Rev 1.2 ( Version: a02082, Firmware Version: Apr 27 2020 14:35:17)
DAC: Pre Box S2 Digital (external, connected via USB)

The topic is pretty straight forward. If my network connection drops (router restart or similar), volumio does not reconnect to the the network. At least I cant find it in the DHCP Client list and i cant reach it via SSH (putty or WinSCP).
I use a static IP Adress and the Hotspotmode is deactivated. This problem does not occur, when connected via ethernet.

It tried different things, even an old plugin from @balbuze (link), but it does not seem to work for me.
I can put it “on” but it stays “inactive”.

Any ideas what to do here? I would be so happy. Thank you very much.

Kind regards
B.

PS: In the DHCP Client list from the router, I can identify volumio via it’s IP.
The name is “Unknown” although the device is named “volumio” in the settings. But this doesn’t have any impact right? I just found it strange…

I used to have this problem with wifi only Volumio devices. I never successfully found the cause, although spent a lot of time looking. I resorted to rebooting once a day (via a cron job), which seemed to work for my scenario. More recently, I run all my devices over a wired network, which seems to be far more stable.

Thanks for your answer.
Sadly, in this case its not possible to connect the raspberry via ethernet for normal operation. I wont drill through two walls in a rented flat :smiley:

This “used” to be fixed I guess, since there are several threads on this topics in the past.
Does anyone NOT have this problem and can share his setup?
Volumio Version, Raspberry Model and Version.
Maybe a older version of volumio does the trick for me until its fixed?

I’m getting the same problem. My Raspberry Pi 4B is connected wirelessly to a Google home mesh network. The volumio ‘server’ is configured with a static IP address and simply disappears without notice or warning. Like you, I don’t want to drill holes in walls just to connect a network cable.

I cannot see the device in the the Google Home wifi settings. Re-boot works for me - but Volumio will disappear again at some unpredictable point. My internet connection is (allegedly) strong - I get 500 mbps download speeds and have around 20 devices connected (most of which are idle). There are no stats for my router that suggests the network drops.

Mh, sounds bad as well. For my part, it mostly went along with network drops, but I’ll have an eye on it.
What I just tried is the following instruction: Rebooting the Raspberry Pi when it loses wireless connection | We Work We Play

I adapted the code a bit (the IP of my router and I changed the crontab period from five minutes to one minute. As of for now: System online for 2 hours, 1 drop “survived”. Lets see, if this is stable I’ll post more detailed “instructions”.

BUT: I think this is something, that could be included within the volumio system itself.

Isn’t this essentially what Balbuze’s plugin does/attempts to do? If it is, and you say the plugin is not working properly, then perhaps it could be updated/modified? I agree that it is a very simple check to do, but most people do not appear to have the problem, so perhaps a plugin is the best way to implement it.

Yes, I think this is the idea. The addon pings the google dns server, I ping my router - I guess that is a matter of taste. To your first answer: I power off the raspberry regularly at night, big power strip for the whole hifi system. Therefore “restart” won’t tackle the problem properly.

Up to now: Still online.

I just noticed, that after soft-reconnection, volumio disappered in the DHCP client list. I cant ping it anymore, can’t reach via SSH.
BUT: Its still reachable and responsive via WebUI and I still can connect via Spotify.

Thanks for participating, I’ll keep you updated.