Volumio doesn't find all my music. (SOLVED)

I am using Volumio 2,699 in a Raspberry pi 3B+, and I have put 11,050 songs, all with their complete tags and covers, on a pendrive USB, all with the same format and bitrate * .m4a.

When I scan the USB with volume, it tells me that it has found 10,795 songs. And of 2030 that there are albums only find 2002.

I have disconnected the USB, I have copied all the songs to /data/INTERNAL, I have rescanned again and it continues telling me that I only have 10,795 songs.

I have executed this and it does find all my music:

volumio@volumio:~$ cd /data/INTERNAL
volumio@volumio:/data/INTERNAL$ find . -name "*.m4a" -type f | wc -l
11050

Is there any way to see which albums you have found, or not, Volumio?

I have looked inside /var/log/volumio.log and I don’t detect any problems in the scans. Maybe because I don’t know what to look for.

Any idea? Any solution?

Thanks

No one has any idea?

Well, the problem has been solved in the most drastic way.

I have converted all my lossless m4a files to 320kbps mp3 and Volumio has recognized 11,050 songs without problems and much faster than m4a.

I guess it would be a compatibility issue, DRM or bagpipes of those… :smiley:

I am using Volumio 2,699 on Volumio Primo and have the same problem. No, I do not accept to apply a workaround and convert some file… Please fix this! A search reveals that this problem keeps popping and on 2.699 too, though there was a reply that this build solves this problem

I found the problem on my side. It was about file system permissions and ownership on the Synology NAS share. I have a share which requires a login via advanced options in Volumio. I did not suspect anything initially, but looking through /var/log/mpd.log revealed that “mpd” fails to access some folders. The problem did not occur under Windows 10 where the same share is mounted from the NAS. I had to fix the access and permissions directly on the command line on the NAS. Watching system logs with sudo journalctl -a as suggested on other threads did not help, since this information is not posted there.

Hello.
I have the same issue. Volumio does not find all my music in the /data/INTERNAL folder. I have no *m4a files… only FLAC and mp3.
I have consulted the logs, but there are no clues as to might be going wrong.
I have assigned ownership of all the folders and files within INTERNAL to mdp:audio. Folders have 775 permissions, and files have 644 at least.
Everything should be readable by mdp and the “audio group”, and folders are writable by the “audio group” (which includes users volumio and mpd).

Still, when I press “rescan” or “update” in “mymusic” under “settings”, music is not found.

What exactly happens when those buttons are pressed? What is the linux process (or volumio process) that is launched to perform the rescan of music? If I could launch the same process on the command line, I can investigate what is going wrong.

Thanks in advance,

Volumio uses MPD (musicpd.org) for quite some things, and for indexing of local music for sure. On your place, I would remove the library via the Volumio UI, start watching “/var/log/mpd.log”, e.g. die “tail -f /var/log/mpd.log”, and create the library again via the Volumio UI so that a new scan is reinitiated and you can see new messages in /var/log/mpd.log. If there will be no messages, I would try to increase the log level. I do not know an option for this in MPD, but I’m sure there is one. The configuration file for MPD in Volumio is /etc/mpd.conf

THanks for your quick answer. Yes… I know it is based on MPD to a large extent. INterestingly, I cannot find /etc/mpd.conf in my volumio system. and the file is nowhere else in the filesystem (I searched throughout /, not only /etc). That’s odd.

Does anyone know what mpd process or command is launched when we press “scan” or “update” in the UI? I have been monitoring running processes and I could not see anything being executed when those UI buttons are pressed.

Thank you,

Hello, same problem here, with flac musics in /data/INTERNAL
Refresh buttons in Source settings don’t solve the issue.
I use RPi Zero W with Volumio 2.834

thanks

Hello again,
I found the trick with more details, following the previous recommendations.
Reading in /var/log/mpd.log helped.
The files need the rights to read AND to exectue for all users.
Doing following command via SSH solved my issue:
chmod -R 775 /data/INTERNAL

bye