Volumio does not display all folders

Volumio 0.jpg Volumio recognizes the NAS and LMS.

With a click on LMS, then “artists”, the display stops in the middle of the “F”. And I do not see anything to go further (other page, for example).

With a click on “genre”, then “Blues rock” (for example), yet appear files beyond “F”.


It’s the same with another NAS and Macbook OSX.

Question: what to do to see all the files in the music directory, whether on NAS or LMS?

Same problem. USB HDD was formatted as NTFS. Linux does not work very well with NTFS. Threw the whole library and formatted in EXT4 and eventually got worse problems. Now Volumio synchronizes only one folder and 10 tracks…

I solved this problem with a *nix specialist. MPD is set up crooked. The Volumio distribution is very raw. Here is a verdict.

This seems to be a ‘permissions’ problem.
I had a similar problem. I had reformatted my external HDD with NTFS (I had decided to change the HDD from Ext4 format to NTFS for better Windows compatibility and ease of maintenance). I had re-loaded all the music folders and files from my PC. But, on the Pi 3+, only a few folders of the HDD were then being listed by Volumio.
To find a solution:

I put the disk back onto my PC;
clicked on the HDD disk’s folder in Windows Explorer;
in ‘Properties’, I set ALL the check boxes to ‘allow’ for both ‘Authenticated users’ and ‘Users’ for all permissions.
Volumio then found all the folders and worked properly after returning the HDD back to the Pi.