Volumio Debian Buster Beta - Raspi images debugging

Hello all friends!

I tested Volumio 3.0 and found that:
The operating system runs really well, and it’s fast, the sound seems pure.
Stores USB scan history
the big downside I see all volumio versions have is: the boot speed is very slow when the music files increase for example:
Hard drive contains 1T of music: boot speed is: 1 min 30 s. 2 Tb music: 2 minutes. This is bad, because I tried the Moodeaudio, it was very smart, it stored the first scan and the boot time was very fast, only 50 S, and regardless of the number of songs and hard drive space!

So can you handle this? ie the start-up speed is independent of the number of music files, and retains the first scan history ??
Thank you very much!

Hey @mac
What pi are you running this on?
This is a pet project that I would like to investigate - the slowdown during boot due to database scanning. It’s some quirk with the async code. However, I don’t really have a large music collection, as I mostly stream these days. So if you don’t mind - could you share your /var/lib/mpd/tag_cache (privately) with me? I’d like to play around a bit to see where the bottleneck is :slight_smile:


Hi ashthespy!

this 2 Mb off file: tag_cache.

when you have time you can see my Pi4??

How do I get it to boot quickly, without being affected by the size of the file: tag_cache.
And where is the starting speed specified?
Please just let me know!

Hi ashthespy!

I was test again Volumio 3.0 vs Moodeaudio 6.7.

1- aAbout boot time:
Volumio 3.0 : 55 s
Moodeaudio 6.7 : 46 s.

2- The music file : 2.2 T music off 4 T Hdd (WD)

I use 32G Micro SanDisk Extreme Pro for write Volumio and Moodeaudio on Pi 4- 4 G,
Ok - after I scan all music to Volumio 3.0 and Moodeaudio, so I test and I see:

1- Moodaudio boot time is still 46 s, with full scan music file, and play well when boot again- no need scan again .

2- Volumio 3.0 boot time go up 1 m 20 s, and some time , it run scan again Hdd,

So I ask you : why Moodeaudio is well with boot time and scan music file??

Why Volumio 3.0 is bad off time boot and scan music auto again?
Oh, Volumio have many many member can support !
Thank you advice
Best regards!

New build - new bugs features! :wink:
Raspberry Pi Volumio-3.014-2020-12-10-pi

  • myVolumio – (very alpha, please test!)
  • Bump to 5.4.79 kernel
  • Buster 10.6

Known issues:

  • Buster node packages have different binary locations, temp fix by symlinking:
sudo ln -s "$(which node)" /usr/local/bin/node
sudo ln -s "$(which npm)" /usr/local/bin/npm
sudo ln -s "$(which npm)" /bin/npm


I installed this just now and had to manually resize the SD card. You posted the solution here (just need to add sudo of course):

One other thing: I have an Allo Boss card. I had to disable HDMI sound in my headless setup or the card was recognized as card 3. I appended this line to /boot/cmdline.txt:


Also in that file, I changed this option:


I did those two things to get the mpd2chromecast plugin to work. There may be another way. I haven’t tried adding those to /boot/userconfig.txt.

Before changing that second option, my sound card was not being properly recognized by mpd2chromecast. However, playback was working out of the analog output of my sound card before I changed that option.

I’ve only had it up for half an hour but my Pandora plugin is working. Looks good!

Virtual Keyboard 1.0.4 doesn’t work… with latest touch display buster beta …

Yes, I wrote that Virtual Keyboard does not work earlier. Not matchbox-keyboard is the problem but chromium browser. Workaround is to revert to the old chromium version that gets installed on Jessie based systems.


auto start 1.1.2 doesn’t revert to last played song … 6 songs later it plays… seems to play random
but not set on random…

default startup volume is not working set on 60 doesn’t jump to 60 , startup volume after reboot is 100%

system information 0.1.3 works oke…

backup / restore 0.7.2 is broken… creates no backup…

album art : /data/albumart/web <<< images not showing they are present…

@truckershitch mpd2chromecast does not directly access the sound card. It does rely on a client connection to the onboard MPD server to continually query the current playback state and track/file details. It would almost suggest that MPD was not functional prior to those changes and hence the mpd2chromecast script fell foul of that. I’ll try updating my own volumio rpi to the same new beta and see if I can reproduce the same issue. I don’t however have any 3rd party sound device on my rpi as it’s only use to stream audio to chromecasts.

I believe that this is the case. I should have been more specific in my message.

I think this is specific to add-on sound cards and your script. If I remember correctly, the first error that occurred was when your script queried the volume parameter of the mpd software status. mpc status did not show a valid value for volume. I tried a number of things until I changed


in the /boot/cmdline.txt file. I don’t think that this is the proper fix, as I was unable to change the volume from your program’s web page.

I’d be happy to help you out with this if you want. Maybe this should be on GitHub or on another thread here on the forum?

We (well @Darmur) had similar issues with the pi0 - the Audio jack doesn’t show up.

Are you running on a pi4? I really hope these bootflags do not need to be tuned on a per-pi basis!
What was the final combination that worked for you? Could you share the output of aplay -l?

Found some hints:

So snd-bcm2835.enable_compat_alsa=1 snd_bcm2835.enable_hdmi=1 should work as before?

EDIT:Looks like they disabled the audio jack for the pi0


On 3.014beta trying to execute dtoverlay from the CLI fails with command not found.

On the Jessie based builts dtoverlay, dtoverlay-pre and dtoverlay-post are found in /usr/bin in the form of symlinks to the respective files in /opt/vc/bin. These symlinks are missing in Buster beta.

results in
error while loading shared libraries: libdtovl.so: cannot open shared object file: No such file or directory

libdtovl.so is present in /opt/vc/lib though.

Edit: Just found that on Jessie /opt/vc/lib/libdtovl.so is symlinked to /usr/lib/libdtovl.so but can’t test ATM if adding that symlink (and maybe running ldconfig) already solves the issue.

All these quirks, if only we could just install libraspberrypi-bin which handles it! :grimacing:
Does this work?

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/vc/lib /opt/vc/bin/dtoverlay <>

Will fix the Lib path in the next build…
EDIT: Just tested, should be fixed in the next build

:innocent: Will test and report back as soon as I get home tonight.

Okay, so it was my fault it seems. I had a lot of problems getting 3.010 to work with my card and I had to change a few things, and I didn’t get everything straight. I thought those changes would be necessary in 3.014 but I was wrong.

I just now started again from scratch. I did not change the configuration in /boot at all and merely went through the startup wizard on the web page. I rebooted and heard the startup sound.

Then I went to check and see if there was a volume value shown in the mpc client. There was not. It merely showed n/a. Choosing a station in Web Radio worked fine from my sound card. Playback seemed all right.

I looked at the sound settings, changed MPD Clients Volume Control to On, and checked again. The volume was at 60%. Success!

I think I’m fine from here. I let @dresdner353 know and I think my issue is finished.

I’ll try and break your beta through some other angle. :smiley:

This is a Pi 3B+ by the way. I don’t know exactly how that changes things but I guess it’s in the audio devices somehow.

1 Like

It suffices to add the symlinks:

sudo ln -s /opt/vc/lib/libdtovl.so /usr/lib/libdtovl.so
sudo ln -s /opt/vc/bin/dtoverlay /usr/bin/dtoverlay
sudo ln -s /opt/vc/bin/dtoverlay-pre /usr/bin/dtoverlay-pre
sudo ln -s /opt/vc/bin/dtoverlay-post /usr/bin/dtoverlay-post

After that dtoverlay command works :slight_smile:

FYI for those following the mpd2chromecast issue with this latest beta… I’ve pushed changes now to handle the absence of volume from the MPD server.

Please share logs and details of how to trigger the error, as I don’t have issues here…

just say how i can get the log ash :slight_smile: btw is there a version 2.853 with a mpd upgraded to 0.21.16?
this is needed for the new youtube plugin …