Volumio crashes while playing QOBUZ in Hi Res (24/192)


IGMP is used to reduce bandwidth on the network. Instead of sending 1 data package to 1 client, it sends 1 data package to multiple clients. However it only works if every node in the network has IGMP. IGMP is a fire and forget protocol, so there is no control if a client received the package. Since you’re mentioning drop-outs/stuttering, it could be the case here.
A lot of network gear have this option default enabled, hence my question.

a 2nd suggestion is to use a tool like Acrylic Wi-Fi Home (There is a free version). To see if one of your neighbors is interfering with your network, using the same channel.
If I would setup my network on channel 11, i sure would have issues like you’re mentioning.
Every color is a different access point.

Hey there! Well this option sure isn’t easy to find in my router. Main problem is, it is in French and the UI is clearly not designed for hard-core network engineers… I tried and find info about that but so far, nothing… The wifi channel is configured on auto, which means that if a neighbor is jamming my signal, you would think it would change to the next best channel, wouldn’t you? I will try and find time to monitor my network with the app you suggested. I’ll keep you posted! Thanks for the support again. Nice to see people not giving up on a total stranger like myself ^^.

So I gave Acrylic Wi-Fi Home a try and the only other signal in the area was in a rather opposite band and its strength was pretty weak. Mine was in the middle of the “good” zone and by the way, Volumio crashed again today (I guess the whole system is down when it happens). If I connect a monitor, is there a chance to have more information from the shell? I have not tried that until now…

Regarding the IGMP snooping, the only mention of that feature tied to my router was from people trying to substitute it with a third party equipment and trying to handle the TV stream. All I know is that it is compatible with IGMP 2. But there is no option with that name anywhere.

Is there a chance that the Pi 4 is still too new to be fully supported by Volumio, which I think run on a rather old raspbian version? Cause now I am “tweawless” and it still crashes when the bandwidth reaches its limits… In the meantime, I limited the sampling to 96kHz…

No I don’t think it’s related to Volumio on a rPi4.
The WL part on the rPi is not high science, due to it’s short areal.
Other things that can cause issues:

  • Metal casing
  • Added HAT

I run out of ideas or suggestions.

I will try to connect my TV on it to see if I see any specific error message. But I really think that the limited BW is the key of my problem. As you said, the CPU load is minimal and the crash cannot be tied to it. Is there a way to send feedback to the dev team by any chance? I haven’t looked it up yet.

There is a lot old topics about “stuttering” issues. I will keep digging…

Thanks anyway. You helped a lot already.

yes you can.
See this instruction:

Hey Wheaten. Any idea how I can get some follow-up once I submitted the report?

@volumio, Hey Wheaten. Any idea how I can get some follow-up once I submitted the report?
Maybe like this.

Or drop then a mail, with the issue and reference to the log at info at volumio dot org
Keep in mind they are extremely busy.

I manage multiple SW development projects with 30 people working on them, trust me, I know the drill :slight_smile: .It is just so I can monitor if any progress has been made (old habits due to my job maybe :sweat_smile:)

mmm, then you also know that the last will win :slight_smile:

  • single user error
  • Multiple user error

Which might not play in my favor since I seem to be a rare bird… :cry:

Let’s hope now this topic has bumped to the front, someone else has some suggestions. As I ran out of them.

pi4 is good img is bad lot of bugs there in that version. there should be 2.904 beta version…
and there is 3.xx versions too

Is there a known issues’ list or something? Cause yes, stability-wise, it is not great… I found workarounds that are satisfactory for a while but at some point, I want to use my device fully…

not really but i’m mutch of the time on here and i see all the time the same version giving problems…
and some go to 2.904 or 3.xx pi4 2/4/8gb?

Smart reference to my hats? (mutch) :rofl:

I am a rather recent member of this community so I woudn’t know. I have always run the 2.8.whatever version (I subscribed like a few months ago). So far, I only updated my pi once. I am what you “kids” call a noob :stuck_out_tongue: . No seriously, I had no clue this version was famous for its flaws… Plus I think I do not have access to the 2.9 or even 3.x versions (still based on Jessie by the way?).

2.904 should be jessie and 3.xx is buster
and and i’m after 1,5 year still a noob but learned a lot in the mean while.

i think if you want the 2.904 ip/dev turn on test mode and do a update from
settings>system>systemupdate check for updates

3.xx is still in beta so not all versions will give you the plugins

PI 4GB (sorry, I missed your question)

hi @volumio maybe you can shine a light on this issue