Volumio + chord qutest + intel NUC 7i3BNH

Hello all,

please help me with this:

I have volumio with Chord qutest DAC and I have problem with decode native DSD. When I play DSD tracks and I set up in Volumio “Direct DSD” DAC says 768 or 705,6 kHz, and sound is nois with hight frequency but Qutest supports direct DSD stream. So when I set up in Volumio “DoP” DAC says correct DSD stream and sound is correct, that means it’s the opposite of setting.

Does supports volumio direct DSD for quest DAC?

Thanks.

To check if there is support for the Chord Quest, you would need to do a

lsusb

Then check the vendor code with what was witten in this thread
But, you will need to take a dev version for x86, you will find it in the Volumio Development/ Development Talks section.

Thank you very much.

I installed the dev version: 2.529-2019-01-14-x86

I tried command lsusb and Volumio said:
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 245f:0815
Bus 001 Device 003: ID 062a:4182 Creative Labs
Bus 001 Device 002: ID 0bda:0306 Realtek Semiconductor Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Unfortunately this version does not see any usb drive. I’m new in Linux Volumio so I do not know how exatly change (edit) /volumio/.env NODE_MOUNT_HANDLER from ‘false’ to ‘true’?

For info: GUI via HDMI, wifi and LAN work perfectly.

  1. I had to learn the basics of Linux and I managed to change the command over the command window, finally I found all the music on the USB and network - super. GUI via HDMI on TV and control on this Intel NUC is very quickly - this built is better then official built from download section…

  2. Unfortunately, the problem with direct DSD playback is still the same.

as it appears, there is no support for Chord Qutest under linux, other systems like Roon are struggling with the same issue.
For the Chord Qutest to work, it will need a patch as for all other native dsd-capable devices.
There may be a way to do this, but there is no guarantee this will work.
do aplay -l and notice the card number for the Qutest.
then do

cat /proc/asound/cardx/stream0

where cardx is the card you found with aplay -l, then output the results here.

I tried and I get:

**** List of PLAYBACK Hardware Devices ****
card 5: Qutest [Qutest], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
volumio@volumio:~$ ^C
volumio@volumio:~$ cat /proc/asound/Qutest/stream0
Chord Electronics Ltd Qutest at usb-0000:00:14.0-4, high speed : USB Audio

Playback:
Status: Stop
Interface 2
Altset 1
Format: S32_LE
Channels: 2
Endpoint: 5 OUT (ASYNC)
Rates: 32000, 44100, 48000, 88200, 96000, 176400, 192000, 352800, 384000, 705600, 768000
Data packet interval: 125 us

This appears to confirm that there is no native DSD support for this device.
Nothing much we can do about that, I’m sorry.

Unfortunately. So thank you very much. I hope it will be in the future…

According to the manual for the Qutest, native DSD playback is only supported via ASIO in Windows using their driver. It does support DoP over USB and COAX however, so maybe try DoP over Volumio.