Volumio as a DLNA server

I am having trouble using Volumo as a DLNA server. The MiniDLNA plugin is installed and I can see, but can’t play, FLAC files on a USB drive that is attached to my Volumio Pi (3.198).

I have tried with my Yamaha receiver, my LG smart TV as well as Windows Media Player and VLC runnning on a Windows 10 PC.

The Yamaha receiver attempts to play the track, which fails but no error message. The LG TV gives an error “This file cannot be recognised. Playing the next file.” It tries a few more tracks then gives up.

WMP says “Windows Media Player cannot access the file. The file might be in use, you might not have access to the computer where the file is stored, or your proxy settings might not be correct.”

So maybe it is a file permission issue?

Please post a picture of the config page of the MiniDLNA plugin where the path to the audio files is shown.

If you have SSH access to Volumio, better post the results of

cat /data/configuration/music_service/minidlna/config.json

and

ls -al /media

I am seeing the same problem with Volumio 3 /RPi / minidlna plugin. The DLNA index (Artists/Albums/Tracks) is all visible in every device, just the files don’t play with any device - I get various error messages depending on the device.

Works perfectly with Volumio 2 and the old minidlna plugin. In both cases (2 and 3) it is from a fresh install from flashed SD card. I think the old plugin uses an older version of mindlna.

Am currently running Volumio 2 but I will switch back to my Volumio 3 card and try to get the configuration data mentioned by gvolt

I have got it working on another Pi running 3.198. I can play the files from my PC, Yamaha receiver, etc. So it is not a Volumio 3 thing. So I can just start again with another image.

gvolt,
No need to expend energy on this now but, for what is it worth, here is the /media folder:

volumio@volumiodigi1:~$ ls -al /media
total 10
drwxrwxrwx 1 root root 1024 Feb 22 19:35 .
drwxrwxrwx 1 root root 1024 Feb 26 13:06 …
drwxrwxrwx 1 root root 4096 Feb 25 07:40 Crucial_NVME_1T
drwxrwxrwx 2 volumio volumio 1024 Jan 24 09:57 NVMe_Drive_1T

The 2nd drive is not currently attached, only the Crucial_NVME_1T

Here is minidlna config.json:

volumio@volumiodigi1:~$ cat /data/configuration/music_service/minidlna/config.json
{
“show_more”: {
“type”: “boolean”,
“value”: false
},
“media_dir_a”: {
“type”: “string”,
“value”: “/mnt”
},
“media_dir_p”: {
“type”: “string”,
“value”: “/mnt”
},
“media_dir_v”: {
“type”: “string”,
“value”: “/mnt”
},
“merge_media_dirs”: {
“type”: “boolean”,
“value”: false
},
“db_dir”: {
“type”: “string”,
“value”: “/data/configuration/music_service/minidlna”
},
“log_dir”: {
“type”: “string”,
“value”: “/var/log”
},
“root_container”: {
“type”: “string”,
“value”: “.”
},
“network_interface”: {
“type”: “string”,
“value”: “eth0,wlan0”
},
“port”: {
“type”: “number”,
“value”: 8200
},
“presentation_url”: {
“type”: “string”,
“value”: “/”
},
“friendly_name”: {
“type”: “string”,
“value”: “VolumioDLNA”
},
“serial”: {
“type”: “string”,
“value”: “00000000”
},
“model_name”: {
“type”: “string”,
“value”: “MiniDLNA on Volumio”
},
“model_number”: {
“type”: “string”,
“value”: “Version 1.2.1”
},
“inotify”: {
“type”: “boolean”,
“value”: true
},
“album_art_names”: {
“type”: “string”,
“value”: “Cover.jpg/cover.jpg/AlbumArtSmall.jpg/albumartsmall.jpg/AlbumArt.jpg/albumart.jpg/Album.jpg/album.jpg/Folder.jpg/folder.jpg/Thumb.jpg/thumb.jpg”
},
“strict_dlna”: {
“type”: “boolean”,
“value”: false
},
“enable_tivo”: {
“type”: “boolean”,
“value”: false
},
“tivo_discovery”: {
“type”: “string”,
“value”: “bonjour”
},
“notify_interval”: {
“type”: “number”,
“value”: 5
},
“minissdpdsocket”: {
“type”: “string”,
“value”: “/run/minissdpd.sock”
},
“force_sort_criteria”: {
“type”: “string”,
“value”: “”
},
“max_connections”: {
“type”: “number”,
“value”: 50
},
“loglevel_general”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_artwork”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_database”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_inotify”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_scanner”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_metadata”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_http”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_ssdp”: {
“type”: “string”,
“value”: “warn”
},
“loglevel_tivo”: {
“type”: “string”,
“value”: “warn”
},
“wide_links”: {
“type”: “boolean”,
“value”: false
},
“enable_subtitles”: {
“type”: “boolean”,
“value”: true
}
}

@evansj57 Thank you for the report.

Currently the path to your audio files is set to “/mnt” (which is the plugin’s default). “/mnt” contains several directories - amongst others there is a folder “USB” which is a symlink to “/media” where your USB drive has been mounted.

So, if you should encounter the issue again, try enabling the “Wide Links” option on the config page of the plugin. In case that should not help I would suggest to change the audio files path on the config page of the plugin to the “real” full path to the audio files, e.g. /media/Crucial_NVME_1T/music.

Edit: @evansj57 Just tested a configuration similar to yours. Result: Enabling the “Wide Links” option should solve your issue.

Have now switched back to Volumio 3 and pleased to say that enabling “Wide Links” seems to work for me too. DLNA server can be read by other devices.

So thanks for the solution @gvolt and thanks to @evansj57 for posting in the first place!

Thank you for confirming. :slight_smile: