Volumio and Virtual Keyboard (SOLVED)

I use the latest version of volume on a raspberry pi 3B +.

I tried to install the Matchbox-keyboard and the florence with apt-get and they seem to have installed well.
The problem is that when trying to execute them both give “Cannot open display” error
And if I run xhost + I get the error xhost: unable to open display “”

Would anyone know what happens or what can I do to solve this problem?

No one knows how to try?

Do you have installed both Matchbox-keyboard and Florence in parallel and how do you execute them?

Do you have the Touch Display plugin installed (I guess so)?

Did you install other Xserver related software and if so what steps did you take?

Also please connect to your Volumio via SSH and post the results of ls -al /tmp/.X11-unix/ and systemctl status -l volumio-kiosk

Now I only have florence installed.

Yes I have the Touch Display Plugin installed, on a 7 "screen.

I only installed the volume image on the microsSD and I have not tried to install anything other than virtual keyboards.

And here are the operations that you have asked me:

volumio@volumio:~$ ls -al /tmp/.X11-unix/ total 0 drwxrwxrwt 2 root root 60 Feb 11 19:00 . drwxrwxrwt 13 root root 480 Feb 11 19:00 .. srwxrwxrwx 1 root root 0 Feb 11 19:00 X0 volumio@volumio:~$

volumio@volumio:~$ systemctl status -l volumio-kiosk
● volumio-kiosk.service - Volumio Kiosk
   Loaded: loaded (/lib/systemd/system/volumio-kiosk.service; disabled)
   Active: active (running) since Tue 2020-02-11 19:00:38 UTC; 8min ago
 Main PID: 1405 (startx)
   CGroup: /system.slice/volumio-kiosk.service
           ├─1405 /bin/sh /usr/bin/startx /etc/X11/Xsession /opt/volumiokiosk.sh                                                          -- -nocursor
           ├─1426 xinit /etc/X11/Xsession /opt/volumiokiosk.sh -- /usr/bin/X :0                                                          -nocursor -auth /tmp/serverauth.5nMA6ea9Wk
           ├─1428 /usr/lib/xorg/Xorg :0 -nocursor -auth /tmp/serverauth.5nMA6ea9                                                         Wk
           ├─1551 /bin/bash /opt/volumiokiosk.sh
           ├─1570 /usr/bin/ssh-agent /opt/volumiokiosk.sh
           ├─1575 /usr/lib/chromium-browser/chromium-browser --enable-pinch --pp                                                         api-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args                                                         =enable_stagevideo_auto=0 --disable-pinch --kiosk --no-first-run --disable-3d-ap                                                         is --disable-breakpad --disable-crash-reporter --disable-infobars --disable-sess                                                         ion-crashed-bubble --disable-translate --user-data-dir=/data/volumiokiosk --no-s                                                         andbox http://localhost:3000
           ├─1613 /usr/lib/chromium-browser/chromium-browser --type=zygote --no-                                                         sandbox --user-data-dir=/data/volumiokiosk --ppapi-flash-path=/usr/lib/chromium-                                                         browser/libpepflashplayer.so
           └─1667 /usr/lib/chromium-browser/chromium-browser --type=renderer --d                                                         isable-3d-apis --disable-breakpad --disable-pinch --enable-pinch --no-sandbox --                                                         enable-features=AutofillCreditCardSigninPromo<AutofillCreditCardSigninPromo,Auto                                                         fillProfileCleanup<AutofillProfileCleanup,DocumentWriteEvaluator<DisallowFetchFo                                                         rDocWrittenScriptsInMainFrame,ExpectCTReporting<ExpectCTReporting,IncidentReport                                                         ingDisableUpload<SafeBrowsingIncidentReportingService,IncidentReportingModuleLoa                                                         dAnalysis<SafeBrowsingIncidentReportingServiceFeatures,IncidentReportingSuspicio                                                         usModuleReporting<SafeBrowsingIncidentReportingServiceFeatures,MaterialDesignUse                                                         rManager<MaterialDesignUserManager,NegotiateTLS13<TLS13Negotiation,NetworkTimeSe                                                         rviceQuerying<NetworkTimeQueries,NewAudio

Feb 11 19:00:38 volumio startx[1405]: Current version of pixman: 0.32.6
Feb 11 19:00:38 volumio startx[1405]: Before reporting problems, check http://wi                                                         ki.x.org
Feb 11 19:00:38 volumio startx[1405]: to make sure that you have the latest vers                                                         ion.
Feb 11 19:00:38 volumio startx[1405]: Markers: (--) probed, (**) from config fil                                                         e, (==) default setting,
Feb 11 19:00:38 volumio startx[1405]: (++) from command line, (!!) notice, (II)                                                          informational,
Feb 11 19:00:38 volumio startx[1405]: (WW) warning, (EE) error, (NI) not impleme                                                         nted, (??) unknown.
Feb 11 19:00:38 volumio startx[1405]: (==) Log file: "/var/log/Xorg.0.log", Time                                                         : Tue Feb 11 19:00:38 2020
Feb 11 19:00:38 volumio startx[1405]: (==) Using config directory: "/etc/X11/xor                                                         g.conf.d"
Feb 11 19:00:38 volumio startx[1405]: (==) Using system config directory "/usr/s                                                         hare/X11/xorg.conf.d"
Feb 11 19:00:39 volumio startx[1405]: modprobe: FATAL: Module g2d_23 not found.

Thanks for the help

That looks OK. Apart from pixman this looks pretty much the same on my system. I guess you can use the functions of the Touch Display plugin or do you get then error messages as well?

Does the error “Cannot open display” appear (only) when you try to start florence manually from the command line? If so, what happens when you run DISPLAY=:0 florence
BTW: What are you trying to achieve when executing xhost + I?

xhost + I was a check I saw on the internet, but it didn’t give me the expected response.

I want to put in .bashrc the florence boot string so that it starts with volume, but it doesn’t work for me:

DIPLAY=:0 /usr/bin/florence

He doesn’t do anything, or I don’t see him do anything.

If I run it through SSH, this appears to me:

volumio@volumio:~$ DISPLAY=:0 /usr/bin/florence
Florence version 0.6.2
XRecord extension found version=1.13
Your screen does not support alpha channel. Semi-transparency is disabled
WARNING: Service name lost.
WARNING: Notification failed

(florence:2252): GLib-GObject-CRITICAL **: g_object_set: assertion 'G_IS_OBJECT (object)' failed

(florence:2252): GStreamer-CRITICAL **: gst_element_get_bus: assertion 'GST_IS_ELEMENT (element)' failed

(florence:2252): GStreamer-CRITICAL **: gst_bus_add_watch_full: assertion 'GST_IS_BUS (bus)' failed

(florence:2252): GStreamer-CRITICAL **: gst_object_unref: assertion 'object != NULL' failed

The last lines are repeated every time I play a florence key.

I just want the virtual keyboard to use the Volumio search.

Thanks for your help

You may also try the following but I doubt you would get rid of the “failed” messages you recently posted:

  1. Open /opt/volumiokiosk.sh with sudo nano /opt/volumiokiosk.sh

  2. After the line openbox-session & add a new line containing florence &

  3. Save the file by Ctrl+x, y and “Enter”

  4. Disable the touch display plugin and then enable it again.

  5. If it does not work check the output of systemctl status -l volumio-kiosk

If you don’t mind using matchbox-keyboard instead of florence maybe start another attempt following these steps:

  1. Do not only install matchbox-keyboard but also matchbox-window-manager sudo apt-get install matchbox-window-manager matchbox-keyboard

  2. Open /opt/volumiokiosk.sh with sudo nano /opt/volumiokiosk.sh

  3. Substitute the line openbox-session & withmatchbox-keyboard -d & matchbox-window-manager -use_titlebar no &

  4. Save the file by Ctrl+x, y and “Enter”

  5. Disable the touch display plugin and then enable it again.

First, openbox-session & is disabled, which I don’t know if it affects something or not:

#openbox-session &

I modify and try to disable the plugin, but volume disappears from the screen. Restart the system by SSH and then volume does not start, it remains in volume login:

By SSH I execute what you tell me:

volumio@volumio:~$ systemctl status -l volumio-kiosk
● volumio-kiosk.service - Volumio Kiosk
   Loaded: loaded (/lib/systemd/system/volumio-kiosk.service; disabled)
   Active: inactive (dead)

That is not by default. If there is no entry regarding e.g. the matchbox-window-manager remove the[code]

[/code]from that line.

You should not have to restart Volumio (reboot). You should have access to the UI through any webbrowser running on a device which is in the same network as Volumio.

P.S. Maybe post the result of cat /opt/volumiokiosk.sh

Ok, we’ll try the other virtual keyboard.

Uninstall florence:

sudo apt-get remove florence
apt-get autoremove

Delete about ten million things… :slight_smile:

I install the matchbox, edit the file and restart the system from SSH since it was not booting.

It stops again in volumio login:

By SSH i execute:

volumio@volumio:~$ systemctl status -l volumio-kiosk
● volumio-kiosk.service - Volumio Kiosk
   Loaded: loaded (/lib/systemd/system/volumio-kiosk.service; disabled)
   Active: inactive (dead)

If you disabled the plugin you need to enable it again. If you can access Volumio through a webbrowser you can do that from there.

In case you did not disable the plugin try systemctl start volumio-kiosk


volumio@volumio:~$ cat /opt/volumiokiosk.sh
while true; do timeout 3 bash -c "</dev/tcp/" >/dev/null 2>&1 && break; done
sed -i 's/"exited_cleanly":false/"exited_cleanly":true/' /data/volumiokiosk/Default/Preferences
sed -i 's/"exit_type":"Crashed"/"exit_type":"None"/' /data/volumiokiosk/Default/Preferences
openbox-session &
matchbox-keyboard -d &
matchbox-window-manager -use_titlebar no &
while true; do
  /usr/bin/chromium-browser \
    --disable-pinch \
    --kiosk \
    --no-first-run \
    --disable-3d-apis \
    --disable-breakpad \
    --disable-crash-reporter \
    --disable-infobars \
    --disable-session-crashed-bubble \
    --disable-translate \
    --user-data-dir='/data/volumiokiosk'        --no-sandbox     http://localhost:3000

The lines of the matchbox were duplicated, when installed they would have been created and we then created two more. I have deleted them and now it works perfectly.

Problem solved.

Thank you very much from my heart, friend.

Congrats solving it :smiley:
Thanks for your feedback!

P.S. I just recognized that your /opt/volumiokiosk.sh contains “openbox-session &” and also “matchbox-window-manager -use_titlebar no &”. If that should be the current content of the file I suggest to remove or comment the openbox entry like that #openbox-session & My post advising the opposite (https://forum.volumio.org/volumio-and-virtual-keyboard-t13906.html#p72099) was referring to the case of using florence while sticking to openbox as window manager, not the combination of matchbox-keyboard and the matchbox-window-manager (which is meant to substitute openbox).

Good evening, I’m a new member. For a few days I have a raspberry p4, lcd touch 7 "1024x600. I have installed volumio and I would like to use these components better. I have no programming knowledge. I understand how to enable shh, use putty. I need help to install everything I need to have LCD working 100% and with virtual keyboard, to insert text from LCD I would need help step by step Can you send tutorials pdf or videos? A heartfelt thanks to those who can help me.
My email is: dragospyro @ live.it

Have you tried to simply install the plugin ‘touch display’ and the other ‘virtual keyboard’ ?

Ciao, scusami tanto…ho installato il plugin touch di volumio, ma non so dove trovare “tastiera virtuale” e come installarla. Grazie per l’aiuto.

here :wink:

Ciao e grazie per la tua disponibilità. Ho controllato nel menù ed installato questo plugin. tutto ok. ora finalmente funziona. Volevo chiederti 2 cose importanti per me.
A) Il mio progetto ha monitor lcd 7" touch waveshare (https://www.waveshare.com/wiki/7inch_HDMI_LCD_(C)). Quando installo volumio, lcd non funziona. Installo plugin touch e display lcd funziona. Ora volevo chiederti ma non devo instalalre eventuali driver??? è tutto ok così? Devo impostare risoluzione schermo? e se si come?
b) Ma sul touch non si puo’ abilitare barra controllo volume?
Grazie amico.

Sorry I can’t read Italian… The rule in this forum is English speaking. :wink: