Volumio always boots as hotspot

Hi there,

in my case Volumio always starts as hotspot instead of connecting to my wifi network.

Then I have to connect to the hotspot and change the connection to my wifi network via the UI.
That works but is a little pain.

I would like Volumio to connect directly to my wifi network on start-up/reboot and only to start as a hotspot when my wifi network is not available.
(Don’t want to disable the hotspot completly)

Any ideas? Thanks!

This is exactly what Volumio is programmed to do: switch to hotspot only if your network is not available.
When you shut it down, do you it correctly or you remove power?

Hi Volker,
it happens to one of my devices also some time. the receive signal is to less.
maybe you can move your device a bit or try a update.

another idea. change the wlan channel in your wlan network.
for example on channel 1 i had only 5.5mb bandwidth, changing to channel 8 i had 65mb bandwidth and not interrupts with booting again into hotspot.
good luck.

  1. In my setup Volumio always starts in Hotspot-Mode even if my network is available. Same behavior at power-on or reboot over UI (“shutdown restart”).
    I can only establish connection to my network by connecting to the Hostspot > Ul > settings > network > select my wifi network > Message “Wireless Restart”. Then ist connects to my network instead of hotspot-mode.

  2. My wifi network is turnd off over night. Volumio then switches to Hotspot-Mode. Which is ok. But it doesn’t automatically reconnect to my network when it is available again in the morning, which would be nice.

UI shows a strong wifi signal to my network and connection is stable when connected.

Help appreciated. Greetings.

I dont think it will switch back to the router’s ssid used before just because you turn the router ON and its ssid is available again, dont think it is intended to work that way. You’ll need to restart the rpi too and then it will connect to the router’s ssid, so it does here…