volumio alexa plugin

Hi All,
The plugin is ready for beta deployment for whoever interested. It’s running nicely on my volumio rpi box :slight_smile:



Greeeeeat!!! So eager to try it! Time to buy an echo…
PS: Is there a way to make its configuration easier? Such as the MQTT user pass?

the plugin configuration indeed contains mqtt user/pass as well as broker host (it’s actually ALL the configuration needed).
the configuration of the mqtt broker inside alexa/aws is indeed hardcoded and could be improved I guess… I’m just a newbie with alexa configuration so maybe it will improve in the future (i’m also open for pull requests…)

So a couple of things

  1. I really like the idea of being able to control Volumio from an Echo, definitely a worthwhile addition.
  2. I copied all the files from GitHub to the rasp pi following the instructions, putting them in /data/plugins/user-interface/alexa/ and made the edits to /data/configuration/plugins.json and aws_lambda.py. I noticed a few minutes later that the user-interface folder was empty. Any idea what I did wrong?
  3. How does my Echo learn about the skill? This has me completely confused as your instructions only talk about edits in Volumio, I didn’t see anything to install / setup for the Echo.


Hi Pat,
re. 2 - if the plugin disappears, it means that /data/configuration/plugins.json was not updated correctly - please double check the plugin section was added under user_interface section.

re. 3 - you aer right, i omitted any instructions for alexa since amazon site has a very detailed (step by step) instructions - just google “how to add alexa skill” in amazon site and use the files (aws py file and utterence etc… files) when needed. I admit there is some learning curve related to alexa skill setting that I had to take also before having the system work (and also for MQTT I guess).

Just keep in mind the following flow
Human <-> alexa <-> MQTT (topics /alexa/command & /alexa/response) <-> volumio.

I guess that since home automation is still in its infancy and everything is fragmented in term of protocols, you sill need to be a little it of “hacker” to make it work …


Thanks Lior, I’ve been wanting to look at Alex skills development so now I have some great motivation. Should have some time to look at it in the next few days.

Good news, got it working! The learning curve on ASK was a little step but manageable - took me about 6 hours (never done anything with python before and only a little js plus I may be a slow learner :slight_smile: !). I did have to make some very minor tweaks to both the py file and the plugin. I’ll create a pull request sometime next week, the weather this weekend will be unusually springlike here in the eastern US so I intend to be outside as much as possible!

How to deployment aws_lambda.py.
I could not.“Unable to import module ‘aws_lambda’: No module named paho.mqtt.client” :cry:
@alior101 I send to you my file, do you do for me. create .zip all file

Argh - I really would like to get this working but I’m having an issue with setting up the new skill and how it talks to cloudmqtt. It would really be helpful to develop further documentation on this so users who are not familiar with the alexa skill setup can follow. I’ve read through the guide but its not clear how it talks to MQTT and ultimately my amazon tap. For now I guess my volumio setup will sit next to my amazon tap without talking to one another.
I would really appreciate any help people could provide.

i would love to use this plugin.
I tried everything, but now i’m stuck at the lambda function with test errors while importing libraries for mqtt …
Any solutions? What i am doing wrong?
Best Regards

Just wondering if there has been any further development on this… as Alexa continues to evolve as a (if not the) home assistant, would be great to get integration to Volumio.

I plan to play around with the plugin as it is, but has anyone else tried anything lately?

i could not get this to work in the new Volumio so i created an alternative solution that is much simpler

explained here:

Thanks - I’ll give it a run!

Hi, I know this is an old blog post, but I have been trying to get this to install but am struggling. Therefore any assistance would be greatly appreciated.

I have downloaded the git zip packages onto volumio and have extracted them to a folder, however when I run volumio plugin install over ssh, I get the message that no package is found, what am I doing wrong?

it has been a while since I played around installing unofficial plugins with volumio (early 2018). So this may be something to do with the new plugin certification model I am reading about.

as an aside how do I view the directories in order to amend the aws.lamba etc they used to be listed on the internal storage. However they aren’t there anymore. Although I can see them listed under SSH.
Annotation 2020-01-02 142036.png

Hi. The provider of MQTT is no longer free so I have subscribed to IBM Cloud but struggling how to find the settings to change the Cloud MQTT can anyone help? Thanks Dave