Volumio Airplay only via WIFI, not ethernet (Raspberry Pi 4)

Hello Folks,
I’m new to Volumio - I installed it on a Rapsberry Pi 4 and after the HiFiBerry Dac arrives, I’ll be using it with a DAC Pro.
I’m experiencing a strange problem when trying to connect via Tidal connect or Airplay to my Volumio Device, which is hooked up via ethernet (1Gbit/s) and ist perfectly asscessible via ssh/webinterface/app:
Airplay is not working, when I turn the volumio Wifi function off (which I want cause it is connected via ethernet).
More info about my system:

  • Router: FritzBox 7490
  • Switch: Passive 16 Port Netgear everything is connected to
  • Volumio in latest version (tried dev version as well)
  • Volumio Hotspot ist turned off
  • Volumio shows existing connection on both, ethernet and wifi
  • Volumio is accessible both via ethernet and wifi

Does anybody ran into the same problem? It’s working fine via Wifi but I want to integrate as less devices as possible into the wifi.
I googled a lot and it could be possible that the airplay (shairport) functionality is just hooked up to wifi and not ethernet - any way i could change that (obviously with ssh connection)
Besides that volumio runs amazingly fast and nice!

Thanks a lot in Advance!


It sounds like the Tidal and Airplay devices are still looking for the Wi-Fi connection of your Pi when you have disconnected the wireless connection.

Have you tried to disable the Wi-Fi and deleted the network from the Pi. Rebooting it and preferably the Router as well.
Your router should flush all existing connections.

I just now disabled Wi-Fi on my wired Pi3 and had to reboot it looks like it either was actually using Wi-Fi or there is something not working cleanly.

Thanks for your answer! Something else seems to cause the problem: My router is not sharing the multicast signal required for airplay between wifi and ethernet! So everytime I deactivated the wifi on the Pi, the multicast signal which is send by iPhone or other airplay devices is not routed to the airplay device (which are all connected via ethernet). You can enable multicast connection between WiFi an ethernet on the FritzBox via this guide: https://fvdm.com/code/tweak-fritzbox-for-airplay-across-ethernet-and-wifi
This also seems to solve the often experienced Problem that airplay is generally just working with WiFi-clients (sonos, AV-Receivers,…)