Volumio 3: Wifi off at reboot and SSH not enabled

I just installed Volumio 3.165 on a Raspberry Pi 4 that previously had version 2.915 installed.
At the end of the “first wizard config” I had the working system.
The problems I encounter are these 2:

  1. at every restart I find the wifi turned off. Luckily I have installed the “Touch Display” plugin and I can turn it back on directly from the Raspberry.
    For completeness of information, both the wifi and the wired network (cable not connected) are set with static IP.

  2. I can’t activate access via SSH. I created both the ssh file inside the /boot folder and activate SSH through the /dev page but access is always disabled.

Is there any workaround especially to solve the wifi problem?

The wifi issue seems resolved with version 3.173.

Still problem enabling SSH.

After a couple of days without using Volumio, today the problem of wifi non reconnecting is again present.

Don’t mix two method to enable ssh.

Neither method works, even when used once at a time.

Are you sure you use the correct IP?
I use SSH on all devices, every day, it works.

I’m sure that the IP is correct because I use it for access the web GUI.
The most annoying thing is that I need to enable the wireless interface at every reboot.

How do you attempt to connect via SSH? From a Linux machine or using putty like?

ssh volumio/IP
Password volumio

I’m using PuTTY using the IP

As you can see I can reach the web GUI, I can ping the IP but SSH doesn’t work.
I confirm that in /boot folder is present a file named “ssh” (without quotes).

Windows Firewall issue?

I don’t think because with Volumio 2.xx it has worked flawless until I’ve updated it to version 3.
For me is always possible to access via SSH other machine on the same network so I don’t think that WF can be the culript.
In order not to leave anything out, however, I also tried with Windows Firewall disabled.

Considering that you may have network issues, can you check the “seconds between keepalives” setting in the “Connection” category in the putty settings? If it is 0, you could try with 5.

The mystery of SSH is solved:
in the /etc/ssh folder there was still the old sshd_config file that referred to some HostKeys no longer present.
For some strange reason the upgrade to version 3 deleted these old keys but left the old config file in place.

After reinstalling Volumio 3 from scratch on an empty SD card the problem no longer occurred and now SSH works correctly.

Unfortunately, however, even a clean installation did not solve the problem of wifi not activating after a reboot.

Did you install 3.165 or 3.173?

Initially I’ve installed the 3.165 updated a few hours later to 3.173.
Now I’ve installed a 3.173 from scratch.

Did the wifi issue ever get sorted as I have what seems to be the same problem - at every restart(or completely off then on) the wifi is disabled?

I have 2x Pi 4Bs with the problem reproducible at every restart.

If the wifi is enabled again then after a network restart notification in the UI the wifi appears connected correctly with the fixed IP address.

At this point I can even pull the ethernet cable out and connect via the wifi IP address and continue playing music.

This is with 3.179 just installed today, and the problem was also there with 3.175 and possibly 3.173.

just gonna chime in, i have a Raspi3b with a Hifi Berry Amp2 and run system 3.198
after a shutdown or reboot wifi disables itself, additionally SSH seems to also disable on every reboot.

IF i connect to ethernet i can connect to the device and re-enable wifi in the web GUI and then i can disconnect the ethernet cable and access the web GUI via wifi and the device will work correctly.

any recommendations and or things i should try to collect and post?

EDIT: I have been playing around with this trying to figure out what is going on and I may have found an interesting connection. it seems that when the Pi is rebooted or shutdown without an ethernet connection, when it comes back up, the WiFi is disabled. However, if i reboot/shutdown WITH an ethernet connection left it, the Pi comes back up with WiFi still enabled.
what is going on here?

Hi,

Unfortunately I have the same WiFi problem.
Volumio I am using for years. I had to reinstall Volumio and now WiFi every times disables itself.
Tried the latest version in a 3 and 4, same result, went back to latest volumio version 2 same problem. In my network nothing is changed. Tried all day, all kind of versions of Volumio and Raspi’s. I get nuts. In the past years never having this kind of problems.
Don’t know what to do anymore…

Ad.