Volumio 3 - Two Independent HDMI Issues

Two systems converted to Volumio 3:

  • RPi3, headless: HDMI Audio Ouput is selectable and it works, however a login prompt is burning my TV screen pixels so I can’t use it long term.
  • RPi4 + Official RPi screen - NO HDMI audio option (there was video activity, so the cable is there and the TV source setting is correct).

What I need is at least one of these two systems to provide HDMI Audio with Video Blacked Out to save my TV from pixel burn-in. I’m comfortable with ssh and command line if that helps.

(I’m aware of the non-Hi-def limitations of HDMI, when that matters my non-TV setup is a Fiio K5 … Klipshorns.)

1 Like

do you have the touch display plugin installed?
gvolt will take it from here…

Connect to Volumio via SSH and try adding


to “/boot/userconfig.txt”. After saving the file a reboot is required.

yes, the touch display plugin is installed on the no hdmi option system. It is not installed on the working system.

Is the hdmi_drive=2 solution intended to solve the RPi4-doesn’t-offer-me-HDMI or is for the RPi3-using-HDMI-is-burning-my-TV-pixels issue? (and thanks for putting that help link in!!!)

Yes. Now I doubt it would help, but trying it wouldn’t hurt :wink:

Thanks, I’ve already swapped the two systems in my house so I’ll get back to this later. Appreciate the help and the caveat. I’m more concerned with the RPi3 HDMI video being non blank right now. If I can’t get rid of that I’ll probably add a DAC hat and bypass the TV. For my TV room listening I don’t feel the need those extra bits.

Can’t you just add hdmi_blanking=1 to the userconfig.txt, so the screensaver of the touch display plugin kicks in?

1 Like

This is the system without the touch screen. I made the change but didn’t wait long enough (5 minutes from a web search) to see if it’d work.Thanks. After The Voice is over I’ll revisit it.

Smaller font, same problem. The hdmi_blanking=1 line is in the userconfig.txt file in the /boot/ directory so it’s not getting overwritten.