Volumio 3 RC1 - Open Beta Testing

So I have an issue on my Volumio 3.159. Pi 3 with a HIFIBerry DAC. Using Media Server to access a Synology Diskstation with an attached USB drive via DLNA. Issue: When I try to select a specific track to play, it doesn’t work (error attached). But if I play the entire album and then skip to the track I want, it works perfectly fine.


It seems to work again over here since last night. Super happy, now in Multiroom :slight_smile:

1 Like

SOLUCIONADO! Mi problema no era Volumio 3, era el Router.
He encontrado la solución a los problemas que tenía con Volumio 3: Cambié el router y éste denegaba el acceso de Volumio. habilité el acceso y se solucionaron los problemas. :smiley:

SOLVED! My problem wasn’t Volume 3, it was the Router. I have found the solution to the problems I had with Volumio 3: I changed the router and it denied Volumio access. I enabled access and the issues were fixed.

“Go to Artist” and “Go to Album” are still broken on Manifest UI and can lead to wrong artist or album.

Steps to reproduce 100% success rate.

  1. add songs to queue
  2. listen all songs(or select last from queue and rewind to very last seconds and wait till it ends)
  3. refresh the web gui with F5
  4. you can see your last song info in the “Now playing screen”
  5. select Goto artist/album, it takes the info from Queue position 0 and show that.
  6. bug reproduces.

E: the underlying issue is that the “position” from getState have reset to 0 when the last song of queue did finish, even thought rest of the info in there still shows the last song of the queue, so the data returned by the call is out of sync with itself in this scenario.


I miss the GPIO Buttons plugin for my status LED on my RaspberryPi 3+ :frowning:

1 Like

If youre OK with SSHing into Volumio and using the command line you can get GPIO-Buttons working fine in volumio 3.

Just follow the post here Install npm module - problem - #9 by Darmur

OK . Have installed with your method. Is also available. Plugin cannot be started :frowning:

Did you update the node modules like suggested?

Can you please take this to a separate thread or PMs please? (Manual installation of plugins is not relevant to the purpose of the thread)

Still cannot use qobuz. Volumio 2 works great, Volumio 3 just stops playing. This is the third time reporting this issue. Seems strange that I should be the only one with this problem. Playing Pink Floyds Dark side of the moon stops after track 3 every time. 100% reproducable for me!

Just stops playing :man_shrugging:
Log http://logs.volumio.org/volumio/9nEWOdF.html

Very strange.
I don’t have this problem.
I almost only hear Qobuz in the highest possible quality with Allo BOSS and have not been able to determine it.
That doesn’t help you any further, I just wanted to share it in order to be able to narrow it down better.

RPI2, RPI3, Allo Boss, HifiBerry Dac+ Pro XLR.


Only that album? Other albums play as expected?

I recently upgraded my account to the new Premium tier and find that I’m not getting any album info in the beta version, and album and artist story returns “Not Found”. I’m primarily using Qobuz but have the same problem with locally hosted music. Is this a known issue?

No all albums seems to stop at some point. This one is always at the same place. First noticed it with the lady Gaga a star is born soundtrack. I think both that and dsotm are gapless? Could have something to do with it maybe.

I have reflashed Volumio 3 a couple of times. I am on the latest version now. I have a good strong wifi signal to the pie. Really frustrating.

1 Like

Change the buffer size, cache or whatever it’s called. But ultimately try another card and/or another way of writing the image. If you been using etcher try Raspberry pi imager it has an option to write a custom image.

1 Like

Also are you using dsp or custom mpd etc… Any plugins?

Tried changing buffer size
No plugins
With or without DAC hat enabled
Flashing with RPI imager
Different SD card

Tried updating mpd. I actually had similar problems with Volumio 2 + Tidal where mpd stopped working randomly. I then updated mpd and it worked flawlessly since then.

I must have some unique combination of hardware or network that just makes this thing not working. I kind of suspect mpd problems now again given the similar trouble with Volumio 2 but I hoped that would be resolved with Volumio 3.

When this happens Volumio hangs but can be recovered by restarting mpd or rebooting Volumio. Pretty useless though when I can only hear 3 tracks of one of my favorite albums. :wink:

Thanks for the suggestions! I guess I will have to stick with Volumio 2 for the time being.

I had problems with Qobuz (not using volumio) when playing from more than one device with my single user account.

Hi Guys, I have reported a V3RC1 UI problem with Qobuz which is annoying here : Qobuz on Volumio - #9 by fabriceo
Please take a look, this doesn’t seem to be extraordinary bug and all virtuoso users who have paid for Qobuz are impacted. Many thanks for supporting us!


Latest version 3.163 seems not as good as previous.
Music (webradio or spotify) would stop after sometimes. System irresponsive to do anything, will take time to come back online.
Log http://logs.volumio.org/volumio/aT2fyL9.html

Raspberry Pi 3
DAC Allo Piano 2.1 + Kali reclocker
Wifi dongle TP-Link … realtek (don’t remember the model)
mSata SSD from Suptronics not recognized.

Hope the logs helps you