Volumio 3 RC1 - Open Beta Testing

For version 3.3.1 of the Touch Display plugin the plugin type has been changed from “system_hardwrae” to “user_interface” according to the docs.

I recommend to uninstall both versions and install version 3.3.1 of the plugin. Report back if the plugin should still fail to connect to the Xserver.

Hi !

With 3.152 installed, I still have issues with Tidal Connect (playing will stop, restarting not always works) but it seems to improved over the pevious versions. I’ve seen other similar reports, let me know if you want me to submit a new log.

Other then that, let’s say this version 3 will be great (I subscribe to My Volumio Superstar). All your efforts are well appreciated … grazie mille !

Michel P.

Hope this will help for those having similar issues:
Pi Zero 2 W → Volumio 3.152 version.

  • worked well when flashed 32GB SD card NOT 16GB (although I was flashing 16GB without error)
  • replacing 1,5A power supply with > 2A one (initially 1.5A worked well but when starting to use web gui more extensively Pi Zero 2W started to reboot)
1 Like

Volumio 3.152, PI 3B, HiFiBerry DIG2 Pro
Added my NAS music folders today and played a few Flacs, no problems.
I then noticed I had the wrong Cover art for two of my ‘LPs’. Went into Explorer and replaced them with the correct ones. Clicked on ‘Update’ in Volumio and they did not change. Tried ‘Rescan’ and again they did not change.
Is that a small bug?

1 Like

Try “reset album art cache” in Sources settings.

More news!

A new simplified subscription plan

Volumio3 will bring also a new and simplified subscription plan, which takes into account the suggestions you guys gave over the years.

Read more about Volumio Premium here

What changes from Volumio2 to Volumio3
Read everything that changes in the transition from Volumio2 to Volumio3.

1 Like

Thanks an Album and Windows Refresh corrected it.

Hi @gvolt
I have Uninstalled both plugins but I do not find in user interface tab the touch display plugin, only in hardware…

That’s because the stable version of the plugin is currently registered with plugin type “system_hardware”. Therefore it only appears in that category. Version 3.3.1 is in beta status. You can only see it when you open the “System Hardware” category and then click on the “Details” button of the Touch Display entry. On the “Details” page you can choose “Install v3.3.1 (beta)”. Then close the “Details” page and click on the “Install” button.

The problem is, that this will not only install version 3.3.1(beta) but also version 3.0.1(stable) and you can’t use the uninstall function to remove 3.0.1 without removing software packages from the system which are still needed by 3.3.1.

So until 3.3.1 becomes stable just disable 3.0.1 (but keep it installed) and enable 3.3.1. If you don’t do beta testing the plugin I recommend to not install 3.3.1 at all - not because I would consider it to be not mature enough, but because of the predescribed hassle.

@mervinio @volumio

When reinstalling the Touch Display Plugin, I noticed that too early “Finalizing installation” is displayed and offered to enable the plugin.

At the time when the “Enable Plugin” button appears, the installation of the downloaded software packages is typically not yet complete.

If the user selects this button immediately, the Xserver will fail to start because the software installation is still running in the background. I suspect that this was the reason for the error message reported by @Lintbf.

I can not make it work. I have Uninstalled both plugins, installed beta 331, activated both plugins but I receive the error with x server. How much should I wait until I can activate the plugin?

1 Like

I recommend to enabled only one of the plugins.

That will probably depend on your Pi model and the speed of your SD card. Now that you have already installed the plugin (as I suppose) disable the plugin, and try enabling it again. Maybe repeat that.

I have tried enabling one by one and I receive error connecting to x server. I have made it work by mistake in the first time now it just does not.

1 Like

Did you disable and re-enable 3.3.1 too? Maybe try it repeatedly.

1 Like

Yes… Strange

1 Like

If it did not help uninstall both plugin versions. Then install the plugin and watch the installation with journalctl -f. Wait for the message info: Folder /tmp/downloaded_plugin.zip removed. Then enable 3.3.1 from the UI.

It did not worked
The plugin is installed very fast… Now only 331 has-been installed without 301.

That sounds a bit strange - are you sure?
I recall the plugin manager code being quite sequential - if it can do parallel installs, it would make setting up my devices after a new flash much faster! :smiley:


I had that effect just recently, too. As I couldn’t believe what I saw, I uninstalled 3.3.1 and re-installed it: Now again both version appeared… Now I don’t get it.


Haha, if it would be predictable :wink: (see above).

Yes, I had both versions installed. Their files were in /data/plugins/user_interface respectively /data/plugins/system_hardware. When I uninstalled 3.0.1 it executed uninstall.sh which removes all software packages “pulled in” during plugin installation (e.g. for chromium-browser, Xserver). As these software packages are identical between the two plugin versions, they were missing for the remaining 3.3.1.

1 Like