Volumio 3 Plugins store issues and discussion

My plugin isn’t in the volumio-plugins-sources fork repo, it has a GitHub repo on its own:

Sorry, but I’m new to this GitHub stuff. What shall I do?

question a lot of plugins of @patrickkfkan are added in the 3.xx but still missing youtube2 plugin when,
will it be added to the list of plugins?

best regards,


Hi again,

I have a question of general interest. Some time ago, I suggested to add an update.sh script to the plugin framework…

…and the Big Boss @volumio found that it was a nice idea:

The logic behind this request is very simple: if you have install.sh and uninstall.sh scripts able to perform tasks with sudo permissions, it is likely that also the update process needs that same feature!

I’m asking because I want to know if you plan to add an update.sh script to the plugin infrastructure or if I have to set up a custom mechanism to update my Minosse DSP plugin.

Thanks :wave: :wave:

@dvo I was wondering the same thing. Youtube2 disappeared from v3 beta a couple of days ago. Just grabbed his v3 version off github and it still works perfectly.

Waiting the stable version, go in IP/dev and enable plugins test mode… :wink:

i run it in any version no problems at all so waiting for stable version seems to be a joke :slight_smile:

I saw a new version from 8080s plugin and install it butI have the same issues
It is very strange that the version that you upload it to github it was working perfectly, is the one from @Fybrox. I use it on 3.145.

Have you installed from "details’ button and select last version?

No, but I know it was 1.02 stable, and the one from details, still 1. 02.but to make sure I will install it again tonight. Thanks
Ps. Before volumio RC beta version I had : working mpd oled plugins, peppy meter and 8080s plugin. Fully working. I have a backup SD card with all of this.
I want to make the same working setup also with volumio 3 release :). Due to this I have started with 8080s plugin than move to mpd
Then my next project is to build a second player for my multiroom setup :slight_smile: . Regards

Ah yes, I reflashed my sd and forgot to set the test mode back. Thanks.

Hi @balbuze,
I went to plugins, click on details and installed v 1.02 stable. Same issue. When I press play the Metadata is ok but imedetlly after that on next song this is not change, remains stuck… And is changed after 2 3 minutes…
Ps. I have noticed that at some point Metadata is synched with the song being played but when the song is finished the next song start also the bar is changed to next song, is starting from zero, but the Metadata remains from previous song
@dvo could you please check on your side it his version 102 is working well?. Thanks

plugin store not in test mode : re-installed the plugin 80s80s - italo : out of sync
( first song was enough to see the same result : second time hypnosis should show midnight passion)
should i take a test version?

1.02 from test plugin /details testing :
same issue! if song is half way, a song just starts at 0 and doesn’t update when the song is finished
it doesn’t catch up or fix this…still running out of sync.

1 Like

I have tested with test version 102 and is the same zi do not know t. I there is other. Thanks for your confirmation :).

Ok, I resubmitted my plugin according to the rules and everything should be fine now.

I know that you are hell-bent on releasing the official Volumio 3 tomorrow :grinning: so take your time… :ok_hand:

1 Like

@volumio @mervinio Is there a timeline for when pending plugins will get approval?

Example - IR Controller 3.4.6 by gvolt · Pull Request #34 · volumio/volumio-plugins-sources · GitHub is now open for ~25 days and there is no feedback.

Meanwhile you have annoyed users complaining about unusable systems because of missing plugin-X and wanting to revert to v2.

More handy ones will start installing things manually, which kinda defeats this exercise?

Also as @Darmur pointed out Upgrade to Volumio 3 - GPOI plugin missing - #14 by Darmur perhaps you should package a few common GPIO plugins and publish it, as the original author has abandoned it.

1 Like

Spotify do you know if it is receiving an other update on Volumio3? Its in the plugins now but its not working on v3.

@giorgosperi It’s working perfectly for me. Could you specify what’s not working.

1 Like

Honestly, I have to “study” how to publish a plugin, because I never did that. I will discuss this internally in the team, I don’t think it will be a problem to learn

1 Like

not the spotify connect. the spotify the standalone on volumio. Its telling me that username/password is wrong. i tried 2 accounts and the same thing.

@giorgosperi Ah, I had the same problem authorising both my systems. Wait 24 hours and try again. I think it maybe at Spotify’s end. Working fine for me now.

1 Like