Volumio 3 Plugins store issues and discussion

Ah yes, I reflashed my sd and forgot to set the test mode back. Thanks.

Hi @balbuze,
I went to plugins, click on details and installed v 1.02 stable. Same issue. When I press play the Metadata is ok but imedetlly after that on next song this is not change, remains stuck… And is changed after 2 3 minutes…
Ps. I have noticed that at some point Metadata is synched with the song being played but when the song is finished the next song start also the bar is changed to next song, is starting from zero, but the Metadata remains from previous song
@dvo could you please check on your side it his version 102 is working well?. Thanks

plugin store not in test mode : re-installed the plugin 80s80s - italo : out of sync
( first song was enough to see the same result : second time hypnosis should show midnight passion)
should i take a test version?

1.02 from test plugin /details testing :
same issue! if song is half way, a song just starts at 0 and doesn’t update when the song is finished
it doesn’t catch up or fix this…still running out of sync.

1 Like

I have tested with test version 102 and is the same zi do not know t. I there is other. Thanks for your confirmation :).

Ok, I resubmitted my plugin according to the rules and everything should be fine now.

I know that you are hell-bent on releasing the official Volumio 3 tomorrow :grinning: so take your time… :ok_hand:

1 Like

@volumio @mervinio Is there a timeline for when pending plugins will get approval?

Example - IR Controller 3.4.6 by gvolt · Pull Request #34 · volumio/volumio-plugins-sources · GitHub is now open for ~25 days and there is no feedback.

Meanwhile you have annoyed users complaining about unusable systems because of missing plugin-X and wanting to revert to v2.

More handy ones will start installing things manually, which kinda defeats this exercise?

Also as @Darmur pointed out Upgrade to Volumio 3 - GPOI plugin missing - #14 by Darmur perhaps you should package a few common GPIO plugins and publish it, as the original author has abandoned it.

1 Like

Spotify do you know if it is receiving an other update on Volumio3? Its in the plugins now but its not working on v3.

@giorgosperi It’s working perfectly for me. Could you specify what’s not working.

1 Like

Honestly, I have to “study” how to publish a plugin, because I never did that. I will discuss this internally in the team, I don’t think it will be a problem to learn

1 Like

not the spotify connect. the spotify the standalone on volumio. Its telling me that username/password is wrong. i tried 2 accounts and the same thing.

@giorgosperi Ah, I had the same problem authorising both my systems. Wait 24 hours and try again. I think it maybe at Spotify’s end. Working fine for me now.

1 Like

and now it worked…probably as you said it was spotify’s end


@crieke @mervinio
Please have a look at the category where the RemotePi plugin appears in the plugin store.

Currently the plugin is filed under “User Interface” but the actual plugin type is “system_hardware”. Would be nice if the plugin could be moved accordingly.

1 Like

17 days ago I submitted a new plugin called “Minosse DSP”, and since then I also submitted two updated versions. I also created the required pull requests to volumio-plugin-sources repo on GitHub for each submission.

Up to now, I haven’t received any feedback and my plugin doesn’t appear among the " Plugins Test Mode" ones.

So, I would like to know how long a developer has to wait before having some acknowledgement from the Volumio team. Thanks.

Thing is, we have a huge backlog of plugins to test, this is why it takes time for us to look at plugins now.
So, just some patience and you wil receive feedbacks

Ok, thanks for your prompt reply.

Cross posting from github PR: Lastfm major update by @Saiyato so we don’t loose concerns.

Ok just did a quick test, it requires way more steps to rework plugins for me, because I typically treat my test lab as expendable (I sometimes just break stuff), I tend to re-image a few times a night just to be on the safe side and test fresh installs.

Maybe I’m doing something wrong, but I need to follow the below steps to submit plugins:

  1. clone the repo (note: as the repo grows, this might take longer)

  2. volumio plugin init → creates the directory, I think you can do this manually as well

  3. Stage the changes (if you try to submit, the message will tell you this) → git add * (which stages everything in the current directory)

  4. Now you must commit the changes, this requires a username and email address

    >volumio@volumiotest:~/volumio-plugins-sources/lastfm$ git commit
    *** Please tell me who you are.
      git config --global user.email "you@example.com"
      git config --global user.name "Your Name"
    to set your account's default identity.
    Omit --global to set the identity only in this repository.
    fatal: unable to auto-detect email address (got 'volumio@volumiotest.(none)')

    You can just use bogus info there.

  5. Staging + committing however is not enough, you need to push them to origin “Your repository contains changes that are not pushed to origin. Please push your changes. Use ‘git push’ to push all changes.” This requires your credentials:

    volumio@volumiotest:~/volumio-plugins-sources/lastfm$ git push
    Username for 'https://github.com':

To be honest, this is kind of a thing for me; so here I stopped. But I presume I can submit afterwards.

1 Like

Just thinking out loud, as I’m not too fond of logging into GH on my test Volumio instance (just broke another one). Can we maybe overload the plugin submit function with the PR reference instead?

That way you can skip the whole local GH administration on a Volumio instance and still leverage the protected (compiled C) binaries to publish BETA versions to the store.

Hmm, not sure I follow what compiled C binaries you’re talking about?

My bad, thought that it would be done by the myVolumio module. While in fact it’s just a push with your bearer token. (see: volumio3-backend/pluginhelper.js at 359b2717b79cfc72b7d1c918d0fc2885a93bca70 · volumio/volumio3-backend · GitHub)

Reading this confirms my assumption, if git status doesn’t return anything of the likes that your changes are not staged, committed or pushed; your plugin is packaged and pushed to the upload endpoint (see L708).

Also, this means that if I login to my GH account, submitting would push the changes on my Volumio instance upstream… thinking out loud now… if I just clone my own branch on my Volumio instance, instead of cloning from the source-repo. The changes are already in the cloned directory and I should be able to submit; nothing is staged or needs to be committed/pushed.

Let me sit on this for a while… I think I found a solution, just need to define the correct steps and order thereof.