Volumio 3 Plugins store issues and discussion

Thank you for all the feedback. We see that there are things to improve on the publish procedure. Please bear in mind that changing the current procedure, while maintaining the new functionalities of the plugins store is quite complex. We are brainstorming and we will probably find a suiting solution soon. In the mean time, all suggestions are welcome. Keep them coming!

1 Like


I guess I got some issues too.
Volusonic have been merged some days ago. The plugin is visible in the store (pi) but not installable, the UI stick @10%. I tryed to download it directly with the link in the detail pan and I got

"Plugin version not found"

The plugin is not present in the store for amd64 build so I couldn’t test it.


What is the download address for the “autostart” plugin? I want to install it from the command line and I can’t find the correct wget https: // …

Looks like everything is ok now.
It was maybe a temporary glitch or someone did something. Whatever thanks guys

I don’t believe it is available yet. The devs are working towards ensuring all Volumio2 plugins are complaint and work well with Volumio3 before making them available!

EDIT: You can track progress here Pull requests · volumio/volumio-plugins-sources · GitHub

@mervinio According to @pauljwells findings it appears that the plugin store lists the version with the highest number - regardless if it’s a beta and if plugins test mode has been enabled.

So even if the user has plugins test mode disabled the version number of a beta is shown (if it’s higher than the newest stable version) in the list of available plugins. If the user then opens the “Details” page this (beta) version is missing.


I’ve just submitted a plugin using ‘volumio plugin submit’. I’m opening this topic because this is my first time and the whole process for plugin submission and approval is unclear. I can’t find any docs specific to Volumio 3, only outdated info for Volumio 2.

So, could, please, someone from the Volumio team confirm if the ‘Minosse DSP’ plugin submission was successful? I can’t see it in GitHub’s volumio-plugins-sources…

My plugin isn’t in the volumio-plugins-sources fork repo, it has a GitHub repo on its own:

Sorry, but I’m new to this GitHub stuff. What shall I do?

question a lot of plugins of @patrickkfkan are added in the 3.xx but still missing youtube2 plugin when,
will it be added to the list of plugins?

best regards,


Hi again,

I have a question of general interest. Some time ago, I suggested to add an update.sh script to the plugin framework…

…and the Big Boss @volumio found that it was a nice idea:

The logic behind this request is very simple: if you have install.sh and uninstall.sh scripts able to perform tasks with sudo permissions, it is likely that also the update process needs that same feature!

I’m asking because I want to know if you plan to add an update.sh script to the plugin infrastructure or if I have to set up a custom mechanism to update my Minosse DSP plugin.

Thanks :wave: :wave:

@dvo I was wondering the same thing. Youtube2 disappeared from v3 beta a couple of days ago. Just grabbed his v3 version off github and it still works perfectly.

Waiting the stable version, go in IP/dev and enable plugins test mode… :wink:

i run it in any version no problems at all so waiting for stable version seems to be a joke :slight_smile:

I saw a new version from 8080s plugin and install it butI have the same issues
It is very strange that the version that you upload it to github it was working perfectly, is the one from @Fybrox. I use it on 3.145.

Have you installed from "details’ button and select last version?

No, but I know it was 1.02 stable, and the one from details, still 1. 02.but to make sure I will install it again tonight. Thanks
Ps. Before volumio RC beta version I had : working mpd oled plugins, peppy meter and 8080s plugin. Fully working. I have a backup SD card with all of this.
I want to make the same working setup also with volumio 3 release :). Due to this I have started with 8080s plugin than move to mpd
Then my next project is to build a second player for my multiroom setup :slight_smile: . Regards

Ah yes, I reflashed my sd and forgot to set the test mode back. Thanks.

Hi @balbuze,
I went to plugins, click on details and installed v 1.02 stable. Same issue. When I press play the Metadata is ok but imedetlly after that on next song this is not change, remains stuck… And is changed after 2 3 minutes…
Ps. I have noticed that at some point Metadata is synched with the song being played but when the song is finished the next song start also the bar is changed to next song, is starting from zero, but the Metadata remains from previous song
@dvo could you please check on your side it his version 102 is working well?. Thanks

plugin store not in test mode : re-installed the plugin 80s80s - italo : out of sync
( first song was enough to see the same result : second time hypnosis should show midnight passion)
should i take a test version?

1.02 from test plugin /details testing :
same issue! if song is half way, a song just starts at 0 and doesn’t update when the song is finished
it doesn’t catch up or fix this…still running out of sync.

1 Like

I have tested with test version 102 and is the same zi do not know t. I there is other. Thanks for your confirmation :).