Volumio 3 on RPI 4 restarts every few minutes

  • They each have their own unique address. I haven’t set up fix IP addresses for them but they always come up on the same.

  • There are walls or floors between the access point and each of these.

  • I haven’t tried wired connections. I don’t have wired network in house

  • Haven’t tried putting local music on all three. Since I loaded 3.378 the cards are clean (except the system)

Follow up to previous observation. I powered #3 off and now #1 & #2 are playing fine.

Sorry for all the question, but it’s difficult debugging via a forum :slight_smile:

  • Are you able to perform the same tests closer to your access point and what are the results?
  • If you numbered your rPi’s, like #1, #2 and #3, can you also play #2 and #3 together or #1 and #2 without issues?
  • Please also perform the test with some local files attached to the rPi’s. I need to have a way to exclude the wireless connections.

It seems related to connectivity issues, as the WiFi in a rPi is not the strongest kind and there are to may obstacles/distance between the access point and rPi’s.

If things error out, please provide the logs, so we have something to look into.

Hello, is any developer looking into this issue? Do you need further data?
After providing the logs, I rolled back to version 3.324, which is stable for me.
If you need further testing on 3.378, I would be happy to help

Thanks for working with me on this!
I can confirm that either #1&#2 or #2&#3 are successful combinations.
I posted logs for #1 and #2 back on Nov2. That is post #40 in this chain.

I’ll have to wait to do further testing closer to the access point and with local music.
I’m in the midst of a project that needs to get wrapped up.

When I get clear I’ll do those tests and report back here.

I do suspect WIFI is at the heart of this. Not sure how the change to 3.378 impacted that. We’ll see what the tests say.

Thanks again

it might be related to new drivers in the updated kernel.
Since any combination of 2 pi’s are working, I am pretty convinced the issue is related to hitting the max throughput of your WiFi connections.

looked at one of the logs, but 30000 hits with, I think the rPi gives up…

Hi @Wheaten, I have the same issue also when connected via LAN (see top of thread, including log posts)

Volumio is looking into this issue.


Hi In all logs i see a repeative error like:
info: Discovery: Browse raised the following error Error: getaddrinfo -3007


Nov 01 09:07:17 bedroom volumio[11914]: info: Starting Shairport Sync
Nov 01 09:07:17 bedroom volumio[12210]: [Vollibrespot] : Connecting to AP "ap-gue1.spotify.com:443"
Nov 01 09:07:17 bedroom volumio[11914]: |||||||||||||||||||||||| WARNING: FATAL ERROR |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||
Nov 01 09:07:17 bedroom sudo[12225]:  volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/systemctl restart shairport-sync
Nov 01 09:07:17 bedroom sudo[12225]: pam_unix(sudo:session): session opened for user root by (uid=0)
Nov 01 09:07:17 bedroom volumio[11914]: Error: getaddrinfo -3007
Nov 01 09:07:17 bedroom volumio[11914]:     at errnoException (/volumio/node_modules/mdns/lib/resolver_sequence_tasks.js:199:11)
Nov 01 09:07:17 bedroom volumio[11914]:     at getaddrinfo_complete (/volumio/node_modules/mdns/lib/resolver_sequence_tasks.js:112:10)
Nov 01 09:07:17 bedroom volumio[11914]:     at GetAddrInfoReqWrap.oncomplete (/volumio/node_modules/mdns/lib/resolver_sequence_tasks.js:120:9) {
Nov 01 09:07:17 bedroom volumio[11914]:   code: -3007,
Nov 01 09:07:17 bedroom volumio[11914]:   errno: -3007,
Nov 01 09:07:17 bedroom volumio[11914]:   syscall: 'getaddrinfo'
Nov 01 09:07:17 bedroom volumio[11914]: }
Nov 01 09:07:17 bedroom volumio[11914]: |||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

Hi! We have found the issue and we made an experimental test build with the fix. Please put all of the Volumio instances on your network in test mode by going to http://{yourIP}/dev, and update to version 3.391 on the system settings page. This is an unofficial alpha build, if there are any new issues please let us know. Please disable test mode after the update is installed.

Please let us know if this fixed your issue.

Here is the link to the image if you decide to flash a new one:

@Richetto @sharberger @plntbsd @Rinaldo_P @marcon

Can you please report back if this solves your issue?
This is very important to us to know

So far no joy.
I have put all three devices into Test mode.
I have run the download.
Under system it still says they are in system 3.378.
I briefly had all three running at one time.
Now all are silent and #3 is repeatedly restarting.

I will attempt again using the download and rebuild the SD cards

Log from System #1

Log from System #2

Log from System #3

NOTE: these logs were pulled after running the over the air update but before attempting to flash the SD cards with version 3.391 via the link above

Will update after flash

Sorry for the extended post, I am limited to 3 replies so I am adding to this as I work through this.
================ indicates additional efforts ======== newer info is at the bottom

Erased (with Disk Utility) and flashed all three cards.
I notice after flashing the files are still dated Sept. 30 2020.

Is this correct for the beta update?

Installed re-flashed card into system #1.
System Settings still identifies the current system on that device as 3.378.

Sounds like I am not accessing the correct files for the beta.

I was able to run over the air update to 3.392 on System #1
Attempting sam eon System #3 and it is restarting before the update completes.

Succeeded with OTA update on system #3.
Good news - the scan was able to find the USB storage attached to system #1 and mount it.
That was not possible under 3.378

Succeeded with OTA update on system #2 - took at least 6 attempts, I lost count
Scan has not be able to find the USB storage attached to system #1.
This device (#2) is furthest physically from the access point.
When #3 connected it was right next to the access point

All three systems are currently playing without restarting cycles.
So far - so good.

Hope that’s helpful feedback

Still need to get shared library working. Then the holy grail of multi-room synchronized music.


3.392 Feedback
The name of the system does not appear with the little speaker icon at lower right of screen.
Remote control devices does not list any available devices even though all three are playing and on the same network.
I can access them each separately by reopening the app and choosing the one I wish to control

I have tested version 3.395. The system look stable now: no repeated player restarts. Good Job!

Three issues to report:

  1. The player consistently restarts when I click the button to add a network drive in the sources page

  2. Volumio default UI at start up is Manifesto, although in the Visual effects page the menu shows contemporary. Changing UI and saving configuration has no effect.

  3. Some issues when adding network drives (see below)

Below a detailed report of what I did (2 sessions), with logs

-------- SESSION 1 ------

Connected RPI 4 to LAN and DAC.

Flashed a new 64Gb sd card with Volumio 3.324 (stable for me)

Connected to Volumio.local via browser and completed the initial guided setup (language Italian)

Connected to Volumio.local/dev and enabled test mode, plugin test mode, ssh

Upgraded OTA to 3.395.System restarted after the update was completed, but did not come back again. No volumio wifi net, no volumio on the router.

I manually power cycled the system and it was back. Volumio.local did not work any more and I connectd using the IP address.

Volumio started with the Manifest UI, although, when going to the visual effects page (effetti visive) it says Contemporary”

System stable. Played some radios

Tried to connect the network NAS (DLNA). The moment I cliecked on the add new drive button, the player restarted

Tried again, and it did restart again.


Powered down Volumio (via web interface)

-------- SESSION 2 ------

Powered Volumio back on and listened music on radio for a while. System seems stable.

Tried to add network drive again (network disk on Synology disk station using NFS). Player restarted as before (waited for it to come back)

Added /volume1/music and I got an error

Added volume1/music and went successfully.

Viewing the source page, I get the same drive connected twice (with exactly the same path), scanning in progress. System stable

Waited for the scan to complete. The rotating arrows keep showing, even when scan is finished)

The rotating arrows do not

Successfully browsed the library and played some music.

Here the logs of session 2


@Richetto thanks for reporting. The restart issue has just been fixed.

Please post in the other thread, devs are now monitoring the other one:

Thanks, will do

My apologies for the delay, I just got home from being out of town the last week. So far I’ve only been able to get one device updated to 3.395 as the other is still cycling through the reboot faster than I can get into the gui.

No terminal access atm but I’m still getting a reboot loop with 3.395, can provide logs in the morning.

I did a clean install of 3.391 on a RPi 4 and I am still experiencing the “Configuration Updated Player Successfully Restarted” loop


it’s cycling through the loop every 19 seconds on both devices. on the device that I have dome the clean installs on intermittently it will do a full reboot with startup sound. the device that has only been upgraded just the configuration update cycle every 19 seconds.

another thing I have noticed is that nothing shows up in remote control devices, or group devices.

I had the same problem but changing the DNS to fixed DNS solved the problem for me. At least for now. I used the Google DNS as first DNS and my local router as second (auto DNS works for all other machines on our network).

Prior to that I did try all the tricks suggested above and updated to the last version.

I’m working on this problem right now. I tried to restart the dhcpcd service and got the following error from “journalctl -xe”, “Not running dhcpcd because /etc/network/interfaces defines some interfaces that will use a DHCP client or static address”.
this is the /etc/networks/interfaces file contents:

auto lo
iface lo inet loopback
allow-hotplug eth0
iface eth0 inet dhcp
allow-hotplug wlan0
iface wlan0 inet manual

did you run into this?