Volumio 3 constant restart

Volumio 3 Issues?

So I’ve updated to 3.175 and it is repeatedly updating settings. I can’t even finish playing 1 song. This is a pi4 b hooked up (usb) to a Gustard xpro26 DAC. Anyone else experiencing this? Volumio2 worked fine.

Keeps saying "Configuration update

Player successfully restarted"

Hello @logan7626. This behaviour has been reported before: Volumio 3 issues: hints and solutions

I’d be tempted to re-flash the SD card with the latest version. Unfortunately this would require you to redo all your settings. If you have a spare SD this would be worth trying.

We don’t know what happens there and we need more info to fix it.

Please

thanks

@volumio

You can reproduce the loop with a slow SD card, either by bad flashing (balenaEtcher seems to give most issues), low class or SD is getting EOL.
I was able to reproduce it on the Odroid N2+ and an ancient 4GB SD.

Thanks, but we need the log (as requested above) to find out what the issue is

Done
http://logs.volumio.org/volumio/PZVG1HP.html

Thanks!
This seems to be due to a device in your network that does not respond to queries for our DLNA browser.

Would you mind:

  • Disabling DLNA Browser (from My Music → Sources)
  • Reboot
  • Let us know if you still experience this issue

Thanks

1 Like

Still doing the issue. I don’t know if this helps but my Raspberry Pi’s are behind a Firewall/Router, Firewalla Gold to be precise.

You have PM :wink:

I have the same issue. Just after login with my premium Account it starts a loop updating the configuration in about every 15s.

“Configuration update
Player successfully restarted”

Update:
I turned off all Sources (UPNP Renderer, Shairport-Sync, DLNA Browser). Everything works fine, until i log in with my Premium Account. Just after that, the Looping begins. Tested on both Versions 3.179 and 3.165. As described in Volumio 3 issues: hints and solutions I went back to 3.165. Same Issue. The Log is from 3.165.

Link to the Logfile: http://logs.volumio.org/volumio/imqT6SI.html

Update 2:
tail -f /var/log/mpd.log show repeating:

Jan 13 22:15 : zeroconf: No global port, disabling zeroconf
Jan 13 22:15 : client: [0] opened from local
Jan 13 22:15 : exception: No such directory
Jan 13 22:15 : client: [1] opened from local
Jan 13 22:15 : zeroconf: No global port, disabling zeroconf
Jan 13 22:15 : client: [0] opened from local
Jan 13 22:15 : client: [1] opened from local
Jan 13 22:15 : client: [2] opened from local
Jan 13 22:15 : client: [3] opened from local
Jan 13 22:15 : client: [4] opened from local
Jan 13 22:15 : client: [5] opened from local
Jan 13 22:15 : client: [6] opened from local
Jan 13 22:15 : client: [7] opened from local
Jan 13 22:15 : client: [8] opened from local
Jan 13 22:15 : client: [9] opened from local
Jan 13 22:15 : client: [10] opened from local
Jan 13 22:15 : client: [11] opened from local
Jan 13 22:15 : client: [12] opened from local
Jan 13 22:15 : client: [13] opened from local
Jan 13 22:15 : client: [14] opened from local
Jan 13 22:15 : client: [15] opened from local
Jan 13 22:15 : client: [16] opened from local
Jan 13 22:15 : client: [11] closed
Jan 13 22:15 : client: [10] closed
Jan 13 22:15 : client: [16] closed
Jan 13 22:15 : client: [15] closed
Jan 13 22:15 : client: [14] closed
Jan 13 22:15 : client: [13] closed
Jan 13 22:15 : client: [12] closed
Jan 13 22:15 : client: [9] closed
Jan 13 22:15 : client: [8] closed
Jan 13 22:15 : client: [7] closed
Jan 13 22:15 : client: [6] closed
Jan 13 22:15 : client: [5] closed
Jan 13 22:15 : client: [4] closed
Jan 13 22:15 : client: [3] closed
Jan 13 22:15 : client: [2] closed
Jan 13 22:15 : client: [1] closed
Jan 13 22:15 : client: [0] closed
Jan 13 22:16 : zeroconf: No global port, disabling zeroconf
Jan 13 22:16 : client: [0] opened from local
Jan 13 22:16 : exception: No such directory
Jan 13 22:16 : client: [1] opened from local
Jan 13 22:16 : zeroconf: No global port, disabling zeroconf
Jan 13 22:16 : client: [0] opened from local
Jan 13 22:16 : client: [1] opened from local
Jan 13 22:16 : client: [2] opened from local
Jan 13 22:16 : client: [3] opened from local
Jan 13 22:16 : client: [4] opened from local
Jan 13 22:16 : client: [5] opened from local
Jan 13 22:16 : client: [6] opened from local
Jan 13 22:16 : client: [7] opened from local
Jan 13 22:16 : client: [8] opened from local
Jan 13 22:16 : client: [9] opened from local
Jan 13 22:16 : client: [10] opened from local
Jan 13 22:16 : client: [11] opened from local
Jan 13 22:16 : client: [12] opened from local
Jan 13 22:16 : client: [13] opened from local
Jan 13 22:16 : client: [14] opened from local
Jan 13 22:16 : client: [15] opened from local
Jan 13 22:16 : client: [16] opened from local
Jan 13 22:16 : client: [15] closed
Jan 13 22:16 : client: [14] closed
Jan 13 22:16 : client: [13] closed
Jan 13 22:16 : client: [12] closed
Jan 13 22:16 : client: [11] closed
Jan 13 22:16 : client: [10] closed
Jan 13 22:16 : client: [16] closed
Jan 13 22:16 : client: [9] closed
Jan 13 22:16 : client: [8] closed
Jan 13 22:16 : client: [7] closed
Jan 13 22:16 : client: [6] closed
Jan 13 22:16 : client: [5] closed
Jan 13 22:16 : client: [4] closed
Jan 13 22:16 : client: [3] closed
Jan 13 22:16 : client: [2] closed
Jan 13 22:16 : client: [1] closed
Jan 13 22:16 : client: [0] closed
Jan 13 22:16 : zeroconf: No global port, disabling zeroconf
Jan 13 22:16 : client: [0] opened from local
Jan 13 22:16 : exception: No such directory
Jan 13 22:16 : client: [1] opened from local

And the link to your system log file is …?

as soon as I set “Activate MyVolumio On Devices” enabled to “off”, the looping stops and Volumio works as expected. When I set to “on”, the looping starts again.

btw, there’s a topic with the same issue, better to merge and continue there.

Anyone got a fix for this?

@deadlyrick Looks like it was solved at the end of this discussion.

If you’re not happy trying the beta release, you can wait for the next stable update, which must be coming soon.