Volumio 3 Buster Beta for RPi

Hi,

Thanks for the log.
It appears that the ST4000LM024 disk partitions are being skipped

Jun 09 21:09:43 volumio-rp4-lan volumio[699]: info: Ignoring mount for partition: boot
Jun 09 21:09:43 volumio-rp4-lan volumio[699]: info: Ignoring mount for partition: volumio
Jun 09 21:09:43 volumio-rp4-lan volumio[699]: info: Ignoring mount for partition: volumio_data
Jun 09 21:09:43 volumio-rp4-lan volumio[699]: info: Ignoring mount for partition: 4TB_SMR

This can only mean that the disk is not being reported by the OS as a removable USB device. We can try to find out why this is, see below.
The check is new for Volumio 3, due to the fact that removable disks are being handled slightly different because of Debian Buster.
Reading any internal disk in the system is causing seriously performance issues (with a deadlock in some situations) with x86 installations, so this was temporarily blocked by only allowing usb disks.
It will be replaced by a future option for the user to select the disk(s) to be read, similar to the way a network share can be selected.

Could you show us the result of

lsblk -o RM,HOTPLUG

It may give us a clue why the disk is not reported as removable device.

This is the result:

volumio@volumio-rp4-lan:~$ lsblk -o RM,HOTPLUG
RM HOTPLUG
0 0
0 1
0 1
0 1
0 1
0 1
0 1
volumio@volumio-rp4-lan:~$

my request was “suboptimal” :flushed:
Could you add the name?

lsblk -o NAME,RM,HOTPLUG

Here you go:

Thanks!
The disk is not detected as a USB device (that is why Volumo skipped it) and not as removable either. HOTPLUG will not help us much, it may not safe as eSATA devices are hotplug-capable.
To be continued…

1 Like

Another request:

lsblk -o NAME,TRAN
or
lsblk -do NAME,TRAN
or 
lsblk -dno NAME,TRAN /dev/sda 

This may be a better way to check for USB

Here you go, Sir

This confirms the issue, we’ll fix it.
Thanks for reporting!

I know this is out of scope of the beta, but pass it as an observation. Generally V3 beta has worked well. I installed it because I wanted remote debugging, in VSCode, for some i2c display software I was porting from python to node.js.
Part of my software has infra-red remote control. I discovered that infra-red is now part of the kernel via gpio-ir. However, when I add dtoverlay=gpio-ir,gpio_pin=19 # for receiving data, to /boot/config.txt, my IQAudio dac+ card can’t be found by volumio. Volumio displays an red alsa error when selecting a track. Remove the line and the IQ Audio works fine again.
This on a Pi3 with 17/5 beta image.

regards,
David

Maybe GPIO19 is already used by your DAC? My HifiBerry DAC+ uses GPIO18…21 for it’s own signaling. I had this problem recently when selecting “spare” GPIO for a rotary encoder volume control.

I did see a message about the GPIO being used in a HifiBerry forum last night. I will try another GPIO pin.

Thanks Andrew…

I should of re-read the iq-audio docs… I have had this board for a few years, I thought I used GPIO18 before, but the documentation says it is used for i2s…so I was stamping all over the codec! When I was connecting it again… something in the back of my mind was telling me it should be connected further down the board.

On another topic the socket-io api is working fine in V3.

regards,
David

Hi, I have a fresh install of the newest beta po rpi and plugins management is empty… Are plugins disable in this beta?

image

I’ve been trying out beta3 and the most noticeable problems are volume control slider does nothing (volume doesn’t change at all), my USB thumb drive is seen by OS but is never seen/added to my library.
running on rpi3b+ using iqaudio DAC pro. the USB stick is 64g Memorex cheapo.

Hallo… reporting the problem
I am using v3.074… with raspberry 3 model B+
using hifi AIODE Digi Pro Digital out
in i2s selector, i used to choose HifiBerry Digi+ Pro…
now in v3, everytime i choose HifiBerry Digi+ Pro, it reporting error when playing the song and the song did not play at all…
so i choose HifiBerry Digi, now it play… but all the song play in slower… it is very noticeable cause i already try some of my song collection and all of them play slower…

Hello

confirm after i using volumio v2.882, everything back to normal… i can select HifiBerry Digi+ Pro and using Hifi AIODE Digi Pro Digital out… the speed of playback also back to normal…