Volumio 3 & Autostart

I’ve got Volumio 3 up and running. I’ve got my NAS share mounted, and I’ve even managed to create a playlist from the music on it, and it’s playing.

I’m trying to figure out a way to make my playlist start playing on boot, and also randomize the queue if possible. I see that there was a plugin available to do this, but based on the forum posts I’ve read, it no longer works.

Is there a solution for this with Volumio 3?

1 Like

Hello and welcome @timjohnson408. The autostart plugin you’d need is not yet ported to V3. You can find the status of all plugins here Volumio 3 Plugin migration status

2 Likes

Okay, so maybe I just have bad timing for my project! Is there still a way to download 2.915? Can’t seem to find anywhere to download it (for RPi).

Thank you for the response, btw!

Click on the banner at the top of the page, then look at the first issues listed: “Volumio 3 does not work for me yet…”
Note that Volumio 2 still works, but you are unlikely to get support for it.
Keep an eye on Volumio 3 Plugin support progress and switch as soon as you can.

Thank you! After trying out two other music player solutions, I’m happy I’ve found one with active community members and developers!

1 Like

Really hoping autostart gets done quickly. Then i will migrate my fleet of 3 RPI’s.
Useless without autostart as a family music player.
I have it setup so you just turn it on and music plays.
set to radio paradise flac.

Autostart is really important for me. I fixed autostart by adding a crontab entry
crontab -e
@reboot sleep 120 && /home/volumio/start.sh

— script content: /home/volumio/start.sh
/usr/local/bin/volumio play

After reboot - power on, latest used radio stream channel resumes and here you go.

4 Likes

Works for me now after a couple more steps:

Had to install cron: sudo apt-get install cron
Had to insert shebang at start of script: #!/bin/bash
Had to make start.sh executable: sudo chmod +x start.sh

1 Like

resolved: crontab -e 00 09 /usr/local/bin/volumio play
00 18 /usr/local/bin/volumio stop

1 Like

Can someone please post a more detailed procedure for this autostart work around.
I am not savy enough to figure it out from these notes.
txs

I will join the request. Maybe someone will tell you in great detail for the most inexperienced how to make the autoplay of the Internet radio playlist begin after switching on (rebooting). Thank you in advance.

1 Like

The autostart plugin works flawless on V3.xxx, only an update for NPM is required. Already did it in this zip file. Make sure to adjust the time, so you’re sure Volumio is fully started. Currently I set it to 40000 (40 seconds)
autostart.zip (152.4 KB)

  • unzip it
  • Place it in your home folder: /home/volumio
  • Open putty and run the command:
    cd autostart && volumio plugin install
4 Likes

It really works. It is very clear how to do it. Thank you very much.

Hello Wheaten!
Cool !
But for me it is not working, maybe you could help me ?
i can see the plugin in the Web-UI, when i switch it to ON settingbutton appears.
But the state still is Red-dot inactive.
If I klick on settings, no configuration is available appears.
If I do “volumio plugin list” the following appears:
prettyName: ‘AutoStart’,
name: ‘autostart’,
category: ‘miscellanea’,
version: ‘1.1.2’,
icon: ‘fa-play-circle-o’,
isManuallyInstalled: false,
enabled: true,
active: false

how can i activate it ?

Best regards and many thanks for your help!
Danny

1 Like

Weird.
Please try the following.

cd /data/plugins/miscellanea/autostart
npm install

if that doesn’t work, post your log as i have no clue otherwise. Lost my Crystal bal.

1 Like

Thanks for your help !!! and the quick answere !

i tried but it still does not work, its not shown anymore on the web-UI

hmmm, i could not find the volumio.log (/var/log/…)
just the mdp.log:

-bash-5.0$ cat mpd.log
Mar 09 14:11 : zeroconf: No global port, disabling zeroconf
Mar 09 14:11 : zeroconf: No global port, disabling zeroconf
Mar 09 14:12 : client: [0] opened from local
Mar 09 14:12 : exception: No such directory
Mar 09 14:12 : client: [1] opened from local
Mar 09 14:12 : zeroconf: No global port, disabling zeroconf
Mar 09 14:12 : client: [0] opened from 127.0.0.1:36078
Mar 09 14:12 : client: [1] opened from 127.0.0.1:36080
Mar 09 14:12 : client: [2] opened from 127.0.0.1:36092
Mar 09 14:12 : client: [3] opened from local
Mar 09 14:12 : client: [4] opened from 127.0.0.1:36104
Mar 09 14:13 : client: [5] opened from 127.0.0.1:36292
Mar 09 14:13 : client: [6] opened from 127.0.0.1:36296
Mar 09 14:13 : exception: Failed to read mixer for ‘alsa’: no such mixer control: PCM
Mar 09 14:13 : client: [0] closed
Mar 09 14:13 : client: [1] closed
Mar 09 14:13 : client: [2] closed
Mar 09 14:13 : client: [4] closed
Mar 09 14:14 : client: [5] closed
-bash-5.0$

1 Like

We need the log generate by Volumio: Sending logs for troubleshooting - Volumio Documentation
And paste the generated link here, so we can access it.

1 Like

The content of the zip is not met requirement for volumio3

1 Like

Hi Balbuze,
I am not the developer nor considering to become one nor even want to spend time to go through all new requirements at this moment. I respect those who did.
I just took the zip file from my V3.3xx system which is working and also for @trekaf (which is a really funny name in Dutch) and hoped it would work for DannyH to

2 Likes

ok no problem :wink:
I just wanted to point that some plugin needs to be updated to work with no effort on volumio 3

1 Like