Volumio 3 Access to music on NAS not working anymore

The update to Volumio 3 on Raspi was the wrong decision. I really regret it!
My Music is stored on a NAS (FritzBox). With Volumio 2 I had the last year trouble-free operation with access to the NAS-stored music.
Volumio 3 doesnt work anymore. I spend hours on that issue. Volumio 3 is accessing the NAS, when I add the path twice. Not with just a single entry. Path is activated even with one entry but no Music wil be listed. When readout of NAS-content is complete, I can delete one of both entries. It works then as requested - as long as Volumio isn’t disconnected from power. Even reboot is ok.
When starting Volumio the next day, the NAS is activated but I have no access to the music anymore. The NAS is not down, access from other devices beside volumio is seamless possible.
I remember access problems to the Fritz-NAS with Volumio in the past. But after endless trials and then successful connection (I still dont know the reason why it worked) I had with Volumio 2 access for more than a year. Even the updates didn’t affected that. Now the problems starting again.
Need qualified support.

Something is seriously broken in handling NAS shares, I experience a similar issue: Volumio 3 NAS source empty despite mount works and files visible in shell

Hope this gets fixed soon, it makes Volumio 3 useless at the moment.

1 Like

I tried your workaround and I experience the same - adding the same source a second time under a different name makes Volumio start scanning my files and I can access, browse, play them. A weird bug.

Additional info: despite adding 2 sources, only a single one is actually mounted.

Volumio3 is not working well with the FRITZ!OS: 07.29

Reacting to this post because is resembles my latest experiences.
What happened. A review made me think Volumio3 was no longer a beta-version. So I decided to push the “Check for Updates” button under “Settings/System Settings”. And away it went to fetch the upgrade. Of course I neglected the advice to keep a back-up and so on, what could possibly go wrong.
Well my internet provider had just decided it was time for an update of the FRITZ!Box 5490, to which I attached a Samsumg T5 SSD-disk drive. This is my FRITZ!NAS where I have stored my ripped CD-collection. It took a while to re-connect the NAS-drive because the update to Volumio3 did not preserve my previous settings, but once connected the problems were far from over. Volumio does (did) not recognize nor find any music at all on the disk. It took me two days to trouble-shoot this.
A long story short. Resetting the FRITZ!Box 5490 activated the newly upgraded software there. This became clear via the media Fritz!Media server which I use on my TV-set (LG-WebOS)
This didn’t solve the Volumio3 problem on my Raspberry3. A fresh download and entire new initial install of Volumio3 didn’t either. So it has nothing to do with the upgrade process, it just does not work. Then I decided to go back and re-install Volumio 2.917 on a separate SD-card. Connected the FRITZ!NAS drive again, and behold, everything back as it was before. So it had nothing to do with the FRITZ!Box 5490 upgrade. I will keep using Volumio2 for a while I guess.
Resume. Volumio3 is not working well with the FRITZ!OS: 07.29
In the near future I will try and take a look at Volumio3 log-files if can find out where they are.

There are multiple threads with this issue, unfortunately no solution found yet. It has nothing to do with the smb/cifs mount, but probably with mpd itself. Unfortunately, I was not able to find any clues in the log, even in verbose mode there. I’m back on v2 now, after a week with the kids not having their beloved music in the rooms :wink:

Fritz!Nas boxes frequently throw up problems on this forum, usually becase the shared folder name is not what you are “expecting/think it is.” Can we please have some proper reports of exactly how you have tried (that means as many details as you have) to set up your Fritz!Nas. Also, please post system logs too people :wink:

Would you share some system logs please?

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile:

Checked the logging, which I could tell from the file-date, presumably created by the indexing process (mpg123). This file is in directory /var/log/mpg123.log
[src/libmpg123/readers.c:1184] error: Cannot open file …mp3: Stale file handle
Jan 04 11:50 : mpg123: libmpg123 failed to open /var/lib/mpd/music/NAS/…/… etc.
A generic mpg123 error
Did some searching on these community pages. A solution was already mentioned here before. So I have tried that too.

  1. In order to start all over again, remove the disk.
  2. Restart Volumio once, to be sure Volumio dismounts the volume with the old settings.
  3. Recreate the disk and specify under Advanced Options “noserverino”
  4. Hit Apply to store these settings.
    It worked for me as well.


Well done for solving the problem. This particular “stale file handle” error has cropped up a number of time since the release of Volumio 3. One to remember & add to the FAQs.

Thanks for the investigation!
I will try and send feedback.
Will take some time.

I like to use the bare minimum of settings required to fullfill the function.
So to use the NAS-function of FRITZ!Box it is sufficient to attach a storage device (USB-diskdrive)
to one of the USB-port on the FRITZ!Box. It has two USB-ports.
Under USB/Storage tick two settings related to “USB Devices and Storage Media on the FRITZ!Box”
V- Storage (NAS) function of FRITZ!Box 5490 enabled
V- Refresh index automatically

Furthermore, because this is about “Home Network Sharing”
V- Access via network drive (SMB) enabled
needs to be chosen. I guess Volumio doesn’t need SMBv1 anymore.

A point of attention could be, under “USB Settings”, the time out setting for “Energy-saving Mode for USB Hard Drives”. I have got it connected to an USB 3.0 port.
Switch USB hard drive to energy-saving mode when idle: 120

But maybe a shorter time out will do.
The Samsung T5 disks come in format “exFAT”. The FRITZ!Box only takes EXT2, FAT, FAT32 or NTFS formatted disks. So this has to be changed to one of those formats. I have chosen NTFS. The volume name is important to remember.
On my Windows-10 PC the FRITZ.NAS is visible too of course. My home-network has no DNS-server, so instead of ‘fritz.box’ comes its IP-address when specifying this in Volumio.

Option ‘noserverino’ survived several restarts in between.
Access to fritzbox-nas is still there. :+1:t2:
Thank you!
Should be implemented in the volumio-software.