Volumio 3.3 public release: Volumio HUB features

In my opinion, the button for settings is not needed here.

I don’t understand the “Play here” function or it doesn’t work for me. On my smartphone (Google Pixel 4a), the button is then green and the circle rotates. However, the output stays the same at Volumio.
When changing a track on e.g. Radio - once play here switched off via the popup message - where can I find the option to switch play here back on?
The Play Here button stops responding

Currently running beta on Asus Tinker board and it works flawlessly for me. Will Manifest UI become open-source component? As I understand currently it isn’t.


there are some i18n keys missing or the reference is incorrect.

When you navigate to

Tidal → My Music / artists → select an arbitrary artist

you get something like this (see screenshot)

This occures no matter if you are in “Classic” , “Manifest” or “Contemporary” UI and in Volumio Version 3.251 and 3.369.


I haven’t tested everything yet but am loving the changes so far. I also agree with a volume percentage display, but wouldn’t need this so much if the volume just topped out on the slider at the maximum volume I set on my device. For example I have my max volume set to 70, and when the slider is all the way up, that would indicate you were at that 70.

Thanks guys for your feedbacks, really useful, we are working on them :wink:

Now, for those of you which expressed the interest in Remote Streaming functionality, well, there’s a surprise for you. We have enabled it on this beta.

So, yes, you can try Volumio as your “Personal Music Streaming Service” :wink:

To try it:

  1. Go to https://play.volumio.com
  2. Login
  3. Select your device by clicking the “PLAY” Icon next to your device

  1. Enable playback to your browser by clicking the “Play Here” button, from the Audio Menu

  1. Enjoy, everywhere

Let us know how that works for you, how do you like it, and how important this feature is for you :wink:


Still waiting on multi-channel support. Dolby Atmos is the fastest growing market segment.
Not sure why discontinued chromecast is a higher priority than modern formats. :frowning:

Hi there, thats big news and i am very excited to try the changes. I like most the decision to make the manifest ui accessible to everyone. Thanks a lot, volumio!

I also like the support for chromecast and sonos devices even though I do not own any. Why do not expand the supported devices to selfmade speaker with snapcast client? I would really like to see such a feature in the future. Even if not, thanks again for the work.

1 Like

I think this is the one of the most exciting new features since I’ve been using Volumio!

Just tried it and it just works. Only one detail: If there is nothing playing or on queu, the button “play here” just spins. So, it seams that it needs to start play on the volumio device before “play here”, wich could lead to starting playing in my home system (eaven if just a few seconds) before streaming to the phone, and so it could wake someone sleeping, or scare someone in the house, and get me in trouble! :grin:

I did not test this possibility yet, just a logic (?) conclusion…

Otherwise, please PLEASE keep this feature!

Hoi Robert.Hecht, a restart of my Primo solved the problem…

1 Like

This is awesome! I’m a owner of a Volumio Primo (so no more beta testing there…:slight_smile: ), but will try to install it on a PC for testing.

Great work.

Can you explain how this is working from a security point-of-view?

Normally when I use Volumio to play music in my local network, my Volumio install talks out through my router to the internet to access streaming services, and to connect to your Volumio servers to check whether I have a premium account, etc.

With this new feature, I can go to a web browser running on any computer in the world. I log in to play.volumio.com. I can then stream music from my home volumio install to that browser running anywhere in the world. So two questions:

  • Is the music going through your servers on its journey from my home Volumio running on my pi to the web browser running anywhere? Or is it going straight from my home Volumio to the web browser? If it’s going via your servers, that seems like it will cost you a lot of bandwidth. Is that affordable for you if lots of people use this feature?
  • How is my music going out from my local volumio over the internet to this web browser? How is this incoming connection to my local volumio being passed through my router? Routers normally block incoming requests.

(Or am I completely misunderstanding this, and it only works on a browser running on a computer on my home network?)

1 Like

It uses the same architecture in place for MyVolumio remote control, which is:

  • Volumio opens an encrypted reverse tunnel to one of MyVolumio cloud servers
  • Playback is fetched from MyVolumio cloud servers, which proxies your Volumio device stream via an HTTPS encrypted connection.
  • You don’t need to open any port, as the connection is initiated by Volumio to our servers
  • We already have about 15 servers worldwide to handle such infrastructure, so there’s plenty of bandwidth available to serve Volumio Premium users (each server can handle about 10k connections without degradations) and we don’t pay for extra bandwidth. In case it’s needed, we can scale the number of servers very quickly.
    If you are curious, see how many servers are required for Volumio to operate:
  • The stream works this way: Player → Volumio AAMMP → HLS Stream → Browser . So actually we stream via http any audio that should instead go to your hardware output.

Hope that helps


Good news guys, we’ve fixed all that you reported and implemented many improvements based on your feedbacks :wink:

We’ll notify you when you can update to the new version :wink:


Thank you for that response. Sounds good. Is this option going to be optional, i.e. can I turn off the ability to stream to a browser from my local Volumio?

Yes, this happens to me as well. If this could be fixed, and the issue that the display of how far through a track the playback is doesn’t catch-up when you pick up your phone after you’ve put it down for a few minutes, then Volumio would be perfect.

New beta build is ready! See the first post for info.

Happy testing!


Local playback in iOS solved: thanks!

Hi @mervinio ,

thanks for the new version and for all the bugs that have been fixed!

I just tested beta version Volumio-3.378-2022-09-30-x86_amd64.img

My impression is there is still work to do…

  • Scan of the locally attached and network files is still not 100% stable.
  • Local UI on HDMI does not work after the first startup. After a second reboot it’s working well.
  • HDMI playback with bitrates above 48k is still hacking the first 5-10 seconds of every file. Playback over SPDIF is perfectly running on high bitrates.
  • Player is restarted every time after uploading a UI background image (strange! where is the correlation here? some misplaced trigger?).
  • Playback options are not 100% stable after a reboot is done.
  • Some translation texts are missing in the UI.

Anyway, that’s the nature of a beta phase - detecting and hopefully eliminating such issues. :wink:

Here comes my detailled test report with several logs - each done after the described phenomenon.

After first boot from USB stick (not update the internal SSD):
logfile: http://logs.volumio.org/volumio/C3HpFd6.html

startup sound at first boot :white_check_mark:
WEB UI is working. :white_check_mark:
local UI (HDMI) is completely white, mouse pointer is visible and reacting, but there’s no UI. :x:
An at first boot time attached USB stick with music files is not scanned automatically . I had to start an “update” at “Sources”. :x:

the playback does work (tried webradio, TIDAL, TIDALconnect, network drive and local music lib). :white_check_mark:
index of local files (music library) scan or update does work. :white_check_mark:
index of network volumes (music library) scan or update does work. :white_check_mark:
automount local new plugged media does work. :white_check_mark:
newly plugged local usb media have to be scanned manually.

SPDIF ok, but there is sometimes a little cnack when switching manually from track to track :white_check_mark:
HDMI 44.1k and 48. sync ok :white_check_mark:
HDMI higher bitrates (everything above 48k) is hacking the first 5-10 seconds of the file. :x:
High resolution files sound broken over the first 5-10 seconds (MP3 96 kHz 32 bit, WAV 96 kHz 32 bit, WAV 192 kHz 32 bit, WAV 352.8 kHz 32 bit, DSD 2.82 MHz 1 bit, DSD 5.64 MHz 1 bit, DSD 11.28 MHz 1 bit, flac 96 kHz 24 bit, ) This error occurs when high sync rates (higher than 48k) on the HDMI bus appear. :x:
analogue out ok (SPDIF stays “on”) :white_check_mark:
Testfiles ok, various formats and resolutions mp3(44.1, 48kHz @ 16bit 24bit), flac(44.1, 48, 96, 192kHz @ 16bit 24bit), wav(44.1, 48, 96, 192, 352.8kHz @ 32bit), DSD (2.82, 5.64MHz @ 1bit)
Webradio ok :white_check_mark:
myVolumio ok (user level: Superstar) :white_check_mark:
TIDAL ok :white_check_mark:
TIDALconnect ok :white_check_mark:
Qobuz not tested
music lib index ok (artists, albums, tracks, playtime) :white_check_mark:
ssh / logs ok :white_check_mark:
samba ok :white_check_mark:
plugin not tested
local UI after first startup of the image - not ok :x:
local UI after a second reboot - ok :white_check_mark:
WEB UI ok :white_check_mark:
background image upload ok :white_check_mark:
restart of the player every time I upload a new background image - not ok :x:
USB automount ok :white_check_mark:
LAN ok :white_check_mark:
WLAN not tested
Network Drives ok :white_check_mark:
update not tested
startup sound ok :white_check_mark:
alarm not tested
sleep ok (stop music and power down) :white_check_mark:

There was a spontaneous restart of the player after 24 minutes uptime :x:

The player does perform a restart every time I upload a new background image :x:

After 3 player restarts the local music library is lost.

… and update or restart the scan is no longer possible.

After a volumio reboot the local UI is working and local library is back.

:x: Some i18n translations are still missing. Navigate from Tidal “My Music” to an artist - you miss all the translation texts in the UI

:x: After a volumio restart (following the “sleep power down”) the playback wasn’t possible - I had to reconfigure the playback options to make it working again.

volumio@smx:~$ inxi -Fxxxz
System: Host: smx Kernel: 5.10.139-volumio x86_64 bits: 64 compiler: N/A Console: tty 0 dm: N/A
Distro: Debian GNU/Linux 10 (buster)
Machine: Type: Desktop Mobo: ASRock model: J3455-ITX serial: UEFI: American Megatrends v: P1.40 date: 07/14/2017
CPU: Topology: Quad Core model: Intel Celeron J3455 bits: 64 type: MCP arch: Goldmont rev: 9 L2 cache: 1024 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 11980
Speed: 2199 MHz min/max: 800/2300 MHz Core speeds (MHz): 1: 2194 2: 2216 3: 2258 4: 2243
Graphics: Device-1: Intel vendor: ASRock driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5a85
Display: tty server: X.org 1.20.4 driver: modesetting unloaded: fbdev,vesa tty: 197x71
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio: Device-1: Intel Atom/Celeron/Pentium Processor N4200/N3350/E3900 Series Audio Cluster vendor: ASRock
driver: snd_hda_intel v: kernel bus ID: 00:0e.0 chip ID: 8086:5a98
Sound Server: ALSA v: k5.10.139-volumio
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASRock driver: r8169 v: kernel port: e000
bus ID: 01:00.0 chip ID: 10ec:8168
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
Drives: Local Storage: total: 1018.48 GiB used: 4.91 GiB (0.5%)
ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: rev: 1B6Q
scheme: GPT
ID-2: /dev/sdb type: USB vendor: Intenso model: Rainbow Line size: 29.69 GiB serial: scheme: GPT
ID-3: /dev/sdc type: USB vendor: SanDisk model: Ultra Fit size: 57.28 GiB serial: rev: 1.00 scheme: GPT
Partition: ID-1: / size: 25.35 GiB used: 31.2 MiB (0.1%) fs: overlay source: ERR-102
ID-2: /boot size: 170.8 MiB used: 61.2 MiB (35.8%) fs: vfat dev: /dev/sdb1
Sensors: Missing: Required tool sensors not installed. Check --recommends
Info: Processes: 168 Uptime: 25m Memory: 3.70 GiB used: 521.7 MiB (13.8%) Init: systemd v: 241 runlevel: 5 default: 2
Compilers: gcc: N/A Shell: bash v: 5.0.3 running in: tty 0 (SSH) inxi: 3.0.32



When adding music to a playlist no checks are done to prevent duplicates. The same exact song can be added many times to the same playlist, causing duplicates in the playlist.