Volumio 3.198 removed rtl8192eu driver (for DLINK DWA 131 wifi dongle)?


I have multiple PIs with Volumio. Just did a system update on an older Pi2B with the above mentioned wifi dongle from v3.179 to todays v3.198. Looks like v3.198 is missing the rtl8192eu wifi driver. Did a fresh install of v3.179 and the dongle works out of the box. On a fresh install of v3.198 it is not recognized, so it was not a problem during system upgrade.

Any idea how to fix? Would be important.

We are on it, thanks for reporting it

1 Like

Thanks for the fast reply!

The issue is that we upgraded the kernel (to add Pi 4 1.5 support), but the Wi-Fi drivers for some external dongles are not available on this kernel.

The additional WiFi drivers (not included in Pi Kernel) are fetched thanks to the work of Mr Engman, which compiles and hosts them (he is the creator of install-wifi script).
Unfortunately, it seems that the latest kernels have not received his attention and the drivers are not compiled.

We are studying a way to fix this, but it’s not a trivial task. We are deciding if:

  • Stick with old kernel until we find a solution (which is a short-term situation), which will require some “hack” to make it work with most recent Pi version.
  • Go on with newer kernel and don’t support many external wifi dongles

Sorry but this is not going to be solved very soon, as its quite a tough call and we are investigating.
If you guys have suggestions, let us know

Hello !

Seems also RTL8812AU driver missing (Edimax AC600, EW-7811UTC) on v3.198.
Before dongle worked all the time almoust no problem, only when i updated to Volumio 3 (im not sure what version) but my Rpi 3b+/Digione in metal case, begin to use both, wifi dongle and internal wifi at same time (two IP adresses). Otherwise wifi worked but Roon connected internal wifi, i got rid of it when i added dtoverlay=pi3-disable-wifi statement within /boot/config.txt , this disabled pi´s internal wifi. New v3.198 not recognized dongle at all.

I vote to keep the latest kernel and user`s with affected dongles can use 3.179 until the hack is available.

1 Like

Thanks for the information. I did a fresh install of v3.179 and wait till you reached a decision. Personally I would of course prefer the first solution, but if you decide for the second I could probably buy another inexpensive WIFI dingle with better support (can you recommend one?).

Interestingly my USB/Headphone dongle (Qudelix 5k) works flawlessly with the PI2, while it produces a lot of noise with the just bought PI4 (Rev.1.5), which I originally intended to replace the PI2…there is always something…

libreelec which is a OS for kodi uses this repo LibreELEC.tv/package.mk at master · LibreELEC/LibreELEC.tv · GitHub

and it runs a very recent rpi4 kernel (5.15)

I would by far prefer the second solution (go with newer kernel and reduce the number of Wifi dongles supported). But then I use ethernet and not a Wifi dongle. If I did use a Wifi dongle i would be happy to invest in one that is supported “out of the box”.
Volumio development is complex enough as it is and any way to reduce complexity will increase stabiity and reliability


Hi @volumio
Is there a list of USB wifi dongles / chipsets that are supported out of the box by the foundation kernel?


What tool do they use to compile from this conf file?

Is there a a timeframe or at least a guesstimate for when this will be fixed?
And if I have to buy a new dongle do I just search for one that is compatible with rpi4 kernel?
Or third option, anyone have a link for a working firmware?


Hi, After updating to the latest Volumio, I have a problem with breaking the wifi connection. Music plays for about 30 minutes. and no connection. The cable connection is ok.

I did the installation clean, on a new card.

Everything is fine on Volumio 2.197. Previous versions didn’t have this problem either, and I have USbridge Sig. for over two years now.

The USB card is TP-LINK TL-WN722N.
Maybe a newer card I need to buy? Which of the new drivers does not require Volumio?

Check in the software what could be the reason

ASUS USB-AC51 AC600 works.

please don‘t flood the forum with threads all about the same topic…

I wanted to answer where I asked if anyone was looking.