Volumio 3.179: Hard drive formats every time i reboot!

I have a externa powered HDD (2TB NTFS) with my music collection plugged into RPi4 with Volumio 3.179 USB 3.0.
I notice that randomly every time I reboot with the harddrive connected, it formats the whole disk and all my data is gone. This happened 3 times already. I confirmed it with tests by adding files to drive and rebooting it. All data was gone. Even tried with other drives too NTFS, FAT 32 and even EXFAT 4. Same result data is lost and only one folder with HDD name exists.

Is this normal? Do i need to unplug HDD before every reboot? Any tips?
This is not convenient, If I didn’t have backup all my music I would have lost everything!

This is an issue we are trying to understand, to fix it ASAP.

Would it be possible for you to please send a log after this happens?

This is very important to us, and I would be really grateful if you could help on this.

Do this:

Thanks, that’s really important

HI, I have not yet rebooted after the files are gone. This happened 10 minutes ago,
Here is the below log

Can you retry without the Transmission bit torrent running (disable for testing)

I don’t have any torrent client.

Yeah, there is transmission-deamon running, this is a torrent client.

Without rebooting, can you please disconnect your USB hard drive and then reconnect it please?

Then send the logs again?

Here you go.

Unfortunately it seems you rebooted…

We at least have some more clues.

@volumio Thanks for contacting me personally by call, Shows how much you care for the Volumio users.
As discussed I will keep you updated and try to recreate the scenario and send the log.

This is a very important issue, so thanks to you for helping us find out, for the benefit of everyone

1 Like