Volumio 2/ X86: install on a HDD

I sat by my computer truing to follow this instruction for a total of maybe six to eight hours Friday and Saturday. Encountering various types of problems but eventually ending up in a situation where Volumio froze every time i pressed Ctrl+Alt+F1.

Then I realized that it’s MUCH easier to just install the internal SSD I wanted to install Volumio on in a PC with windows and to mount the image directly where I wanted it.

Obviously this might be tricky if you are using a system where your storage media is hard to reach.

But anyway: this would be the instruction for that, based on the instruction on how to create a create a botable SD-card. You need yo use another imager that allows you to chose an internal storage media, I found Etcher.

I suggest you ad it to the first post as an alternative for non-hackers :slight_smile:

1: Download and extract Volumio and you’ll have a .img image file
2: Download and extract Etcher: etcher.io/
3: Install the storage media that is going to be used in your Volumio-system on your PC (you might want to start with this).
4: Run Etcher and flash the storage media according to the instructions. You will have to use “unsafe mode” in order to be able to flash to a SSD or HDD.
5: Exit from etcher.io/ and remove the disk!
6: Done! Volumio is now on your SSD/HDD!
7: Put it back where it belongs

Here is how I did install VolumIO on SSD on my NUC:

  • open ssh

  • using fdisk, remove all partitions from SSD

  • create first partition as FAT partition

  • back to volumio: ask to install on SSD


The key was to make the partition a FAT one. Volumio only works with FAT partitions on x86 (syslinux limitation I think)

There is a Volumio menu choice “install on HDD”. It allows you to boot into Volumio using a USB stick and then install Volumio from there. Simple! I just stumbled onto it when going through the menus. It isn’t mentioned anywhere, not in this thread nor anywhere else that I have found.

Will doing it this way result in a slightly different HDD installation, possibly not as perfect as doing it as recommended here? Is this why it’s not mentioned in any instructions?

The menu option has been there for a while, but is not complete and has some minor issues.
There is an update waiting that will also allow to copy to internal eMMC and there is a plan to offer NVME devices when we start the beta for Volumio on Debian stretch. This improves the process to a point where it gets better than the manual copy.
I’ll make sure it goes into one of the next versions.

Also, when creating a new option to install to HDD, can’t it be made so that you install to a partition and not to a complete disk?
I have now got it to work as a multiboot system alongside windows, libreelec, and ubuntu. But it was a few hours of work… while if I would have had the option to select a partition it would have been a smoother install. :wink:
Also the grub settings gave me some work as well.
So maybe, if possible, also allow to use 1 single partition instead of 3 that include the image?
That would make the GRUB config a lot easier :slight_smile:

Total Volumio newbie, just getting started.
What did you have to do to GRUB to get things working?
I am Debian only x86/amd64 user.
~$ inxi:
CPU: 2x Quad Core AMD Opteron 2386 SE (-MCP SMP-) speed/min/max: 800/800/2800 MHz Kernel: 5.2.0-8.slh.2-aptosid-amd64 x86_64

Thank you.

has this been updated?

1 Like

Volumio cannot read the track data on the HDD and SSD. When it is mounted inside. Readable only when connected via an external USB port, I’m tired of not finding any other error. Volumio developers please fix it so that the software is completely comprehensive

Hi all,
in my case it worked simply flashing volumio x86 on a 3.5" empty hard disk (unused) with etcher and plugging it to a pc.

everything worked great

Etcher is nice but misses the option to make a usb-stick for older pc’s, therefore I use Rufus.
Normally when using Rufus to make a bootable usb-stick I tick the box: “settings to use with older bios, alligning partitions” and then the usb-stick works.
As the distro of Volumio is not recognised by Rufus I cannot set this option and the (older) pc cannot boot from the usb-drive.
It simply says: no bootable device!

What can I do to get Volumio on my HDD, I know Volumio works like a charm on this pc?

1 Like