Volumio 2/ X86: install on a HDD

Until we have an Install plugin in place, please do the following:

NOTE: you will loose ALL the data on your HDD.

  • Flash Volumio 2 to a usb stick
  • Format another usb stick wit FAT32, and copy the unzipped downloaded x86 image to it.
  • Then boot from your usb volumio 2 stick.
  • Will until the UI is showing, the press ctrl-alt-F1 to open a terminal session
  • Log in with volumio/volumio
  • Type
sudo blkid

and check the output.

  • You should see /dev/sda, /dev/sdb and /dev/sdc (presuming you only have one disk in your x86 pc)
    The device with the labels “volumioboot”, “volumioimg” and “volumiodata” is the one you booted from.
    The device with the single vfat partition is the stick with the volumio image, assume it is /dev/sdX (X being a, b, c…)
    The other device is your netbook’s hdd, assume it is /dev/sdY (Y being a, b, c…)
  • When sure about the devices, type
  mkdir usb
  sudo mount /dev/sdX1 usb
  cd usb
  ls -l     
  sudo dd if=fullnameofthevolumioimage   of=/dev/sdY   bs=4M
  sync
  cd ..
  sudo umount usb
  sudo rm -r usb
  poweroff
  • remove the usb sticks, reboot et voila

Just wanted to add my input as I wasn’t sure if dd was taking care of the un-zipping. This is the extra steps I added:

  sudo apt install pv unzip
  mkdir usb
  sudo mount /dev/sdX1 usb
  cd usb
  ls -l                     (should give you the name of the volumio image you've just copied to it)
  unzip -p fullnameofthevolumioimage.zip | pv | sudo dd of=/dev/sdY bs=4M
  sync
  sudo rm -r usb
  poweroff

Good one! I did not specifically mention that the image was expected to be unzipped.
Your suggestion seems more efficient as it uses the smaller downloaded zip-file to copy initially (and thus probably faster all-in-all).

-Gé-

on another note, do you know how to get this not to attempt to start a dhcp server. It seems to be waiting 1 minute to do something with a dhcp-server and I cannot believe it would be taking that long to get its ip from the network dhcp server and thus I assume it is trying to start its own.

The dhcp server starts only if you are in hotspot mode, so no need to turn it off.

OK, seems I had a bad ethernet cable causing this grief. Everything is good now (still tweaking). Have it installed on a Zotac Zbox BI-320-U.

Thanks for sharing your x86 model, just thinking as I read this.
Unlike the arm boards, there are about as many different x86 configurations as you get trees in the Black Forest.
Perhaps we should open a section with x86 compatible intel/ amd boxes.
It would help devs, but also users, to know which ones work and which ones (still) have issues.

-Gé-

I have a few older Thinkpad laptops that I want to re-purpose into Volumio clients, to be used with USB DACs. I have no problem booting Volumio from a USB flash drive, and everything that matters seems to work. I successfully followed the instructions for installing Volumio on the test machine’s hard drive, but upon restarting I receive an error message stating “no OS installed.” I think this might be an MBR vs GPT issue. The blkid command identifies the drive as using a GPT partition structure, but these machines cannot boot from a GPT disk.

Any suggestions for fixing this? Why will the flash drive successfully boot but the same image transferred to hard disk fail?

Regarding the setup script, the command “rm -r usb” fails without first moving off of the ‘usb’ mount point and then un-mounting the second flash drive. My working version of the script was as follows…

  mkdir usb
  sudo mount /dev/sdX1 usb
  cd usb
  ls -l     
  sudo dd if=fullnameofthevolumioimage   of=/dev/sdY   bs=4M
  sync
  cd..
  sudo umount usb
  sudo rm -r usb
  poweroff

Thanks for the hint, I’ll add it to the first post

Hi, i have installed a hard disk sata and i configured it to boot, it hangs and display the message:
findfs: unable to resolve ‘UUID=6c0d3184-7851-46c3-919b-ed4c1d379708’
findfs: unable to resolve 'UUID=CC23-EE0D
Specify the squash image partition on the kernel etc. etc.
Do you know some solution?
Thank You!!

This happen on udoo x86!

This is happening also on my Udoo x86. Its the Advanced Plus version.

Hi, I have configured the ard disk sata as music storage in udoo X86 advanced. Since the fstab file does not keep the changes, I have included the necessary commands in the rc.local file, the sharing problem remains. I can not put the files on the hard disk in the network.
The command ‘chmod’ does not work, why?
I think that for you who are more experienced it is easier to solve the problem.
I hope you can help me, the system works well, just fix these small things and we are at the top …
I look awkward for your answer.
Thank you.

Hello! With submitted by the instruction in first post, I can`t to create right bootable media. (((
Instead of this, I use a SATAtoUSB adapter, and then just use ImageWriter with my HDD as USB device.
After this, I connect my HDD, to internal SATA port of x86PC, and now I can boot Volumio without any problems…
So… Maybe сan it be advisable to consider this instruction? Or add in the download section, the images of HDD? Because with USB stick, personally I am, had very poor performance… And even wanted to give up the idea of ​​trying Volumio. Now I understand that this would be a big mistake)))
Thanks anyway! And goodluck! )))

I also used a similar method to write the x86 image to a 2.5" hdd using an external USB HDD enclosure and Win32DiskImager. The HDD was then put in my 2007 Macbook Black and it boots a lot faster than using a bootable USB key.

However, I’m getting the following error during boot that times-out after 3 minutes. Boot continues as normal to the Volumio interface and the wired network connection works ok.
“A start job is running for LSB: Raise network interfaces (XXXs / no limit)”

Is there a way to disable this?

I’m not sure howto, better would be finding the cause.
As I do not have a Macbook here, it is a bit difficult to guess what happens.
Perhaps the network device gets initialized too late, no idea.
Could you create a log file for us, you need to go to the dev page (/dev) and use the upload option.
It will give you a link to the uploaded file, it might give us a clue.

Hi, people! If somebody use greate tool iODD, I can confirm what on x86PC, we can use it.
I create usual USB-Stick, and then copy it to VHD-image with WinImage. Then with VHDTool++ I copy this image to iODD, select this image for boot, and have normal bootable iODD with good worked Volumio!
Also I think with WinImage we can restore VHD-image to real HDD(but i`m not try this to do), as it related to current topic.
Good day!!! :wink:

I got the Win32DiskImager method to work on my CAPS Carbon server. The chip is an Intel N2800, with the SOtM USB board installed. I formatted an SSD to exFAT and used Win32DiskImager to burn the x86 image to the drive. The server booted up just fine, it operates smoothly and sounds great. This is a great workaround for the lack of installer.

I’m having the same issue. Wondering if the distro they are using is unable to handle eMMC storage.

well, instead of just saying you have the same issue, would you please give details on your configuration?
Are you talking about an Udoo or have antother device? We’re not so good at guessing :smiley:
We are using Debian jessie with kernel 3.18.25, which is quite old and does not support the newest hardware, especially not the Intel CherryTrail and Baytrail SoCs which got very late support in linux mainline, eMMC is an issue too.
I’m in the middle of trying new kernels and eventually switch to Debian stretch. Just finished an experimental version, which “should” also support eMMC, but I need feedback.
Link to the image will be published soon in this thread