Volumio 2; Unable to mount the internal drive on a netbook

Hi,

I am in the process to convert an old Asus eee PC 1000H into a dedicated Volumio player V2.0.

I resolved already some issues like changing to Belgian Azerty, closing the lid is not longer suspending the netbook, booting from an SD card works,

However now I am stuck when I try to use the internal drive to serve music files.

If I go to Browse -> Music Library -> I see NAS (mounted a SAMBA volume), USB (Where I see an attached USB drive, and INTERNAL that remains empty even when the drive is mounted.

First I tried to modify /etc/fstab, but that was always overwritten. I found an old post for V1.X where it was documented how to fix this by editing a php file. However in 2.0 it seems that this is changed and I could not find how to fix it.

So I decided to edit

sudo nano /etc/rc.local

adding content …

mount /dev/sda1 /data/INTERNAL

This works and was verified by logging in with ssh.

volumio@volumio:~$ ls -al /mnt
total 12
drwxrwxrwx 1 root root 4096 Nov 19 23:28 .
drwxr-xr-x 1 root root 4096 Nov 21 20:56 ..
lrwxrwxrwx 1 root root   14 Nov 19 23:28 INTERNAL -> /data/INTERNAL
drwxrwxrwx 1 root root 4096 Nov 21 20:11 NAS
lrwxrwxrwx 1 root root    6 Nov 19 23:28 USB -> /media


volumio@volumio:~$ ls -al /data/INTERNAL/
total 3784
drwxr-xr-x  22 root    root       4096 Nov 23 19:59 .
drwxr-xr-x   1 volumio volumio    4096 Nov 21 21:37 ..
drwxr-xr-x   2 root    root       4096 May  1  2016 bin
...
lrwxrwxrwx   1 root    root         30 May  1  2016 vmlinuz -> boot/vmlinuz-3.19                                                                                                                                                             .0-32-generic
-rwxr-xr-x   1 root    root    3755389 Nov 23 19:59 x.mp3

FYI, the internal drive still contains an older Linux mint distribution and is formatted etx4. But there are a lot of mp3 and flac files in a Music folder.

If I unmount the internal drive, the INTERNAL folder on the user interface disappears. So it seems that the drive is ‘seen’, but I am not able to browse the contents with the Volumio user interface.

I also tried to mount somewhere under media, but that didn’t work either.

Any tips or help how I could resolve this issue?

I think allowing to serve files from an internal drive is a big bonus.

Hi,

struggled with the same problem.

Created two folder in /mnt/ & /var/lib/mpd/music/ and softlinked 'em. First folder is the mount point, the second the reference for the engine were to look for music. If your music is anywhere on that drive you should be able to reference/softlink to that point. In my case i use the disk only for music.

installed cronjob and added the mount on bootup command

sudo apt-get install cron sudo crontab -e @reboot mount /dev/DISK /mnt/MOUNTPOINT

Only way i was able to get it working…not a beauty, but it’s doing the trick :wink:

have fun