Volumio 2 on Rock64

This thread offers people the opportunity to discuss the Rock64 board version maintained by me.
These images will not be released on the download page.
Anyone willing to help maintaining the Rock64 platform is very welcome.

New images will be built at regular times to follow up on finished Volumio development cycles.
They will also be built on request (if there is appropriate demand for it).

This opening post will hold links to generated Rock64 image versions.

Current and previous links to downloads

Current version
updates.volumio.org/rock64/volum … 64.img.zip

Changelog
2.773 (05-05-2020)

NEW ADDITIONS

Advanced Music Credits display and discovery (MyVolumio Superstar required)
New design of artist and album cards
Improved usability of browse layouts
Improved Backend responsiveness
Show database updating status on UI3
Continuous playback for albums and playslits

FIXES

Linting Fixes
Do not show webradio headers if no webradio results
Show search results even with non working plugins
Preserved image hash versioning
Improve Wireless and bluetooth coexistence on PI
Ignore Internal Validity mixer
Do not show indication of 0 bitrate on webradios
Improved Bluetooth Performances for PI3B
Show webradios bitrate on mobile UI

2.729 (27-02-2020)

FIXES

Better propagation of initial state on multiroom handler
Handle ungraceful device disconnect
Improve webradios search results
Fix oauth login on new signup controller
Remove fakepulsingknob animation
Fix Log rotation service
Do not show podcasts on webradio search
Fix seek and volume control on UI3 Playback page

NEW ADDITIONS

Add MyVinyl background
Show webradios bitrate
Sort webradios result alphabetically
Allow to enter coupon on trial period
Simplify Factory Reset facility
Improved retriaval of wireless network results
Reload UI on network saving
Added privacy settings facility

Previous versions
volumio-2.715-2020-03-04-rock64

Changelog

  • Updated to current Volumio/myVolumio version

volumio-2.528-2019-01-12-rock64
Changelog

  • Added support for a range of DSD-direct (native) capable USB Audio devices.

Previous versions
volumio-2.507-2018-11-30-rock64
Changelog

  • As 2.504, but with “myVolumio” enabled

volumio-2.504-2018-11-29-rock64
Changelog

  • Added support for device tree overlay
  • Script enhanced for building myVolumio for Rock64 (coming next)

volumio-2.462-2018-09-29-rock64
Changelog

  • Fixed soft reboot issue
  • Support for additional wifi dongles

volumio-2.424-2018-07-20-rock64
Changelog

  • Added support for Realtek RT5370

volumio-2.390-2018-03-27-rock64
Initial version

  • supports booting from eMMC and SD card
  • supports a select number of simple I2S DACS
  • currently output formats are limited, drivers in the Rockchip kernel are still WIP

Tested with the Rock64 DAC HAT and a wired ES9023 DAC module.
Many old PI/PI2+ DACs should work (provided they do not need I2C for control).

I am trying to compile 8812au driver for Rock64, can you let me know where do I get the linux-kernel for Volumio? It is missing in the image.

Excuse me, but you are wrong, I do declare all the resources, which is what we expect from all contributors.
I’m using Ayufan’s kernel, which is clearly stated in the README.md of the platform git repo.
Go and check it out, you will find all you need.
https://github.com/ayufan-rock64

I am sorry, I am new to development. I do not intent to offend anyone.

Thank you for the link, I’ll check it out.

In case you are new to development, I recommend not to start building.
It may not be as easy as it may seem and we do not offer step-by-step instructions.

The Realtek 8812au driver is not in Ayufan’s kernel sources, adding it is something you have to work out with him.
There is nothing much I can help you with in this case as this is outside our scope.

I can’t get this image to work (volumio-2.390-2018-03-27-rock64.img nor volumio-2.299-2017-10-29-rock64.img) on my brand new ROCK64 1G.

I took the image, wrote it to a brand new MicroSD card with Win32DiskImager (and also Etcher), put it in my Rock64, and connected the power. The green power light and the ethernet light came on, as well as a red and a white light on the other end. The white light stayed on for a few seconds, then went out. I let it sit around for over an hour, and nothing happened. When I look at the card, the basic setup is still there, it did not expand to use the whole drive, it appears that nothing at all happened. I tried this with two different cards and with two different ROCK64 SBCs, with and without the ROCK64 DAC HiFi Shield (ESS ES9023 DAC chip), and with and without a WiFi dongle. I tried ayufan-rock64 Android 7.1 and it booted up with no trouble.

Any ideas? I’d love to help troubleshoot if you can direct me.

Thanks.

Well, I officially feel like an idiot. I had expected it to act like the normal Volumio install (like on my C2) with it showing up on WiFi, etc. :blush:

I did the crazy thing of hooking it up to a monitor and finding a nice command prompt waiting for me /facepalm
I got the newest version running and have successfully played FLAC, MP3, and WAV files, from a USB drive and from my DLNA server. Lots of win!

After lots of tweaking, I got some audio out of the HDMI (still don’t know how), and also finally discovered that I needed to move jumper J3 on the DAC to use the analog outputs. AC/DC is now rattling my walls.

I can’t seem to get WiFi running, is that because I am doing something wrong, lack of drivers for my dongle, or is it not up and working yet? When I turn on WiFi, the slider goes to on, but it doesn’t give me an option to look for a network or put in a key or name.

Thanks for building this, btw. I really appreciate it. Looking at the feature requests, Volumio seems to be coming along great!

Very well possible that it is a dongle issue, not all of them work.

In case you know how to use SSH (volumio.local/dev dev page, button “enable”) please do sudo lsusb after you plugged in.
If it was plugged in, just take it our and reinsert, then do ‘lsusb’.
Curious to see the output, I could then tell you if that dongle is supported.

Well, this exact same adapter (the WiFi 0 from Ameridroid) works perfectly on my Volumio install on my C2.

Bus 001 Device 002: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

Enabling the WiFi in the Network page doesn’t bring up any configuration options. About 30 seconds after hitting save, the Volumio dropped off the network. The wired connection is still up, but no longer has an IP. Setting a static IP in the Network settings also killed the network. I was able to manually set up the IP (or enable DHCP) from the CLI, but that is not all that useful.

Trying to enable WiFi, whether there is a dongle or not, wipes out the IP Address of eth0, even if I have set it manually. This is very strange. Bouncing eth0 doesn’t work, either. When I rebooted after setting the manual IP, then enabling WiFi, I still didn’t have an IP. I was able to set it manually (or enable DHCP) from the CLI. Strangely, even though I have enabled DHCP, etc., the Volumio web interface is still telling me that I have a static IP set up (the Status is correct, but the settings below are not). I set it back to Automatic IP, hit Save, and my network is wiped out again. This is very odd.

What next? Is there some logging I can enable? I checked /var/log, but didn’t find much useful. This snippet from volumio.log might have something?

[code]2018-04-15T19:11:17.910Z - info: mDNS: Found device Volumio-2
2018-04-15T19:11:50.196Z - info: CoreCommandRouter::volumioGetState
2018-04-15T19:11:50.198Z - info: CoreStateMachine::getState
2018-04-15T19:11:50.199Z - info: CorePlayQueue::getTrack 0
2018-04-15T19:11:50.341Z - info: CoreCommandRouter::executeOnPlugin: appearance , getUiSettings
2018-04-15T19:11:50.409Z - info: CoreCommandRouter::executeOnPlugin: wizard , getShowWizard
2018-04-15T19:11:50.410Z - info: CoreCommandRouter::executeOnPlugin: system , getShowWizard
2018-04-15T19:11:50.418Z - info: CoreCommandRouter::executeOnPlugin: multiroom , getMultiroom
2018-04-15T19:11:50.424Z - info: Listing playlists
2018-04-15T19:11:53.583Z - info: CoreCommandRouter::getUIConfigOnPlugin
2018-04-15T19:11:53.807Z - info: CoreCommandRouter::executeOnPlugin: network , getInfoNetwork
2018-04-15T19:11:54.445Z - info: CoreCommandRouter::executeOnPlugin: network , getWirelessNetworks
2018-04-15T19:12:11.171Z - error: Upnp client error: Error: This socket has been ended by the other party
2018-04-15T19:14:17.548Z - info: CALLMETHOD: system_controller network saveWiredNet [object Object]
2018-04-15T19:14:17.550Z - info: CoreCommandRouter::executeOnPlugin: network , saveWiredNet
2018-04-15T19:14:17.619Z - info: Permissions for /etc/network/interfaces set
2018-04-15T19:14:17.684Z - info: mDNS: A device disapperared from network
2018-04-15T19:14:17.687Z - info: mDNS Browse raised the following error TypeError: Cannot read property ‘toLowerCase’ of undefined
2018-04-15T19:14:23.719Z - info: CoreCommandRouter::executeOnPlugin: wizard , reportWirelessConnection
2018-04-15T19:14:23.721Z - info: CoreCommandRouter::executeOnPlugin: network , getWirelessInfo
2018-04-15T19:14:27.816Z - info: CoreCommandRouter::executeOnPlugin: upnp , onRestart
2018-04-15T19:14:28.720Z - info: CoreCommandRouter::executeOnPlugin: upnp , onRestart
2018-04-15T19:14:28.765Z - error: Cannot kill upmpdcli Error: Command failed: /usr/bin/sudo /usr/bin/killall upmpdcli
upmpdcli: no process found

2018-04-15T19:14:37.958Z - info: Upmpdcli Daemon Started
2018-04-15T19:14:38.827Z - info: Upmpdcli Daemon Started
2018-04-15T19:15:47.647Z - info: mDNS: Found device Volumio-2
2018-04-15T19:15:47.785Z - info: CoreCommandRouter::volumioGetState
2018-04-15T19:15:47.786Z - info: CoreStateMachine::getState
2018-04-15T19:15:47.787Z - info: CorePlayQueue::getTrack 0
2018-04-15T19:15:47.802Z - info: CoreCommandRouter::executeOnPlugin: multiroom , getMultiroom
2018-04-15T19:15:47.805Z - info: Listing playlists
2018-04-15T19:15:49.154Z - error: Upnp client error: Error: This socket has been ended by the other party
[/code]

I believe the kernel for the Rock64 is missing the right driver for that WIFI Adapter. I took a quick look at the config file for the Rock64 kernel and didn’t see the driver enabled.

The Rock64 kernel does have a driver for the RT5370, although experimental, but perhaps good enough.
This is what I will add in the next image version, kernel compiled OK.
Ralink rt2500 / rt2501/rt73
Ralink rt27xx/rt28xx/rt30xx

  • where rt2800 includes support for rt33xx, rt35xx, rt3573, rt53xx, rt55xx (all EXPERIMENTAL)

I’d appreciate that because, without WiFi, I am kinda dead in the water with these.

Understandable…
OK, kernel was done yesterday, I need to find some time to add it to the platform files and then build an image.
I hope to get this done during the weekend, but no promise. I’ll send you the URL to download prior to publishing it here.
Once you say your dongle works, I’ll post the update in the OP.

Thanks much. No rush, really, as I won’t be able to test it for at least a week.

i bought ROCK64 Board(4G memory) and ROCK64 STEREO AUDIO DAC ADD-ON BOARD .

and
using volumio-2.390-2018-03-27-rock64.img ,
i can start volumio , but no sound comes from dac board :mrgreen: .

i guess something is wrong with my settings.


volumio@volumio:~$lsmod
Module Size Used by
xt_REDIRECT 16384 1
nf_nat_redirect 16384 1 xt_REDIRECT
xt_tcpudp 16384 1
iptable_nat 16384 1
nf_conntrack_ipv4 24576 1
nf_defrag_ipv4 16384 1 nf_conntrack_ipv4
nf_nat_ipv4 16384 1 iptable_nat
nf_nat 24576 2 nf_nat_redirect,nf_nat_ipv4
nf_conntrack 126976 3 nf_nat,nf_nat_ipv4,nf_conntrack_ipv4
ip_tables 24576 1 iptable_nat
x_tables 32768 3 ip_tables,xt_tcpudp,xt_REDIRECT
uas 20480 0
usb_storage 61440 2 uas
autofs4 40960 0
squashfs 53248 1
lz4_decompress 16384 1 squashfs
overlay 45056 1

root@volumio:/home/volumio# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDMI], device 0: ff000000.i2s-i2s-hifi i2s-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: I2S [I2S], device 0: ff010000.i2s-rk3328-hifi rk3328-hifi-0 []
Subdevices: 0/1
Subdevice #0: subdevice #0
card 1: I2S [I2S], device 1: ff010000.i2s-snd-soc-dummy-dai snd-soc-dummy-dai-1 []
Subdevices: 1/1
Subdevice #0: subdevice #0
card 2: SPDIF [SPDIF], device 0: ff030000.spdif-dit-hifi dit-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

There is a known issue with the DAC factory default jumper settings for J3 and J4.
Make sure J4 is set to L and J3 set to 50M, do not do this while powered on!

For correct settings also refer to the attached image:
IMAGE-1.JPG

I had that same issue when I first assembled mine, but found a post that described that solution.

Any idea when you might be able to get that new build out, with the WiFi driver?

I’ve got a bit of a backlog with the main platform, but it is still in the pipeline.
Hope to get it done this weekend or shortly after.

Cool beans, thanks. I am sure that your life doesn’t revolve around Volumio :slight_smile:

Firstly, I just want to say that you guys have done a great job with volumio… it is a great package - easy to install and configure, looks good, sounds great :wink:

I have the rock64 DAC board, but wanted to run docker and volumio side by side as I was planning to have an always on rock64 server that doubled as a playback device. Docker didn’t seem to co-operate well on the volumio (although I didn’t experiment with it too long to see why).

I was wondering how hard / what would be the process for getting the I2S audio working on say one of the newer bionic/ubuntu minimal or container images that ayufan does for the rock64? (as I’m guessing it wouldn’t be that different to the Debian image - just not sure what sound related stuff needs to be configured. Or should I poke around with docker on volumio a bit more as it should be working?