Volumio 2 on Orange Pi Boards

Hi, I have volumio running on an orangepi board orangepi plus board. Where are you stuck so I guess that does not help you a single bit :laughing:

Yup. I followed this repo https://github.com/pkendall64/platform-orangepi.
I tried to build new one with newer kernel. But i got brick. My orange pi zero couldn’t boot.
I’m not sure why. That’s reason i asked if you could make a build for Orange Pi Zero with latest supported kernel. :stuck_out_tongue:

Based from @pkendall64 works. I built latest Volumino version (2.834) with kernel 5.4.45.
But wifi still not working on Orange Pi Zero. Looks like this isn’t kernel issue.
Waiting @pkendall64 give us a favor :smiley:

Link if someone interested

Some ideas –
I am not sure how you are using those build scripts, but are you sure the modules for the xr819 are built and loaded?.
You might also need the right device tree patches. Try decompiling your current device tree and checking if the following patch is included.

diff --git a/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts b/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts
index 454408b..df356b5 100644
--- a/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts
+++ b/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts
@@ -49,6 +49,7 @@
 
 #include <dt-bindings/gpio/gpio.h>
 #include <dt-bindings/input/input.h>
+#include <dt-bindings/pinctrl/sun4i-a10.h>
 
 / {
 	model = "Xunlong Orange Pi Zero";
@@ -157,6 +158,10 @@
 	 */
 	xr819: sdio_wifi@1 {
 		reg = <1>;
+		compatible = "xradio,xr819";
+		interrupt-parent = <&pio>;
+		interrupts = <6 10 IRQ_TYPE_EDGE_RISING>;
+		interrupt-names = "host-wake";
 	};
 };

@ashthespy I used armbian for build with command like this

./compile.sh KERNEL_ONLY=yes BOARD=orangepizero BRANCH=current LIB_TAG=v20.05 RELEASE=jessie KERNEL_CONFIGURE=no EXTERNAL=yes BUILD_KSRC=no BUILD_DESKTOP=no

I could see driver & patch was applied from output log

Also I rechecked decompiling dts.
sun8i-h2-plus-orangepi-zero.txt (34.1 KB)

I’m not sure what we’re missing here. Any ideas ?

Does the file /etc/modprobe.d/xradio_wlan.conf exist?
Looking at Armbian’s scripts, something along these lines might get you going?

MACADDR="xx" # Define something
echo "options xradio_wlan macaddr=${MACADDR}" >/etc/modprobe.d/xradio_wlan.conf
cd /etc/network/ && ln -sf interfaces.network-manager interfaces
modprobe -r xradio_wlan 
modprobe xradio_wlan

@ashthespy Finally i found what happened here.
Orange Pi Zero used PA20 to enabled wlan. But we applied a patch to use this pin for I2S DAC. So wlan always disable.

I found a soldering way to enable wlan + I2S DAC on Orange Pi Zero

  • Find U58 near antenna connector, get rid of pin 3 connection. Remaining connection on the board is PA20. It’s Data OUT, connect it to the I2S DAC.
  • Connect IC U58 pin 3 to 3.3Vcc. The Wlan will be powered continuously
    Both working.

2 Likes

Oh yeah, I forgot about this. Sorry for the silly debug hunt!
I recall reading about the pin mapping issue long time ago.

EDIT: There some posts earlier this this thread as well about PA20 and the Zero. By any chance did you also get the I2S working on it?

I just ordered one. I’ll feedback tomorrow.

1 Like

@ashthespy I found a 5102A DAC fit perfectly with Orange Pi Zero.



It worked. Sound really good. Cons: No hardware volume

Here pinout. See Sabre connections

1 Like

Hi I have exact the same DAC.
Did You managed to get this working with Orange Pi Zero?
I’ve connected and configured according to this post but no sound comes from the DAC.

Are use using Volumio ? If not try this one Link to confirm your DAC is working and wire corectly

  • Volumio-2.406-2018-05-31-orangepizero.img.md5

Is this the latest image for Orange Pi Zero H2-plus ??

(I am having some trouble with this image and, after reading this thread, I think it might be another file with some fixes).

Thank you

Yes, I’ve used yours build with no luck.
I’ve connected DAC like below, but no sound is coming from it.

Just to clarify when I connect this DAC to Raspberry it’s working like a charm so DAC itself isn’t broken.

Hi Ktoanllba, is your build working? Can you share it?
I used Volumio-2.406-2018-05-31-orangepizero.img, but it doesn’t work.
I’d like to install in my orange pi zero lts

Ah, sorry, I saw now.
I will try it!

With my Orange PI zero LTS I tried this version and it run well! It found my external Usb Dac S.m.s.l. Sanskrit 10th

I have enabled a addition Usb from the file /boot/armbianEnv.txt

I tests all with a 192kHz 24bit trace:

The only problem is wifi is not enabled.
Someone has a idea?

Scroll up a bit :wink:

But this post is aboute use PA20 for I2S and Wlan together.
I didn’t solder nothing, and my wifi run if I use a normal armbian iso.
Inside the software maybe I need to change something for use P20 like wifi pin

Ah sorry, thought you understood what had to be done :slight_smile:
Just don’t load that I2S overlay and you should be good to go.
To do this, edit the /boot/armbianEnv.txt file and remove the user_overlays=sun8i-h3-i2s0 line.