Volumio 2 on Khadas boards

the log does not show anything abnormal.
I will connect to a tv coming Monday and test the same setup, see what happens.

Hi,

Thanks for looking in on my issue.

This afternoon, I hooked up the VIM to a Samsung computer monitor. This seemed stable, but after about 50 minutes the ‘Aw Snap !’ webpage appeared.

Tried wireless network connection in stead of wired ethernet, but the issue kept returning.
Tried disabling the only plugin I use : Radio Paradise, still the same.

Opening the Volumio webpage on another device (e.g. my thinkpad or an Android tablet) while running the HDMI output, seems to trigger the issue.

Anyway, thanks for having a look at it.

Have a nice weekend,

Steven

Thanks. I got it.
But another bored thing is that the wifi cannot be up. The image don’t include the module of 8723bs, and I can get the wifi up with 8723bs.ko in the earlier version. Could you compile a module of 8723bs? The dhd module cannot get the 8723 module up. The following is the error with dhd module:
[ 742.844596] dhd_module_init: in Dongle Host Driver, version 1.579.77.41.10 (r
)
[ 742.846422] ======== dhd_wlan_init_plat_data ========
[ 742.851586] dhd_wlan_init_gpio: WL_HOST_WAKE=-1, oob_irq=54, oob_irq_flags=0x
418
[ 742.859093] dhd_wlan_init_gpio: WL_REG_ON=-1
[ 742.863454] dhd_wifi_platform_load: Enter
[ 742.867647] Power-up adapter ‘DHD generic adapter’
[ 742.872513] wifi_platform_set_power = 1
[ 742.876482] ======== PULL WL_REG_ON(-1) HIGH! ========
[ 742.881754] aml_wifi wifi: [extern_wifi_set_enable] WIFI Disable! 486
[ 743.088430] aml_wifi wifi: [extern_wifi_set_enable] WIFI Enable! 486
[ 743.594351] wifi_platform_bus_enumerate device present 1
[ 743.594397] ======== Card detection to detect SDIO card! ========
[ 743.600453] sdio_reset_comm():
[ 743.603681] meson-mmc: sdio: resp_timeout,vstat:0xa3ff2800,virqc:3fff
[ 743.610169] meson-mmc: sdio: err: wait for irq service, bus_fsm:0x8
[ 743.616577] meson-mmc: meson_mmc_irq_thread 2770 sdio: cmd:52
[ 743.622510] meson-mmc: sdio: resp_timeout,vstat:0xa3ff2800,virqc:3fff
[ 743.628969] meson-mmc: sdio: err: wait for irq service, bus_fsm:0x8
[ 743.635370] meson-mmc: meson_mmc_irq_thread 2770 sdio: cmd:52
[ 743.662132] meson-mmc: [sdio_reinit] finish
[ 745.690353] failed to power up DHD generic adapter, 3 retry left
[ 745.707031] wifi_platform_set_power = 0
[ 745.707074] ======== PULL WL_REG_ON(-1) LOW! ========
[ 745.710667] aml_wifi wifi: [extern_wifi_set_enable] WIFI Disable! 486
[ 745.917296] wifi_platform_bus_enumerate device present 0
[ 745.917338] ======== Card detection to remove SDIO card! ========
[ 745.923405] aml_wifi wifi: [extern_wifi_set_enable] WIFI Disable! 486
[ 746.130053] wifi_platform_set_power = 1
[ 746.130087] ======== PULL WL_REG_ON(-1) HIGH! ========
[ 746.133733] aml_wifi wifi: [extern_wifi_set_enable] WIFI Disable! 486
[ 746.340419] aml_wifi wifi: [extern_wifi_set_enable] WIFI Enable! 486
[ 746.846350] wifi_platform_bus_enumerate device present 1
[ 746.846395] ======== Card detection to detect SDIO card! ========
[ 746.852448] sdio_reset_comm():
[ 746.855677] meson-mmc: sdio: resp_timeout,vstat:0xa3ff2800,virqc:3fff
[ 746.862163] meson-mmc: sdio: err: wait for irq service, bus_fsm:0x8
[ 746.868569] meson-mmc: meson_mmc_irq_thread 2770 sdio: cmd:52
[ 746.874500] meson-mmc: sdio: resp_timeout,vstat:0xa3ff2800,virqc:3fff
[ 746.880964] meson-mmc: sdio: err: wait for irq service, bus_fsm:0x8
[ 746.887361] meson-mmc: meson_mmc_irq_thread 2770 sdio: cmd:52
[ 746.914122] meson-mmc: [sdio_reinit] finish
… …
[ 794.970690] failed to power up DHD generic adapter, 0 retry left
[ 794.986442] wifi_platform_set_power = 0
[ 794.986484] ======== PULL WL_REG_ON(-1) LOW! ========
[ 794.990440] aml_wifi wifi: [extern_wifi_set_enable] WIFI Disable! 486
[ 795.196712] wifi_platform_bus_enumerate device present 0
[ 795.196757] ======== Card detection to remove SDIO card! ========
[ 795.202819] aml_wifi wifi: [extern_wifi_set_enable] WIFI Disable! 486
[ 795.409668] failed to power up DHD generic adapter, max retry reached**
[ 795.410870] unregister wifi platform drivers
[ 795.415259] wifi_platform_bus_enumerate device present 0
[ 795.420761] ======== Card detection to remove SDIO card! ========
[ 795.426907] aml_wifi wifi: [extern_wifi_set_enable] WIFI Disable! 486
[ 795.633567] ======== dhd_wlan_deinit_plat_data ========
[ 795.633615] dhd_module_init: Failed to load the driver, try cnt 0
[ 795.639659] Error creating socket.
[ 795.643184] dhd_module_init: Failed to load driver max retry reached**
[ 795.649752] dhd_module_init: Exit err=-19

Thanks again!

Boring?? Nobody is stopping you from using the old version :wink:
We are using the khadas 4.9.206 kernel, 8723bs was only added to the staging drivers until kernel version 4.12.
So until we switch to the mainline kernel, which can take a while, there is not going to be any support for it.
(Unless you can convince Khadas to add the driver, as I have no time for that just now).
You will have to do with the onboard wifi & bt for the moment, it works fine.

Steven, I tried your setup with a Samsung TV.
Apart from an overscan issue (which can be corrected easily), it appears to work OK.
Did you install any other plugins installed, anything else?

Thanks!

New versions are out, covering the latest Volumio features (including Music Credits)

Hello everybody,

I’m new to the community, first of all thanks for delivering such a nice product.
Sorry if I make some noob questions, but I’m still getting familiar with the SBC world.

I have a Khads VIM3L and would love running Volumio on it. I made some reasearch, but I’m still not fully convinced that I understood what’s the best way to get this.
As far as I understood:

Option 1:

  • Install Android on the EMMC (currently I have CoreElec, but I think it doesn’t allow boot from SD correct?)
  • Burn the “VIM3” image from the first post of this thread into SD Card (it’s the same between VIM3 and VIM3L correct?)
  • Setup the VIM for booting from SD

Drawback is that it won’t automatically update, but there is a way around it with the “test mode”.
Not sure of the actual drawback in not having it on EMMC, can you help me understand?

Option 2:

  • Install the latest Krescue image from the Khadas forum to have Volumio directly on EMMC

The first post says that these images are not guaranteed to be in line with the latest “SD Card release” posted here, but at the same time it says that OTA would work.
Does that mean that after an update the 2 would become the same and I would get the actual latest release?

Again sorry if my questions are quite basic and thanks a lot for your help!!
Giulio

Hi,

Sorry for the late reply. I’ve been busy installing solar panels on our roof. It took more time then expected, as usual.

I’m using the ‘Radio Paradise’ plugin. And Tidal.
I just updated via OTA to your newest version (06 05), still the ‘Aw, Snap !’ is haunting me :smiley:

I’m going to try clean install now, and will keep this thread posted.

Greetings,
Steven

Any Khadas Kresc version plus OTA will get you the same version as the latest SD release.
In case you need to keep the eMMC contents, then booting from SD is the way to go, it just takes a few seconds more to load. During normal operation you will hardly notice the difference.

VIM3 is not VIM3L.

Thanks a lot, I think I have it clear now.

Based on what you said on the VIM3 vs VIM3L, I guess there is still no official Volumio release for VIM3L (nothing in the first post at least) and the Khadas Krescue seems the only option, so I’ll go with that.

Thanks again!

I install via krescue on VIM1 to EMMC this vrssion VIMx.Volumio.last.emmc.kresq
in options about update system ver 2.748
then I switch to dev mode and update to ver 2.766
but after reboot in seting I see ver 2.748

I have not tested the .kresq VIM1 images from @hyphop, therefore I can’t say what state that version is in.
Version 748 is very suspicious, as there where quite a few fixes afterwards.
In case Khadas has no newer version, I cannot guarantee the OTA will work.
Can you give me the download location, so I know which version to download?
Testing can take a little time due to other activities.

Meanwhile use the SD card version, it works.

dl.khadas.com/Firmware/Krescue/images/
I download krescue ve4sion from link

That is an old and unreleased Khadas test version.
We do not support it, sorry about that.

latest version for vim3 download not working…

sorry, can’t confirm that (verified to be sure), VIM3 boots fine here (same for VIM1 and VIM2).
Please test if you can boot any other image from SD.
If not, then this is a well known issue not related to Volumio.
Refer to the Khadas support board and make sure your eMMC has been initialised properly.
Note: you need Khadas “multiboot” on it

The links to volumio-2.774-2020-05-06-kvim3.img.zip and volumio-2.774-2020-05-06-kvim2.img.zip are seems to be broken
Getting “404 Not Found” error when trying to download it

Thanks for the warning, I’ll have a look.

Download links corrected!