Volumio 2 on Amlogic g02ref (AML8726-MX)

Hello,

I have an old Android TV Box based on the Amlogic g02ref customer platform with AML8726-MX SOC. Originally, I had it running LibreELEC (Kodi) which worked rather well given the low-specs of the device (Dual-Core, 1GB RAM).

I would like to repurpose this box as a dedicated audio player since it has a coax digital output which I could connect directly to my amp. With LibreELEC (Kodi), navigating through the audio files, web radio and Youtube streams proved to be a bit cumbersome and the only real way to do it is through a screen connected to the device. Kodi’s web interface is sluggish and sometimes freezes the device, and there are a lot of things you cannot access through it (such as Audio Settings).

I needed something to play music files off my DLNA server, Youtube streams and web radio - all controllable through a responsive web interface so the device can run headless. I decided to give Volumio a try.

So in case anyone else is interested, here it is: Volumio image for Amlogic g02ref devices (version 2.657)

Note that this build is by no means perfect, mainly due to the outdated kernel used (and the partially broken Amlogic m6 PCM driver that came with it). It is important that you check the README on the repo for an overview of what issues you might encounter:

https://github.com/patrickkfkan/volumio-platform-aml/tree/master/g02ref

So far it’s working well enough for me. I am using the coax digital audio output and have set Audio Resampling to 16-bit + Very High quality while keeping sampling rate “Native”. Most of my audio files are 44.1khz and 48khz, with the occasional 96khz and a few 192khz. Since I intend to run Volumio for 24/7, I’ll see how it goes in terms of stability.

The web interface is, by the way, snappy. Way snappier than Kodi’s :wink:

I have taken the liberty to fork the platform-aml repo started by @balbes150 and placed my g02ref platform files there. I should mention I learnt a lot from @balbes150’s builds for other Amlogic SOCs. Credits also go to those at the LibreELEC team for the Amlogic kernel, @emanuel4you for his g02ref kernel patches and @adilinden-oss for the OverlayFS kernel patch.

Well done!
Pity that this is “doomed” due to lack of support in a mainline kernel.
Kernel 3.10 is very old, I remember backporting overlayfs when I did the first version for the Harddkernel’s amlogic s805 based Odroid C1 years ago. But we still do regular updates for it, including myVolumio support.

Thanks for the compliment :wink:

At least the S805 is one gen ahead of the g02ref (Meson8 vs Meson6), so even with the same kernel version some things are supported better. But for S805 devices, we have hope they will one day be fully supported in mainline: http://linux-meson.com/doku.php (despite what they say, I don’t believe they will ever have full support for g02ref/Meson6 given the age of these things and the effort required to support them).

So far, I have been running my g02ref build 24/7 without additional issues other than those already mentioned in my github readme. I have since owned a couple of 176.4khz and 88.2khz FLACs which I couldn’t play with the onboard audio because of broken / incompatible Amlogic PCM drivers, so I am now using a cheap $5 USB to Digital Coaxial adapter for audio output. With this adapter, I don’t have to rely on the Amlogic drivers and I can resample those FLACs to 16-bit 48khz (which this adapter supports) for playback. Fortunately, I don’t have great ears and haven’t been able to distinguish the difference in sound quality :laughing:
IMAG2531s.jpg

Updated to Volumio 2.692 . CIFS support also added to kernel (couldn’t believe I left it out in the first place :astonished: )

I’m probably the only one using a g02ref device for Volumio :smiley: , but I’ll put it up here anyway in case someone finds it useful.

Download: Volumio2.692-2019-12-29-amlg02ref.img

do you have anything newer re. amlogic devices?

The only “newer” Amlogic device I have is a NanoPi K2, which was actually released 2+ years ago :laughing:

(btw, I tried to reply to your PM but couldn’t add you to recipients)

Hello Patrick.
Yesterday I found this post about running Volumio on Amlogic 8726-MX devices, something I was looking for. I have a Matricom G-Box Midnight MX2 with that SOC. I have flashed a SD card with your image and it worked on first try using the toothpick method, amazing.
I already using Balbes fork for S802 for lonh time with very good performance. But the s802 fork doesn’t have WIFI support, at least in my box. The MX fork is working perfectly using WIFI and Ethernet network connections.
I’m using SPDIF audio out to connect to a AV receiver.
I tested very few things, installed Spotify an Spotify Connect pluggin. First one worked withou issues. Second one doesn’t show on Spotify app on my cellphone. Maybe a pluggin issue.
The other issue that I found is that Airplay is not working. Apparently the sharepoint service doesn’t starting at boot time. I started it manually and my iPhone detected the volumio box, but i ran out of time to test if audio is being streamed.
Thank you!!

The AirPlay issue was described here:https://forum.volumio.org/airplay-not-autostarting-after-upgrading-692-t13521.html
Is present at Volumio 2.692.

Is there a way to make the box to boot directly from SD card without having to apply the toothpick method? I’ve been reading the Libreelec forum but dinidn’t figured it out. Thank you.

Hi chatosaf,

Thanks for pointing this out. Come to think of it, I actually haven’t tried Airplay since upgrading to 2.692 (it was working in 2.657 with my friend’s iPhone). I don’t own any Apple devices myself so the issue doesn’t really affect me, but it would be nice to see this fixed in the next Volumio release.

-Patrick

Do you have access to the serial console of your device? For my board I connected a UART adapter like this (wires soldered to the debug pins - I added a fan as well since the box runs rather hot for me :wink:):
aml8726mx-uart-1.jpg

If you have access to the serial console, it should be possible to configure u-boot so that it boots directly from SD card.

Ok Patrick, thanks for the information. I will investigate if it’s possible to apply the multi-boot procedure that is used on S802 boxes.
Also I will try to build a image based on previous version of volumio.

Great job, thank you!