Volumio 2: Gapless Playback Not working

I’m running Volumio 2.001 using HiFiBerry DAC Pro on a Raspberry Pi 3.

I seem to be unable to find the option for Gapless playback, and despite finding multiple posts which claim it’s working on Volumio 2.001, I’m not able to find any that point to a possible option or fix I missed.

File type is VBR MP3s, encoded with LAME. I did test that I get gapless in Foobar2000, so I’m fairly certain it’s not the files.

Any ideas? I’m comfortable working in command line if that helps troubleshoot.

It has been solved in the new versions, which are available to update if you use the dev procedure:
go to ip/dev

enable test mode

now update, you’ll see the new version

let me know if now gapless works (its enabled by default)


at my Raspi 3, with HiFiBerry DAC +, gapless works fine since Oct. 01… I had no Problems with Release2.001 at mp3 and FLAC Files.
At the moment i test the (Test) Release 2.021 and there it is the same. No Problems! If i want to be niggling, i find fault with mp3 micro intermission at the transition between two titles. With flac files I can´t hear any intermission.



Yes, the micro “intermission” is exactly what I’m referring too - Thank you for confirming the issue on an identical setup.

I’m updating to 2.031 now and will try it with mp3s again and report back.

Tested with v2.031 and the small break between the tracks is still there. I will try with FLAC as a test.

Any ideas of other settings to try?

Hello everybody,
I don’t see anything related to gapless in Volumio’s settings: where should it be?
Is it possible to customize the gap delay between tracks? Is it possible to fade a track, and directly start the next one without any gap, and even removing the silence at the end of a track? It would be nice in a party for example.
Thanks for your help
Config: Volumio 2.129 on RPI3

Gapless is enabled by default, the other things you’re asking might be added in a next release

Thanks a lot :slight_smile:

Volumio 2.129 on Rasp Pi B with HiFiBerry DAC+ card.
I seem to have a small gap between tracks, so I don’t have a gapless playback but a short ‘dead space’ between tracks.
Is this normal or should playback be completely seamless?
A little bizarre when tracks which have been mixed then have a pause introduced by Volumio.
Is this a known issue elsewhere?
Thanks in advance.