Volumio 2 beta + Hifiberry DAC+

Hi,

I have installed recently Volumio 2 beta 4 on my RPi 2 B with Hifiberry DAC+, but I cannot get it to work.

I have tried adding to /boot/config.txt

dtoverlay=hifiberry-dacplus
dtdebug=1

creating /etc/asound.conf file:

pcm.!default  {
 type hw card 0
}
ctl.!default {
 type hw card 0
}

My /etc/modules file contents are

snd_soc_hifiberry_dac

What am I doing wrong and what can I do to make it work?

Thanks for help in advance :slight_smile:

Same here, RC1. The software seems to recognize the card and set it up properly but all I’m getting is terrible static and noise when playing anything. My hunch is that the default RPi DAC (Card 0) is being used instead of the Hifiberry DAC+ (Card 1). Any tips would be appreciated!

Same with hifiberry digi+

Big white noise with HiFIBerry digi+ on coax and optic but sometimes it’s works …

Also only (something like) white noise with Volumio 2 RC1, RP 3 and Hifiberry Digi+ (optical).
Interestingly, startup sound without noise.

I am a noob with raspberry pi. I literally know nothing. I bought a hifiberry digi+ and raspberry pi3. I used hifiberry 's installer and its working except it does not recognize the built in wifi. I have to use an usb wifi adapter. The volumio interface in the last day (i have just used it for about 3 days) has been acting funny , i get on playback page -Playlist position NaN/undefined - where there is no info. The playlist page does not show any songs i add but if i add and play songs, the song would play but no info on both pages. I had been using firefox when this problem occurs. I just tried using chrome and everything works normally so far. By the way, when i turn off the raspberry do i just use the turn computer off tab on volumio and then unplug the pi3 or is there something else i should be doing?

I’ve got a similar problem, my dac+ is configured but it seem not working at all…

edit: I make a test with the native audio jack of my RP1 and it work better than in the 1.55 (the sound is not perfect but it work…)

HiFiBerry support team wrote me that that release is still using an old kernel. Volumio need to update the kernel to the current version.

What can we do ?
Wait for a new version ? When ?

nounouchet

Good question. I would like to try Volumio 2, but without DAC…

RPI3/Hifiberry DAC+ Pro

I can confirm the loud static noise seems to be fixed in kernel 4.1.21 as per my post here:

https://volumio.org/forum/loud-static-with-hifiberry-dac-t4204.html

Sound still switching hi to lo-fi every now and then. Interestingly, this was also happening with the Volumio 1.5 installer from Hifiberry. I think that was running the 4.1.19 kernel.

For me, kernel 4.1.19 produced the static noise on Volumio2.

My results thus far:
[] Volumio 1.5 (Hifiberry installer) @4.1.19: Channel swapping(?) or intermittent ‘lo-fi’
[
] Volumio 2 (build.sh) @4.1.19: Loud static noise
[] Volumio 2 (build.sh) @4.1.21: Intermittent ‘lo-fi’
[
] Volumio 2 (build.sh) @4.4.9: No sound issues yet. Mixer Control dropdown says ‘No Hardware Mixer Available’

To get Hifiberry DAC+ working on a raspberry pi 1 with volumio 2 RC1, you have to build a new kernel doing the following:

  1. ssh to the Pi

  2. Download the Raspberry Pi tools, configure environment and kernel:

  3. Configure and build kernel (this will take many hours):
    (For raspberry Pi 1 default build configuration)

    • cd linux
    • make bcmrpi_defconfig
    • make;make modules;sudo make modules_install
  4. Configure modules:
    (for hifiberry dac+)

    • sudo nano /boot/config.txt
    • dtoverlay=hifiberry-dacplus
  5. sudo shutdown -r now

  6. play some music!

Hope this helps.

Hi,

I have recompiled the new kernel and it boots fine, but I get just noise. I can select the HiFiberry DAC+ in the web interface, but it doesn’t seem to work correctly.

Any ideas?

Thanks!

I’m new to pi and Linux but I have some knowledge. My build for Volumio 2 is a Pi 3 with the HifiBerry DAC +.

I’ve created and booted the latest (856) build but it would hang on the crda register. I cntrl-c and ran the two lines from issue 266. Both ran and completed but now any boot results in:
Raspian GNU/Linux 8 volumio ttyl
volumio login:

If I login, it does the character logo and drops to a prompt. Wifi does not work.

Perfectly willing to re-download the image and start again but could use a bit of help. Once I install the 856 build - should I expect a working install?
How and where do I pause the load to give the wireless info? Could I pull the card and edit it to include the correct wifi info on one of my other machines?
Since the crda fix, it never attempts to register itself.
Any clues would be appreciated.

Interestingly enough, I built a second card since I was seeing errors on the card reader itself.

This card, with zero mods, but initially using a wired connection, logged in and worked right off the bat. I used the interface to connect to my wireless network and disconnected the ethernet.

Pointed it to my Synology NAS and after creating a user there, everything works perfect. My M-Audio speakers truly leave something to be desired and one might be dead, but all works now. Impressive.

Viagra Price Cialis Propecia Acquista Cialis Cephalexin Dog Eye Infection