Volumio 2 and Static IP Addresses

I would like a wireless static IP address for my portable Volumio 2 box. Changing the network options in the GUI does not work … Volumio 2 says configuration saved successfully, but when I look again at the network settings, we are back to automatic IP.

On my Volumio 1.5 box (different one), I have the static IP set by altering the /etc/network/interfaces file, but this doesn’t work for Volumio 2.

I know that Raspbian altered things last year so that the interfaces file contains the line ‘iface wlan0 inet manual’ rather than ‘iface wlan0 inet static’, and then the static IP address was sorted by the dhcpcd client configuration. However, Volumio doesn’t appear to be using this new client at all.

Anyone out there successfully using Volumio 2 with a static IP address?

Most routers have an option to always assign the same IP address to a device, based on it’s MAC code. (Look for Address Reservation in your router’s DHCP setup menu.)

It’s probably easier to do it that way than to edit /etc/network/interfaces.

Yes, I can do it on the home router, but this is for a portable device which may be on my home LAN, tethered to my phone in the car, or on any other network.


I have exactly the same issue. The RPI should be portable with a static ip.

edit: The Web Frontend doesn´t work. It doesn´t accept the netmask i need.

Has Anybody fixed this problem?

I have same problem and solved.
1.Log in Volumio by ssh such as putty.

2.edit interfaces file
sudo nano /etc/network/interfaces

#iface eth0 inet dhcp
iface eth0 inet static

3.edit resolve.conf
sudo nano /etc/resolv.conf


4.Reload network
sudo /etc/init.d/networking reload


That may well work for a wired connection (indeed it is the method i referred to in my first post that I use on Volumio 1.55), but it does not work for a wireless connection.

There are additional processes going on in networking/wpa_supplicant now, due to the newer versions of Raspbian (since about this time last year).

I am using a RPi Zero so there is no ethernet to use.