Volumio 2.915 on pi - Various issues/questions

Hi everyone

I used to have volumio running on cubox (i2 Ultra, running an old version - 2.417), but cubox recently died. Now trying volumio on pi.

Volumio Information

Volumio Version: v 2.909, updated to 2.915
Hardware: pi3, Ethernet connection through Airport Express
DAC: audiolab M-DAC (USB connected)

1/ Volumio needs reboot when DAC is turned off [SOLVED]
End of the day, I switch the DAC OFF, but leave the pi ON.
Next day, switching DAC ON, I cannot get (any kind of) music going unless volumio is rebooted.
Same behaviour noted with 2.909.
Solution by Evan ([How I can turning DAC on/off without rebooting Volumio - #9 by krutsch]) works for me to solve that issue.

2/ volumio iPhone app hangs
Connect with iOS app, and add an album to the queue.
Phone locks, as usual.
After some time of inactivity (e.g. towards end of album), phone app needs to be killed so that connection with volumio is re-established.
If phone app is not killed, volumio cannot be accessed (not possible to pause, skip track, no access to music library, etc.). It is a behaviour I didn t have min cubox.
Is that running as it should be on a pi?

3/ network issues suspected
Got a wireless dongle which used to work very fine on cubox. (Asus AC-56 or AC1200; 8812au drivers)
Plug it into pi, connect to wireless network, disable hotspot, reboot.
volumio does not restart.

Tried to disable on-board wireless chip as I used to do on cubox, by adding
blacklist brcmfmac to /etc/modprobe.d/fbdev-blacklist.conf
Same issue: volumio does not reboot.
Any suggestions?

Thanx a lot for feedback