volumio 2.201 : how to modify USB rights

i am using a raspberry pi model B with the latest stable of volumio v 2.201.
i want to be able to transfer music directly to my usb hdd mount (/mnt/USB/HDD) but i couldn’t make it working
what i don’t understand is that i can upload my files to /mnt/INTERNAL but not “into” USB/HDD/any folder.
here is the command i used to mount my hdd :
mkdir /mnt/USB/HDD
mount -t vfat /dev/sda1 /mnt/USB/HDD
ls -l gives me
ls -l /mnt/USB/
drwxr-xr-x 24 root root 32768 Jun 19 14:37 HDD

i tried to modify /etc/samba/smb.conf figuring that the problem came from there but il still doesn’t work :
netbios name = Volumio
server string = Volumio Audiophile Music Player
workgroup = WORKGROUP
security = user
map to guest = Bad User
encrypt passwords = yes
wins support = yes
local master = no
preferred master = no
os level = 30

[Internal Storage]
comment = Volumio Internal Music Folder
path = /data/INTERNAL
read only = no
guest ok = yes

comment = Volumio Internal Music Folder
path = /mnt/USB/HDD
public = yes
guest ok = yes
browseable = yes
writeable = yes
read only = no

i can’t get write even with the command
chmod 0777 /mnt/USB/HDD/subfolder
i don’t get any error but the job isn’t done : always in read only mode!

so please help me to find why i can’t upload my music directly to my usb mount.