Volumio 2.029 drops connection (Cubox-i4)

wired/ethernet, NAS as music source, all DHCP with reserved IP addresses,
network is known to be stable and fast

Volumio 2 replacing Volumio 1.5 on Cubox-i4Pro

Volumio 2 installs properly, but shortly after booting:

-ping results get erratic, from <1 ms to >150 ms, often connection gets lost entirely
-NAS library scan halts after a few 100 artists
-Web UI (Firefox on PC, wired) disconnects
–so far this happened only during library scan
–trying now to see if it disconnects too when just idling

I have exactly the same problem on volumio 2.029 and cubox-i4 pro. Web UI crashes, access with MPD client lost connexion when scaning or updating library.

The scan of the library crash after 200 artists, 90 albums, 1200 titles.
I have deleting all JPG in tags, cleaning the flac library but no effect.

Everything was working in volumio 1.5.

Cubox i4-Pro, USB HDD attached. Facing the same problems as already described by Pedro and Werner. Additional to that: I was not able to activate wireless LAN. Restarting the Cubox without USB HDD attached gives more stability. Changes can be made in the menu and saved without any problem but with HDD attached a lot of instability and time-outs and so no ability to change any menu entries.

yes, there is a known problem with cubox wifi on the kernel version we use.
This will be taken care off next week I hope, still waiting for my SolidRun parcel.

Volumio 1.55 is different in many ways, it is a complete solution re-write and uses the 4.4.7 kernel (which could actually be the source of the listed problems).
In case the network problems persist, I will consider reverting to the stable 3.x.x kernel and backport the necessary changes in order to get Volumio to work.

Groeten :slight_smile:

just to give more feedback - for some reason I have this working ok, although with Cubox-i2eX:

  • V 2.029
  • Synology NAS via NFS
  • WLAN not activated, only LAN, as this is a known bug (system doesn’t even start up with WLAN activated)
  • 548 albums / 7579 tracks indexed within a few minutes
  • there seems to be something wrong with DNS-resolution as hostnames cannot be mounted, IP-adress for NAS worked fine

EDIT: actually I might have to correct myself - Indexing is still ok, but I am experiencing extensive audio dropouts of about 15s or more when playing Flac-files. When that occurs, also, the My Music dialogue is empty and only shows the two empty tables for ‘My Music’ and ‘Network Drives’.

The new Volumio 2 looks awesome!

Unfortunately, I can confirm this behavior on my rig:

Volumio 2.029
Cubox i4
Ethernet connection (did not try to set up wifi, but it doesn’t appear to be working)
Synology NAS DS 214 play

I’ve had this setup working fine on Volumio 1.5 for more than a year.

My device locks up every time I try to run the first scan of a new library mount - it stops responding to ping, ssh connections become unresponsive as does the web UI. I can play back web radio just fine.

I’ve tried NFS and CIFS mounts, did a number of configuration options on the NAS and/or the Cubox but none worked.

(Edit 11/21 - I can get both NFS and CIFS mounts to work and see the disk, but none of the different configurations I tried fixed the crashing problem on trying to scan the library.)

It seems to be able to stay up, if I leave it alone - so long as I don’t do the scan, it remains responsive for a while.

Great to see volumio 2 released for cubox

Syno 212+, NFS share
cubox-i2 ultra with volumio 2.029
Usb hub
Audiolab MDAC

Mounting NFS: no issue
Index library first attempt: same issue as other on first scan (up to 142 artists and then crash).
Index library second attempt: just clicked rescan after cubox came up and OK (>15k tracks)
Webradio: OK
Audio dropouts: none. I used to have, but since I put the hub (powered hub) in between the cubox and the NAS, no issue at all.
(for info, I had to add the hub for previous volumio, as well as for any release of archphile)

Missing from volumio for cubox: Kernel headers to get a wifi dongle driver (rt8812au) compiled (or best, have the driver included in the image :slight_smile: )

Overall, very good for me, just that one glitch at first scan library.

Internal wifi will be seen to soon, I will also add the rtl8812 driver when supported.
Regarding linux headers there might be something new coming up, I need to check this with Michelangelo, otherwise I will add them.


Update:I left my Cubox up playing a web radio stream - seems to be stable 24 hours later.

Whatever is going on in the current release, it seems to be isolated to accessing network storage.

Unfortunately, without an ability to scan the library without a hard crash, it makes volumio unusable for its core task of playing back my music library.

Any ideas about an ETA for a fix to address this?

Yes, this makes Volumio 2 useless.

To add insult to injury, iOS 10.1.1 just broke the Volumio 1.5 WebUI


Si I am essentially without music.


The issue seems to be for more devices, I got an Odroid C2 and have exactly the same issue as reported on this thread :

After a couple indexing (around 100 artists) the process halts and volumio restart. I posted the log on the other thread.

Hope to get this solved soon as I miss listening to music :frowning:

Yes, we have seen the reports and are working on it.

Cross posting a response from a file server mount issue thread here, as it may be related? Original thread here:


Big thanks to the development team for this new release of Volumio it seems promising.
Unfortunately it is not stable at the moment with Cubox-i.
I confirm that i’m also facing the networks issues reported in this thread and i’m looking forward a solution to switch to Volumio 2 with my little Cubox-i.
Is there any update regarding this issue ?


Same for me. I have a Cubox-i4pro. Volumio 1.5 works with no issue. I have a 256G usb thumb drive attached to the cube and outputs on usb to dac.

For Volumio 2 it does not work. I very quickly loses sight of the tracks and then it hangs and goes into a fix screen with activity (“circling”).

Hope it gets fixed soon. For now I have reverted to Volumio 1.5.

Thank you.