Volumio 1.55 Raspberry 2 model b crashes

I’m having some serious problems running Volumio on Raspberry. After startup with no USB devices connected, only HDMI, LAN and miniUSB wired, the system crashes after couple of minutes. I manage to play a minute or so some music from Spotify and then music stops and after a while Rasb crashes with the attached messages. The same hapens if I hook a USB stick and try to play music from it. I’m thinking that I might have a faulty Raspberry? I’ve tried three different microSD cards and the image is downloaded from Volumio.org page. Any help would be greatly appreciated!

Edit: I have also tried two different USB power supplies with 5 V / 2 A ratings, without success. Could the problem be with the laptop PC’s (Lenovo Thinkpad T440s) SD card reader that I’m usig to create Volumio image files?

Have you tried to use an other distribution? Does it crash like volumio? Then the problem would most likely be either a faulty pi, or SD writer but the 2nd sounds improbable to me. Worth checking though.

Yes, I tried Rune Audio and XBMC. Both of them didn’t even boot up. So after these experiences I sent the Rasp back to the store I bought it from for replacement. Just a day after that I bumped into this site: http://elinux.org/RPi_SD_cards and found out that my brand new Kingston SDC10G2/16GB SDHC card is not supported by Raspberry pi. There’s quite A long list of not compatible Kingston SDHCs, so it might be that all the other cards - being Kingstons too - I tried were unsupported. I had absolutely no idea that Rapberries are so nitpicky about the memory cards they swallow!