Volumio 1.55 NFS mount points

I have Volumio 1.4 running with NFS mounts. I found this worked better in my system.

I have A Rasberry Pi B+ plus IQAudio Dac + which I haven’t managed to get working satisfactorily.

I’ve loaded Volumio 1.55 and set about configuring it.

When I tried to create an NFS mount, I saw an error the the mount point didn’t exist, now when I try to go back, after a reboot, the Library menu does not respond at all.

[Edit] The error is “mount.nfs: mount point /mnt/NAS/Classical does not exist”. Since Classical is what I wanted the library to be called, it seems to be that the mount point simply hasn’t been created for some reason.

I’ve tried switching to CIFS/SMB and deleting the mount but that doesn’t work - I’m guessing because in both cases it is trying to delete a non-existent mount point.

I have fixed this.

Start telnet session and login
cd /mnt
ls reveals only UPNP and USB directories
mkdir NAS
chmod 777 NAS

Now I can create nfs mounts.

Had this same issue for my NFS mounts. Thanks for the post.

What did you SSH in as? root or pi?

There is already a NAS folder on mine but the owner is pi

Dang in hell! Tks Terry.

The Dev must have forgotten to make the directory!

@Jerry
ssh in as pi with password raspberry, then “sudo su” will take you straight into root mode wihtout asking for a password. chmod 777 will set full permissions to all so no need to change the owner of the directory.

T