Volumio 1.55 for Raspberry Pi & Raspberry Pi 2

Here it is!
It is compatible with every little Pi out there, while keeping compatibility with i2s DACs.

Download at:
sourceforge.net/projects/volumio … p/download


  • Compatible with Raspberry Pi, Rasbperry Pi B+ and Raspberry PI 2
  • I2s DAC compatibility with Raspberry PI 2 (Hifiberry Dac Plus, IqAudio Dac Plus and others)
  • Better Spotify handling: new Spop daemon version and search by Name or Artist
  • USB DAC hotplugging is now supported
  • USB Storage can be used on the fly, and you’re not required to reboot any more

Please give your feedbacks, as there’s a whole new kernel inside!

Works beautifully on the Pi2!

I bought the Pi2 when announced and hoped to load Volumio to act as a media streamer to my DAC. But was very disappointed when I discovered the Pi2 was not yet supported, even more-so when I had to use Kodi as a substitute (which does not do any favours for HiFi).

So I was elated when I noticed the new build pop up Thursday. I’m still trying to figure everything out, but so far so good. Job well done, sir.

EDIT: Actually, I now realize I’m running the 1.51PI2 build! I’ll update and share my findings when I get home :slight_smile:.

Not working here (RPI 2 + USB Logilink UA0099). I can connect to Nas but the Database could not be upgraded. Everytime I try to change something via Webui, the WebUi crashes.

Many thanks for getting Volumio working on the Raspberry Pi 2 so quickly. To get everything up and running less than a week after the hardware was released is truly astonishing! It works brilliantly on my newly acquired Pi 2 and sounds great (I am using the HiFiBerry DAC+ with my music on a usb stick plugged into the Pi 2).

Great! Really happy to hear that!

Up and running within 10 minutes using a DIGI+ with optical output to my Audio Aero Capitole CDP/DAC. Only tried a USB stick but will connect the NAS up later.

Many thanks Michelangelo, great work to get it working so quickly.

  • Nervously awaiting information whether 24/192 USB audio works without glitches :open_mouth: *

Can we use the system updating of Volumio 1.5.1 to migrate from 1.5.1-> 1.5.5?

Kind of the same question here, but when updating from version 1.5
I just tried it and it (now?) says “release version: 1.55” in volumio.local/credits.php so I guess I succeeded?

Unfortunately the update function doesn’t work for this version. The spotify fixes needs more deep system tweaks that cannot be applied via update system.
However, if you don’t use spotify you can safely upgrade the system via the update function…

Fantastic ! My main concern was about hotplug : it was difficult to explain to every member of the family in which order we have to switch on the things : too technical, they just complain ! Now with hotplug dac and hotplug usb key, this will be very easy. Thanks a lot !

What mpd version is there in ?

I had the same problem with an unresponsive crashing UI.
It was solved by downloading the Sourceforge file (previously used the Volumio page torrent link I guess the torrent was corrupted ) and reinstalling to sd card.
Works great now ! :smiley: (Pi B )

Interested to know if your file was from torrent or direct ?

Could others confirm that the torrent download is corrupted?
Checking md5…

My volumio version recently updated itself from version 1.52 to 1.55. The new spotify search for albums and/or artists works like a charm.
What exactly won’t work without a clean 1.55 image installation?

Best regards

The Spotify configuration script. So if you’ve already configured spotify, you’ll not be affected by the problem…

I’ve updated to the 1.55 build and I’m experiencing something similar. It can mount the location fine, but my library doesn’t get rebuilt. Whenever I turn on/off my DAC, the Pi crashes (volumio.local (and IP) do not respond, times out). Shame, as I foolishly deleted the working 1.51pi2 build and can’t download it again anymore :frowning:.

Synology DS415play (NFS share) <-> Pi2 /w Volumio 1.55 <-> Rotel RA-1570

Did you guys use the update function or downloaded a fresh image?

If you updated, try to install samba and cifs-utils

I downloaded the fresh image.

Thanks for Volumio and all the work you put into the project!

RPI 2 + USB Schiit Modi; After Volumio crackled itself through the startup sound it has left me with a big Silencio.
Any suggestions, someone?

Hi, michelangelo

I had installed the 1.55 volumio and could hear the Es9018 sound via I2S connection,
but my 16/44.1 wav , alac and flac files were noisy, other bit/Freq combination are OK!
so could you tell me the solution for it?