Volumio 1.5 plays high resolution files at "warp" speed

Hi Everybody,
this is the problem:

Configuration: Raspberry Pi model B. Dac Audiophonics I-Sabre DAC ES9023 Raspberry Pi / I2S. Volumio 1.5. Flac stored in a NAS with Openmediavault.

With Volumio 1.4 High resolution files (192kHz, 88kHz …) are played perfectly.
With version 1.5 such files are played at unusual speed, as you can hear in the example attacched.

The DAC is configured as “Hifiberry” (in 1.4 it’s ok).

Thank’s alot.

Voce 010.zip (331 KB)

maybe you must install volumio 1.51 (http://volumio.org/forum/testing-needed-for-i2s-dacs-t1958.html)

Thank You.
I will try and let You know if it works.


Hi !
I 've got same raspberry and dac than you. With Volumio 1.5 it works, but please let us know if you 've got a slight crackling sound when playing 16bits 44khz file . It start as soon as you press play buton. With higher resolution it’s ok.
Thanks you.

Hi to everybody,
I’ve tryed kernel upgrade and 1.51 installation. Now all it’s fine. No more warp speed!

16 - 44.1 fine
24 - 44.1 fine
24 - 48 fine
24 - 88.2 fine
24 - 96 fine
24 - 192 fine

For Balbuze: no ckackling sound when starting playback of 16-44.1 files. Pleas let me know if You need more tests. I’ll be glad to contribute.

Thank You!


I’ve got a Raspi B+ with Hifiberry+ and Volumio 1.51.

Got the same issue as well + playback GUI obviously irritated as well. Only hires flacs, everything else works fine. I considered network problems, however, same problem with usb stick. Thanks for any hint in advance!

Just by the way, if I add a logitech wireless keyboard via usb, wifi-stick won’t work.


Could please test a file I’ll give you ? This file contains no music, only silence… :astonished: . But in my case with the dac ess9023 from audiophonics, I hear a crckling sound. With Volumio 1.4 it’s ok.
The link for the file : demo.ovh.eu/fr/7528f14db49750019b27abbd58eace54/
Let me know !
Thanks !

I’m getting the same problem. I have Pi B plus Hifiberry and Pi B+ plus IQaudio. Not sure that it was because I didn’t play hires files at first but the problem appeared to start.

I’m now going to try 1.51 on both.

I tried the update to the B+ box. That didn’t work.
I’ve updated B/Hifiberry and B+/IQAudio boxes.

The B/Hifiberry box now has problems attaching to my NAS drive.
The B+/IQAudio plays hires files.


I’ve tryed your sample file. Result: absolut silence. No crackling or other sounds.
Hope this is useful for You.
This is the DAC: audiophonics.fr/en/kits-modu … -8962.html

Please let me know if You need further tests.

Best regards,

Thanks for the test!
Which setting do you use for volume control? No news of feared hardware ? Could you try with software ?
My DAC is not the same than yours audiophonics.fr/en/kits-modu … -8396.html

@ balbuze
My mixer setting is “disabled”. I’ve tryed also “software” and with this setting I can hear a veeeery low white noise only if volume is not set to 100% (at this level, no noise), slightly increasing when I decrease volume.

Hope this helps.


I my case I use software volume as I use directly an amp without pre amp. So I set volume near 50 or less. That’s strange but it appears with Volumio 1.5 and 1.51, and with 16b 44khz…
Is there a change in mpd settings ? Or is it a problem with drivers ? Don’t know.,
To be followed…

Hi again,

since my last post and due to Christmas vacation I could spend some (!) time on trying to get my Raspi B+, Hifiberry+ and Volumio 1.51 (most recent versions in each case) to play high resolution audio files. I decided for that combination since it seem to be the most common one…

The issue: 24bit 192khz flac are played in a fast forward mode sounding distorted.
Most interesting the playback view claims file to be “Stereo - 24 bit - 88.2 kHz”.
so, maybe wrong frequenzy detected is the core issue… but by what?

@balbuze: unfortunately the link to your test file seems to be be invalid, so I could not try that.

So, after studying other peoples stuff on quite the same issue I tried e.g. downgrading the kernel, which seems to have work in the past and partially. This lead to nothing being played anymore.

So, nearly (see my post on webradio as well) everything quite fine. Execpt hires audio!

Any help or hint appreciated!