Volumio 1.5 on Cubieboard: upgrade or not upgrade

After the boos as a preliminary setup activity I tried the usual “apt-get update” and “apt-get upgrade”.
The prompt of the latter shows that about 300 packages are out of date.
I quitted the command, but the question is now: should I update or not?



Simple answer: no
More detailed one: update only if you know how to restore proper settings of php-fpm, nginx and mpd.

Let me know

I think there is a problem in /etc/apt/sources.list.

deb http://http.debian.net/debian jessie main non-free deb-src http://http.debian.net/debian wheezy main non-free
This means that the reference Debian distribution used by apt-get is Jessie, whilst it seems that Volumio is built on previuos distribution i.e. Wheezy. This causes the request to upgrade over 300 packages.

I tried to upgrade and fortunately apt-get is savvy enough to keep back many packages:

The following packages have been kept back: base-passwd bind9-host bsdutils dbus dmsetup init-system-helpers initscripts iproute iptables iputils-ping isc-dhcp-client isc-dhcp-common libbind9-90 libdevmapper1.02.1 libhtml-parser-perl libio-socket-ssl-perl libisc95 libisccfg90 liblocale-gettext-perl liblwres90 libnet-ssleay-perl libpam-modules libpam-modules-bin libpam0g libpulse0 libsasl2-2 libsemanage-common libsemanage1 libsocket6-perl libssh2-1 libtext-charwidth-perl libtext-iconv-perl libusb-1.0-0 libva1 libxslt1.1 login minidlna mount mpd nginx nginx-common nginx-full ntfs-3g openssh-client openssh-server passwd perl perl-base perl-modules php-apc php5 php5-cli php5-common php5-curl php5-fpm php5-sqlite procps sudo sysv-rc sysvinit sysvinit-utils udev util-linux wget zd1211-firmware 0 upgraded, 0 newly installed, 0 to remove and 65 not upgraded.
It however updates many others packages (about 250) which are mainly libraries.

The net result is that, surprisingly, everything seems to work: the web interface works perfectly and the music flows from the speakers.
I also upgraded the kernel to the 3.4.105 version, taken from the Igor Pecovnik’s site.



I have a similar problem on Raspberry Pi after update and upgrade, with this sources.list:

deb http://repo.volumio.org/apt/ jessie main contrib non-free rpi
deb http://mirrordirector.raspbian.org/raspbian/ jessie main non-free rpi
deb-src http://mirrordirector.raspbian.org/raspbian/ wheezy main non-free rpi

because I was trying to install the python md module. Now, the WI does not work any more.

Some questions:
I was also wondering about the entries referencing Jessie and Wheezy in sources.list. Is that intentional? Why?

Can you elaborate a bit more what happened with the update, and how it can be fixed? Configurations of nginx, mpd and php-fpm were mentioned, why haven’t the the configs not been saved by the update process?

Can the system be resurrected?

Thanks for the great work otherwise :slight_smile:

The easiest, fastest way to fix the system is reflash the SD card.
Upgrades to volumio via apt-get isn’t supported, writing an how to resurrect after apt-get upgrade etc. takes a lot of time, time that is used for bug fixes and features for volumio.

What you could try, after reflashing the SD, is to change jessie into wheezy. I did try this once and the upgrades didn’t affect the installation, but be sure to keep current when asked.