Volumio 1.4 w Cubox-i - mount USB


My portable USB drive is formatted as Mac OS Extended (Journaled). When I connect it to the USB of cubox-i running Volumio 1.4, the drive will start and stop repeatedly. Do I need to reformat the drive to another format before it can be used?

Thank you.

Needs to be FAT32 or NTFS drive. I formatted mine to fat32. Works for a little while and then it has never worked again. When I connect the external usb drive with music files inside, volume cannot see the drive under “Browse”. I can only see Webradio. If I do a library/update mod database, under “Browse” RamPlay, UPNP, NAS and USB will be shown besides webradio. But the USB folder will be empty. It cannot see my files. Same with a thumdrive in the usb port. I even tried to reflash Volumio in the micro SD card. To no avail.

So now I use Volumio as a webradio only, as I can’t get it to mount my NAS. And Volumio also isn’t able to see my usb thumb drive or usb external drive. Bumber :slight_smile:

Works now. What I did is I swap the cubox-i usb connections between the usb external drive and the usb connect to the dac. And volumio can see my files in the usb hard disk. Great. Sounds wonderful! However, it stops playing a song after 1 min 15 s. Consistently. I do not know why. Test again tomorrow.

Even when formatted to Fat32, Volumio can’t play music from my Western Digital Portable 500G Harddisk well. Music stops before 1 min 15 s. Now I am playing from a usb thumb drive instead. No problem at all.

does your USB have dedicated power or is it plugged into a power USB hub?

You are absolutely right. I realized it is not Volumio. It is Cubox-i4pro’s USB port could not supply enough current to the WD 500G portable drive to start it up properly. I use a Y cable and put in more current to the usb portable drive and it works with Volumio on Cubox with no problem.

So it is a hardware issue I faced. Not software.