Volumio 1.4 on Pi - busy when entering WebUI

First things first:
I started with Volumio on Pi v1.2beta (very happy with it) and recently upgraded to 1.4.

I welcome most of the enhancements but some the behaviour is different and makes me consider to go back to 1.2beta.

Environment: RasPi with Hifiberry DAC, music files accessed by CIFS share on NAS (>10k files)

Since 1.4, every time I enter the WebUI (first access to the WebUI after starting the browser), the playlist and browse tab only shows an empty page for first 10 to 15 sec. After that everything (except the library tab, of course) works as expected.

On the system I can see the process www-data ... php-fpm: pool db consuming approx. 80% CPU time for the amout of time mentioned above. Is the library function responsible for that?

Is there an easy way to disable the library function?

Thanks in advance!

I have just noticed that this topic is already discussed in “suggest a new feature” and michelangelo is working on a less consuming library .js and/or a library function switch.

Nevertheless, I would keep this thread open for now.

This evening I had some time to look into it.

As I am actually happy with v1.4 but just annoyed by the delay created by the library initial load everytime I access the WebUI - here a workaround until michelangelo has made it less resouce consuming or inserts an ON/OFF switch:

remove the following lines in file /var/www/js/scripts-playback.js

    $.post('db/?cmd=loadlib', {}, function(data) {
    }, 'json');

That’s it. You still see the library tab, but without function. The patient ones could change the other files as well to make it disappear completely.